LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2004, 03:14 PM   #1
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Rep: Reputation: 0
ATI drivers not working on Xfree86 4.3 with Radeon 9600 xt


I am new to linux and running suse 9.0 and im trying to get the 3d acceleration to work on my ATI Radeon 9600 XT.
I did everything the ati site said to do. i downloaded the check.sh ran it and saw i am running 4.3.1. so i downloaded the 4.3.0 driver and installed it.

linux:/home/elf-assassin # rpm -Uh --force fglrx-4.3.0-3.9.0.i386.rpm
########################################### [100%]
########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.21-215-default/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
done.
/sbin/ldconfig: File /usr/X11R6/lib/FGL.renamed.libGL.so.1.2 is too small, not checked.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now

then i ran the fglrxconfig and answered all the questions right...then when it was finished i ran the fglrxinfo and it still is runnin mesa not ATI..
Please Help
 
Old 05-31-2004, 07:55 PM   #2
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
I don't run SUSE but don't they have special rpms for the install?
If not I'll help ya get it up and running.
L8tr
 
Old 05-31-2004, 10:40 PM   #3
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
that what i placed in my thread...thats the output i got from running the rpm in the konsole the way i said to in the instructions on the ati site. And after the whole setup its still not working so if you can help or tell me why thats would be great Feend
 
Old 06-01-2004, 12:32 PM   #4
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
Please post output of dmesg, and the build log of the driver in /lib/modules/fglrx/build_mod/
remember that you have to install the driver w/ run level 3 (no xserver). I used the 3.2.8drivers as the others are poop. I have not used the newest one 3.9.0you may want to try it ?
CU Soon
L8tr
Feend
 
Old 06-03-2004, 11:30 AM   #5
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
here is the output of 'dmesg' i dont know what you want from /lib/modlues/fglrx/build_mod/

jason@Arkadian:~> dmesg
Linux version 2.4.21-144-default (root@i386.suse.de) (gcc version 3.3.1 (SuSE Linux)) #1 Fri Nov 14 00:01:36 UTC 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
501MB vmalloc/ioremap area available.
0MB HIGHMEM available.
511MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 131056
zone(0): 4096 pages.
zone(1): 126960 pages.
zone(2): 0 pages.
ACPI: RSDP (v000 PT800 ) @ 0x000f71d0
ACPI: RSDT (v001 PT800 AWRDACPI 16944.11825) @ 0x1fff3000
ACPI: FADT (v001 PT800 AWRDACPI 16944.11825) @ 0x1fff3040
ACPI: MADT (v001 PT800 AWRDACPI 16944.11825) @ 0x1fff7ec0
ACPI: DSDT (v001 PT800 AWRDACPI 00000.04096) @ 0x00000000
ACPI: Skipping APIC setup
Building zonelist for node : 0
Kernel command line: root=/dev/hda6 vga=0x31a desktop splash=silent
bootsplash: silent mode.
Initializing CPU#0
Detected 2828.802 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 5570.56 BogoMIPS
Memory: 514356k/524224k available (1579k kernel code, 9480k reserved, 605k data, 160k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 128K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: bfebfbff 00000000 00000000 00000000
CPU: Common caps: bfebfbff 00000000 00000000 00000000
CPU: Intel(R) Celeron(R) CPU 2.80GHz stepping 09
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20030619
PCI: PCI BIOS revision 2.10 entry at 0xfb370, last bus=1
PCI: Using configuration type 1
Looking for DSDT in initrd ... not found!
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: System [ACPI] (supports S0 S1 S4 S5)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 6 7 10 *11 12)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 6 7 *10 11 12)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 6 7 10 11 12)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 6 7 10 11 12)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 6 7 10 11 12)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 6 7 10 11 12)
ACPI: PCI Interrupt Link [LNK0] (IRQs 3 4 6 7 10 11 12)
ACPI: PCI Interrupt Link [LNK1] (IRQs 3 4 6 7 10 11 12)
ACPI: PCI Interrupt Link [ALKA] (IRQs 20)
ACPI: PCI Interrupt Link [ALKB] (IRQs 21)
ACPI: PCI Interrupt Link [ALKC] (IRQs 22)
ACPI: PCI Interrupt Link [ALKD] (IRQs 23)
PCI: Probing PCI hardware
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
00:00:08[A] -> IRQ 10 Mode 1 Trigger 1
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
00:00:08[B] -> IRQ 5 Mode 1 Trigger 1
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
00:00:08[C] -> IRQ 11 Mode 1 Trigger 1
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
PIC: IRQ (11) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (11) already programmed
PIC: IRQ (10) already programmed
PIC: IRQ (5) already programmed
PIC: IRQ (11) already programmed
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
apm: overridden by ACPI.
Starting kswapd
bigpage subsystem: allocated 0 bigpages (=0MB).
kinoded started
VFS: Disk quotas vdquot_6.5.1
aio_setup: num_physpages = 32764
aio_setup: sizeof(struct page) = 48
vesafb: framebuffer at 0xd8000000, mapped to 0xe0818000, size 16384k
vesafb: mode is 1280x1024x16, linelength=2560, pages=5
vesafb: protected mode interface info at c000:5820
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
bootsplash 3.0.9-2003/09/08: looking for picture.... silenjpeg size 30981 bytes, found (1280x1024, 15663 bytes, v3).
bootsplash: silent jpeg found.
bootsplash: silent jpeg found.
Console: switching to colour frame buffer device 148x51
fb0: VESA VGA frame buffer device
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 64000K size 1024 blocksize
loop: loaded (max 16 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 00:0f.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt8237 (rev 00) IDE UDMA133 controller on pci00:0f.1
ide0: BM-DMA at 0xc800-0xc807, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0xc808-0xc80f, BIOS settings: hdcMA, hddio
hda: WDC WD1200BB-00DWA0, ATA DISK drive
blk: queue c03bc8e0, I/O limit 4095Mb (mask 0xffffffff)
hdc: LITEON DVD-ROM LTD163, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
ide-floppy driver 0.99.newide
Partition check:
hda: hda1 hda2 < hda5 hda6 >
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
cryptoapi: loaded
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 374k freed
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
libata version 0.71 loaded.
sata_via version 0.10
ata1: SATA max UDMA/133 cmd 0xB000 ctl 0xB402 bmdma 0xC000 irq 10
ata2: SATA max UDMA/133 cmd 0xB800 ctl 0xBC02 bmdma 0xC008 irq 10
ATA: abnormal status 0x7F on port 0xB007
ata1: thread exiting
ATA: abnormal status 0x7F on port 0xB807
ata2: thread exiting
scsi0 : sata_via
scsi1 : sata_via
reiserfs: found format "3.6" with standard journal
reiserfs: enabling write barrier flush mode
reiserfs: using ordered data mode
reiserfs: checking transaction log (device ide0(3,6)) ...
for (ide0(3,6))
Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Trying to move old root to /initrd ... failed
Unmounting old root
Trying to free ramdisk memory ... okay
Freeing unused kernel memory: 160k freed
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
Adding Swap: 506008k swap-space (priority 42)
reiserfs: enabling write barrier flush mode
reiserfs: enabling write barrier flush mode
via-rhine.c:v1.10-LK1.1.17 March-1-2003 Written by Donald Becker
http://www.scyld.com/network/via-rhine.html
eth0: VIA VT6102 Rhine-II at 0xe000, 00:30:18:82:03:0e, IRQ 11.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
eth0: Setting full-duplex based on MII #1 link partner capability of 45e1.
raw1394: /dev/raw1394 device initialized
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
ehci_hcd 00:10.4: VIA Technologies, Inc. USB 2.0
ehci_hcd 00:10.4: irq 5, pci mem e18d9000
usb.c: new USB bus registered, assigned bus number 1
ehci_hcd 00:10.4: USB 2.0 enabled, EHCI 1.00, driver 2003-Jun-19/2.4
hub.c: USB hub found
hub.c: 8 ports detected
usb-uhci.c: $Revision: 1.275 $ time 00:40:37 Nov 14 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xcc00, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xd000, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 3
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xd400, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 4
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xd800, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 5
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
uhci.c: USB Universal Host Controller Interface driver v1.1
mice: PS/2 mouse device common for all mice
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SLPB]
ACPI: Fan [FAN] (on)
via82xx: Assuming DXS channels with 48k fixed sample rate.
Please try dxs_support=1 option and report if it works on your machine.
PCI: Setting latency timer of device 00:11.5 to 64
ACPI: Processor [CPU0] (supports C1)
ACPI: Processor [CPU1] (supports C1)
IPsec Security Association Database (SADB): initialized.
IPsec Security Policy Database (SPD): initialized.
IPsec PF_KEY V2: initialized
ACPI: Thermal Zone [THRM] (43 C)
IPv6 v0.8 (usagi-cvs/IPsec6 based StS) for NET4.0
IPv6 over IPv4 tunneling driver
i8253 count too high! resetting..
bootsplash: silent jpeg found.
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: irq 7 detected
lp0: using parport0 (polling).
usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
mtrr: 0xd8000000,0x8000000 overlaps existing 0xd8000000,0x1000000
Linux video capture interface: v1.00
eth0: no IPv6 routers present
ide-floppy driver 0.99.newide
hdc: attached ide-cdrom driver.
hdc: ATAPI 48X DVD-ROM drive, 512kB Cache
Uniform CD-ROM driver Revision: 3.12
mtrr: 0xd8000000,0x8000000 overlaps existing 0xd8000000,0x1000000
hub.c: new USB device 00:10.0-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x4b0/0x10e) is not claimed by any active driver.
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi2 : SCSI emulation for USB Mass Storage devices
Vendor: NIKON Model: NIKON DSC E4300 Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi2, channel 0, id 0, lun 0
SCSI device sda: 31232 512-byte hdwr sectors (16 MB)
sda: Write Protect is off
sda: sda1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
USB Mass Storage support registered.
usb.c: USB disconnect on device 00:10.0-2 address 2
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Info fld=0xa00 (nonstd), Current sd00:00: sense key Not Ready
sda : block size assumed to be 512 bytes, disk size 1GB.
sda: test WP failed, assume Write Enabled
sda: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 2097144
I/O error: dev 08:00, sector 2097144
I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
I/O error: dev 08:00, sector 0
[fglrx] Maximum main memory to use for locked dma buffers: 430 MBytes.
[fglrx] module loaded - fglrx 3.9.0 [May 11 2004] on minor 0
[fglrx] module unloaded - fglrx 3.9.0 [May 11 2004] on minor 0
[fglrx] Maximum main memory to use for locked dma buffers: 430 MBytes.
[fglrx] module loaded - fglrx 3.9.0 [May 11 2004] on minor 0
[fglrx] module unloaded - fglrx 3.9.0 [May 11 2004] on minor 0
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
ALSA via82xx.c:704: invalid via82xx_cur_ptr, using last valid pointer
[fglrx] Maximum main memory to use for locked dma buffers: 430 MBytes.
[fglrx] module loaded - fglrx 3.9.0 [May 11 2004] on minor 0
mtrr: 0xd8000000,0x8000000 overlaps existing 0xd8000000,0x1000000
[fglrx:firegl_addmap] *ERROR* mtrr allocation failed (-22)
[fglrx:firegl_unlock] *ERROR* Process 10249 using kernel context 0
 
Old 06-03-2004, 12:14 PM   #6
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
The file: /lib/modules/fglrx/build_mod/make.log will have the errors if any in the build. It is the best bet for any info on why your module is not working. Please post
L8tr
Feend
 
Old 06-08-2004, 11:15 AM   #7
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
ATI module generator V 2.0
==========================
initializing...
build_date =Sat Jun 5 01:21:18 EDT 2004
uname -a =Linux arkadian 2.4.21-99-default #1 Wed Sep 24 13:30:51 UTC 2003 i686 i686 i386 GNU/Linux
uname -s =Linux
uname -m =i686
uname -r =2.4.21-99-default
uname -v =#1 Wed Sep 24 13:30:51 UTC 2003
uid=0(root) gid=0(root) groups=0(root)
.
drwxr-xr-x 75 root root 9816 2004-06-01 16:34 /usr/include
.
total 1
drwxr-xr-x 2 root root 128 2004-06-05 01:21 ATI
drwxr-xr-x 33 root root 896 2004-06-01 16:07 kernel-modules
lrwxrwxrwx 1 root root 15 2004-06-01 15:59 linux -> linux-2.4.21-99
drwxr-xr-x 19 root root 688 2004-06-01 16:00 linux-2.4.21-99
drwxr-xr-x 8 root root 192 2004-06-01 15:59 linux-2.4.21-99-include
drwxr-xr-x 7 root root 168 2004-06-01 15:40 packages
.
file /lib/modules/2.4.21-99-default/build/include/linux/agp_backend.h says: AGP=1
assuming default: SMP=0
file /lib/modules/2.4.21-99-default/build/include/linux/autoconf.h says: MODVERSIONS=1
.
CC=gcc
cc_version=3.3.1
found major but not minor version match for gcc and the ip-library
ls -l ./libfglrx_ip.a
lrwxrwxrwx 1 root root 20 2004-06-05 01:21 ./libfglrx_ip.a -> ./libfglrx_ip.a.GCC3
.
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
probing for VMA API version...
cc_ret_vma_240 = 0
cc_ret_vma_253 = 1
def_vma_api_version=-DFGL_LINUX240_VMA_API
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
gcc -Wwrite-strings -Wpointer-arith -Wcast-align -Wstrict-prototypes -O2 -D__KERNEL__ -DMODULE -fomit-frame-pointer -DATI_AGP_HOOK -DATI -DFGL -DFGL_RX -DFGL_CUSTOM_MODULE -DPAGE_ATTR_FIX=0 -Dfglrx -DMODVERSIONS -include /lib/modules/2.4.21-99-default/build/include/linux/modversions.h -Ipatch/include -I/lib/modules/2.4.21-99-default/build/include -c ./agpgart_be.c -o agpgart_be.o
compiling './agp3.c'...
gcc -Wwrite-strings -Wpointer-arith -Wcast-align -Wstrict-prototypes -O2 -D__KERNEL__ -DMODULE -fomit-frame-pointer -DATI_AGP_HOOK -DATI -DFGL -DFGL_RX -DFGL_CUSTOM_MODULE -DPAGE_ATTR_FIX=0 -Dfglrx -DMODVERSIONS -include /lib/modules/2.4.21-99-default/build/include/linux/modversions.h -Ipatch/include -I/lib/modules/2.4.21-99-default/build/include -c ./agp3.c -o agp3.o
compiling './i7505-agp.c'...
gcc -Wwrite-strings -Wpointer-arith -Wcast-align -Wstrict-prototypes -O2 -D__KERNEL__ -DMODULE -fomit-frame-pointer -DATI_AGP_HOOK -DATI -DFGL -DFGL_RX -DFGL_CUSTOM_MODULE -DPAGE_ATTR_FIX=0 -Dfglrx -DMODVERSIONS -include /lib/modules/2.4.21-99-default/build/include/linux/modversions.h -Ipatch/include -I/lib/modules/2.4.21-99-default/build/include -c ./i7505-agp.c -o i7505-agp.o
compiling './nvidia-agp.c'...
gcc -Wwrite-strings -Wpointer-arith -Wcast-align -Wstrict-prototypes -O2 -D__KERNEL__ -DMODULE -fomit-frame-pointer -DATI_AGP_HOOK -DATI -DFGL -DFGL_RX -DFGL_CUSTOM_MODULE -DPAGE_ATTR_FIX=0 -Dfglrx -DMODVERSIONS -include /lib/modules/2.4.21-99-default/build/include/linux/modversions.h -Ipatch/include -I/lib/modules/2.4.21-99-default/build/include -c ./nvidia-agp.c -o nvidia-agp.o
compiling './firegl_public.c'...
gcc -Wwrite-strings -Wpointer-arith -Wcast-align -Wstrict-prototypes -O2 -D__KERNEL__ -DMODULE -fomit-frame-pointer -DATI_AGP_HOOK -DATI -DFGL -DFGL_RX -DFGL_CUSTOM_MODULE -DPAGE_ATTR_FIX=0 -Dfglrx -DFGL_LINUX240_VMA_API -DMODVERSIONS -include /lib/modules/2.4.21-99-default/build/include/linux/modversions.h -D__AGP__ -Ipatch/include -I/lib/modules/2.4.21-99-default/build/include -I/usr/src/linux-2.4.21-99/drivers/char/drm -DFIREGL_410 -c ./firegl_public.c -o firegl_public.o
linking of fglrx kernel module...
ld -r firegl_public.o agpgart_be.o agp3.o i7505-agp.o nvidia-agp.o ./libfglrx_ip.a -o fglrx.o
.
duplicating results into driver repository...
target location: /lib/modules/fglrx
copying fglrx.o
copying logfile of build
*** end of build log ***
 
Old 06-08-2004, 12:24 PM   #8
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
I did not see anything wrong w/ the driver in those let's look at glxinfo.
L8tr
Feend
 
Old 06-08-2004, 04:26 PM   #9
elf-assassin
LQ Newbie
 
Registered: May 2004
Location: new york
Distribution: Suse 9
Posts: 17

Original Poster
Rep: Reputation: 0
elf@arkadian:~> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
 
Old 07-03-2004, 12:32 PM   #10
ila
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
I'm having the same prob on unstable Debian, 2.4.26 kernel with R9000 Pro.
lsmod shows fglrx is loaded tho but glxinfo still shows generic driver.

and yes XF86Config-4 driver is set to "fglrx"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9600 Drivers? Spreegem SUSE / openSUSE 3 04-03-2009 03:16 PM
ati driver installer, radeon 9600, xfree86 4.3, suse mcvrwc Linux - Software 5 11-06-2005 11:56 PM
ATI Radeon 9600 SE and Drivers PJLadd Linux - Hardware 1 07-23-2005 12:10 PM
problems configuring XFree86 with ati radeon 9600 - xwindows not running exodious Red Hat 8 09-06-2004 12:55 AM
ATI Radeon 9600, openGL, and drivers ch4s3r Linux - Software 2 02-20-2004 02:49 PM


All times are GMT -5. The time now is 10:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration