LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2005, 03:14 PM   #1
alek.m
LQ Newbie
 
Registered: Dec 2005
Posts: 7

Rep: Reputation: 0
ATI Driver Problems


I can't seem to install my ATI Drivers.
I download the .run file from the ATI website.
Launch the installer in the terminal under root.

First, I went into the option that allowed me to build a .DEB package.
This did not work however, there was an error in the log file, something about
pckg-buildpackage not a valid command.

Second, I tried the first option "Install Driver 8.19.10 on x.Org 6.8.x"
It went through the whole installation, said it was finished. However, i still get no 3D acceleration. I checked the install.log file and this is what it contains:

Quote:
GNU nano 1.2.4 File: fglrx-install.log

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : No kernel module build environment - please consult readme.
Being brand new to linux this tells me nothing, can anyone enlighten me on wtf is going on?

Thanks.
 
Old 12-04-2005, 04:16 PM   #2
j79zlr
Member
 
Registered: Dec 2005
Location: Chicago
Distribution: Gentoo, Slackware, and FreeBSD
Posts: 38

Rep: Reputation: 15
That is basically telling you that the precomiled ATi driver's are compiled against a different kernel. You need to install the full kernel sources and headers for the kernel you are running and rerun the ati driver installation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI driver problems pyschomike15 Slackware 7 02-23-2005 07:15 PM
ATI Driver problems Lithmov Linux - Software 6 07-20-2004 10:57 PM
ati driver problems Gunslinger_ROL Slackware 4 06-22-2004 08:22 AM
2.6.3 + ATI 3.7.6 driver problems marvin2k Linux - Hardware 3 03-16-2004 02:46 PM
ATI driver problems DRooGz Linux - Hardware 1 09-21-2003 02:20 AM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration