LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-08-2014, 12:21 PM   #1
weepc
LQ Newbie
 
Registered: Mar 2014
Posts: 2

Rep: Reputation: Disabled
Question atheros wifi adapter???????


I have an Asus eee pc 2gig surf, I am looking at running Puppy 4.2 but, it is not recognizing my wifi adapter. Why???
 
Old 03-08-2014, 01:12 PM   #2
Bradj47
Member
 
Registered: Oct 2009
Location: Colorado, USA
Distribution: CentOS, Debian
Posts: 114

Rep: Reputation: 5
Puppy might not have the required drivers for this adapter. Please paste the results of the following commands:

Code:
$ ifconfig
$ ifconfig -a
$ lspci
`ifconfig` will tell us what network interfaces are enabled. `ifconfig -a` will tell us all detected interfaces including the disabled ones. `lspci` will give us further information about your system's hardware.
 
1 members found this post helpful.
Old 03-08-2014, 02:05 PM   #3
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,184

Rep: Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168
Why are you using such an old version of Puppy from 2009? 5 years may not seem like much, but it is actually a long time in the Linux world, and you are 10 versions out of date!! Maybe the current Puppy version will have a newer kernel and better drivers for your wifi?
 
Old 03-08-2014, 04:01 PM   #4
hilyard
Member
 
Registered: Jan 2010
Location: Inland PNW
Distribution: Lite | siduction
Posts: 291

Rep: Reputation: 66
+1 snowpine
Plus, use Frisbee when connecting via wireless in Puppy.
 
Old 03-08-2014, 08:47 PM   #5
Bradj47
Member
 
Registered: Oct 2009
Location: Colorado, USA
Distribution: CentOS, Debian
Posts: 114

Rep: Reputation: 5
Quote:
Originally Posted by snowpine View Post
Why are you using such an old version of Puppy from 2009? 5 years may not seem like much, but it is actually a long time in the Linux world, and you are 10 versions out of date!! Maybe the current Puppy version will have a newer kernel and better drivers for your wifi?
Wow, didn't even realize the version. Disregard my post...
 
Old 03-09-2014, 08:12 PM   #6
rokytnji
LQ 5k Club
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17 , ChromeOS
Posts: 5,075
Blog Entries: 20

Rep: Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326Reputation: 2326
Quote:
Originally Posted by weepc View Post
I have an Asus eee pc 2gig surf, I am looking at running Puppy 4.2 but, it is not recognizing my wifi adapter. Why???
Probably because you are a virgin Puppy user. I don't mean it in a mean way.

Menu>System>Hardware information is where you can get and post info on your wireless chip.
Also Menu>System>Pupsysinfo has info like in Network Devices

Code:
▶ Network Devices ◀

Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
 Kernel Driver: r8169
 Memory Used: 39.77 KB
 Path: /lib/modules/3.10.5/kernel/drivers/net/ethernet/realtek/r8169.ko
 Driver Version: 2.3LK-NAPI
 Description: RealTek RTL-8169 Gigabit Ethernet driver

Network controller [0280]: Ralink corp. Device [1814:5390]
 Kernel Driver: rt2800pci
 Memory Used: 7.54 KB
 Path: /lib/modules/3.10.5/kernel/drivers/net/wireless/rt2x00/rt2800pci.ko
 Description: Ralink RT2800 PCI & PCMCIA Wireless LAN driver.
 Driver Version: 2.3.0
I am letting you know this from my

Code:
sh-4.1# su fido
sh-4.1$ inxi -Fxz
System:    Host: puppypc1974 Kernel: 3.10.5 i686 (32 bit, gcc: 4.7.1) 
           Desktop: JWM git-835 Distro: Slacko Puppy Linux Linux 3.10.5 [ arch]
Machine:   System: Hewlett-Packard (portable) product: Presario CQ57 Notebook PC version: 068C110003204910000620100
           Mobo: Hewlett-Packard model: 3577 version: 24.48 Bios: Hewlett-Packard version: F.42 date: 11/07/2011
CPU:       Dual core AMD C-50 (-MCP-) cache: 1024 KB flags: (lm nx pae sse sse2 sse3 sse4a ssse3 svm) bmips: 3993.86 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics:  Card: ATI Device 9804 bus-ID: 00:01.0 
           X.Org: 1.12.4 drivers: ati,radeon (unloaded: vesa) Resolution: 1366x768@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD PALM GLX Version: 2.1 Mesa 8.0.4 Direct Rendering: Yes
Audio:     Card: ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2 Sound: ALSA ver: k3.10.5
Network:   Card-1: Ralink Device 5390 driver: rt2800pci ver: 2.3.0 bus-ID: 07:00.0
           IF: wlan0 state: up speed: N/A duplex: N/A mac: <filter>
           Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller 
           driver: r8169 ver: 2.3LK-NAPI port: 2000 bus-ID: 06:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 250.1GB (-) 1: id: /dev/sda model: WDC_WD2500BEVT size: 250.1GB 
Partition: 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 58.0C mobo: N/A gpu: 58.0 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 92 Uptime: 27 min Memory: 269.7/1623.6MB Runlevel: 5 Gcc sys: 4.7.1 Client: Shell (sh) inxi: 1.9.18 
sh-4.1$
which is different than your Puppy 4.2 install.
http://murga-linux.com/puppy/index.php?f=31
Good luck and on one of my atom netbooks I run http://slacko.01micko.com/
It should run just fine and your wireless should work out of the box on it. Here is a install how to for you.

https://www.youtube.com/watch?v=xxVOH3mo3Gw

it is for 5.3 but will apply for 5.6.

Happy Trails, Rok
 
Old 03-10-2014, 03:53 AM   #7
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,098
Blog Entries: 3

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
you know the 4.2 I think was around the 2.6.XX kernel and Atho5 driver and firm ware was a issue back then yes it worked but you really need to google .
puppy linux 4.2 Ath0 network you will find a ton of info .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 12 Atheros wireless adapter disabled A2K-JackT Linux - Wireless Networking 1 08-08-2012 09:03 AM
wifi card / wifi adapter error wise apprentice Linux - Newbie 2 08-04-2011 06:32 PM
Wifi problem in ubuntu 9.04 with atheros wifi card raghulmz Linux - Hardware 1 10-28-2009 04:58 AM
wireless usb adapter ar5523 atheros mualim_ul_ilm Linux - Networking 0 07-10-2009 09:21 AM
Atheros WiFi jamaliskandar SUSE / openSUSE 2 08-11-2008 10:04 AM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration