LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-11-2004, 06:21 PM   #1
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Linux Mint, FreeBSD, Android
Posts: 355

Rep: Reputation: 32
At startup, Fedora won't mount /home ("label in use")


Hi all,

When I upgraded from Fedora Core 2 to Core 3, I did a clean install on a new harddrive.My new drive now looks like this:

Code:
/dev/sda
  sda1 /boot
  sda2 /
  sda3 swap
  sda4 Extended
    sda5 /home
I now boot from this drive. So far, so good. The old Core 2 drive is now /dev/sdb and looks like this:
Code:
/dev/sdb
  sdb1 /boot
  sdb3 /
  sdb2 /home
I've deleted the swap partition and will delete the boot and root shortly. However, I am continuing to use the old /home partition on this drive for data, mounting under my new /home directory.

The problem is that when I boot, the system refuses to mount the new /home partition, sda5, saying that LABEL=/home is in use. Each time, I have to log in as root and manually mount sda5 and then sdb2 under it. How do I rename sdb2 or otherwise configure the system so that this conflict is avoided at startup?

Thanks for your help.
 
Old 11-11-2004, 06:27 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,928

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Use tune2fs to change the label of the old home partition.
 
Old 11-11-2004, 06:39 PM   #3
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Linux Mint, FreeBSD, Android
Posts: 355

Original Poster
Rep: Reputation: 32
Thank you! I have made the change and hopefully the next time I boot everything will go fine...
 
Old 11-12-2004, 12:25 PM   #4
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Linux Mint, FreeBSD, Android
Posts: 355

Original Poster
Rep: Reputation: 32
Thanks again, everything now fixed.

Also discovered that e2label can do something similar...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC2; VFS: Cannot open root device "LABEL=/" or unknown-block(0,0) Starchild Fedora 11 01-18-2006 04:39 AM
VFS: Cannot Open Root Device "Label=/" abefroman Red Hat 4 05-03-2005 10:03 AM
unable to mount USB camera: "No medium found" in Fedora Core 2 meonkeys Fedora 0 05-20-2004 03:35 PM
Fedora Core 1 SCSI CD-ROM Won't Mount (always get "is not a valid block device") jerrykuch Linux - Hardware 2 04-18-2004 02:02 PM
dump + restore to backup linux ; "Couldn't find matching filesystem: LABEL=/" on boot markus1982 Linux - General 4 09-21-2002 02:16 PM


All times are GMT -5. The time now is 06:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration