LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-10-2005, 04:37 AM   #1
bourbon32
LQ Newbie
 
Registered: Apr 2005
Location: AUSTRALIA
Posts: 5

Rep: Reputation: 0
Asus Ati X800 Pro 256mb Driver Dtecting Problem?


IVE JUST GOT MANDRAKE FOR THE FIRST TIME 10.1 DVD VERSION WHEN I INSTALL AN GET TO THE PART TO CONFIG MY VIDEO CARD IT SHOWS MY CARD I SELECT ATI|RADEON X800PRO" (PCI:2:0:0) SAYS YOUR CARD CAN HAVE 3D HARDWARE ACCELERATION SUPPORT WITH XORG 6.7.0.... THEN WHEN I TEST IT.. IT SAYS "AN ERROR ACCURRED (EE) NO DEVICES DETECTED" TRY TO CHANGE SOME PARAMETERS'.. I HAVE TRYED SO MANY WAYS SO SO MANY WAYS STILL WONT DETECT IT... I END UP USING FRAME BUFFER TO GET IT WORKING BUT IT AINT USING 3D HARDWARE ACC ETC...

CAN ANYONE HELP ME ON THIS PLZ.
 
Old 04-10-2005, 08:52 AM   #2
billyc
LQ Newbie
 
Registered: Jan 2005
Posts: 14

Rep: Reputation: 0
Hello bourbon32
I upgaded my computer to 64 bit and new x800xt ati card and had the same problem with fedora and mandrake 10.1 then a friend gave me mandrake 10.2 beta, club version that he downloaded from mandrake as a member it fixed the problem straight away except 3d didn'd work had to add
section "dri"
mode 0666
to zorg config or the x86 config file at the end
The beta version should be released as a release version soon if not allready i would say get that and your troubles should be fixed or go with 10.2 beta.
Billyc
 
Old 04-10-2005, 10:50 AM   #3
bourbon32
LQ Newbie
 
Registered: Apr 2005
Location: AUSTRALIA
Posts: 5

Original Poster
Rep: Reputation: 0
were us say below

except 3d didn'd work had to add
section "dri"
mode 0666
to zorg config or the x86 config file at the end

how to i go about this ? i downloaded Mandrakelinux-10.2rc2-.i586
an yes it detect my card an monitor this time yay like u said no 3d acc at all

i dont know anything about linux period an i really want to use linux forever.. so can u tell me step by step how to do it plz how to edit an were to go etc...

Last edited by bourbon32; 04-10-2005 at 03:56 PM.
 
Old 04-10-2005, 03:56 PM   #4
bourbon32
LQ Newbie
 
Registered: Apr 2005
Location: AUSTRALIA
Posts: 5

Original Poster
Rep: Reputation: 0
were us say below

except 3d didn'd work had to add
section "dri"
mode 0666
to zorg config or the x86 config file at the end

how to i go about this ? i downloaded Mandrakelinux-10.2rc2-.i586
an yes it detect my card an monitor this time yay like u said no 3d acc at all

i dont know anything about linux period an i really want to use linux forever.. so can u tell me step by step how to do it plz how to edit an were to go etc...
 
Old 04-11-2005, 10:02 AM   #5
billyc
LQ Newbie
 
Registered: Jan 2005
Posts: 14

Rep: Reputation: 0
To Bourbon32
The XF86 config and xorg config file is in etc/X11 directory. I am a newbie to so my way is boot to the root xserver so i have no problems with permissions.Go to start menu,More Applications/Editors and start Kwrite or Kate (donīt bother yet with Emacs or Vi to complicated) with Kwrite or Kate open the etc/X11 directory and look for the xorg.config then open it.(I will paste my xorg.config in just make sure the last 3 lines of mine is put into yours.) That is what made my 3d work you can try tuxracer game to test it or start terminal and put in glxinfo | grep direct or grep | glxinfo to give info
about 3d. I hope that helps you it is what made mine work but canīt be sure it will fix yours.



# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "dri" # direct rendering
Load "/usr/X11R6/lib64/modules/extensions/libglx.a"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Sony"
ModelName "Sony GDM-400PS/400PST/19PS"
HorizSync 30.0-95.0
VertRefresh 48.0-160.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# Dell D800 and few Inspiron (16/10) 1280x800
ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

# Dell D800 and few Inspiron (16/10) 1680x1050
ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

# Dell D800 and few Inspiron (16/10) 1920x1200
ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
Identifier "monitor2"

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# Dell D800 and few Inspiron (16/10) 1280x800
ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

# Dell D800 and few Inspiron (16/10) 1680x1050
ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

# Dell D800 and few Inspiron (16/10) 1920x1200
ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI"
BoardName "ATI Radeon (fglrx)"
Driver "fglrx"
BusID "PCI:1:0:0"
Option "DPMS"

# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === FireGL DDX driver module specific settings ===
# === Screen Management ===
Option "DesktopSetup" "0x00000000"
Option "MonitorLayout" "AUTO, AUTO"
Option "IgnoreEDID" "off"
Option "HSync2" "unspecified"
Option "VRefresh2" "unspecified"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "NoTV" "yes"
Option "TVStandard" "NTSC-M"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
Option "CenterMode" "off"
# === QBS Support ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "no"
Option "ForceGenericCPU" "no"
# === FSAA ===
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
#Option "Xinerama"
EndSection


Section "DRI"
Mode 0666
EndSection
 
Old 04-11-2005, 10:06 AM   #6
bourbon32
LQ Newbie
 
Registered: Apr 2005
Location: AUSTRALIA
Posts: 5

Original Poster
Rep: Reputation: 0
cheers mate for the help.. i give it ago thanks again
 
Old 04-11-2005, 11:46 PM   #7
bourbon32
LQ Newbie
 
Registered: Apr 2005
Location: AUSTRALIA
Posts: 5

Original Poster
Rep: Reputation: 0
Hi again Billyc i tryed it didnt work... then i came across something in your info

Section "Device"
Identifier "device1"
VendorName "ATI"
BoardName "ATI Radeon (fglrx)"
Driver "fglrx" <<<---------------------on mine it says Driver "radeon" Mine still aint using this driver for some reason' so i change it to "fglrx" and rebooted got to a error saying this module aint loaded (ee) error same error i got on 10.1... for some reason it still wont detect my card... but all not lost im gettin an new pc just built for mandrake with an ati9600xt which i tested mandrake with a mates card an work just fine with 3d acc
BusID "PCI:1:0:0"
Option "DPMS"


I cant thank you enuff Billyc for your help mate it was aprecated
 
Old 04-12-2005, 06:33 AM   #8
billyc
LQ Newbie
 
Registered: Jan 2005
Posts: 14

Rep: Reputation: 0
Hello Bourbon32
Sounds to me that you have the version of mandrake that anybody can download. I have the the Mandrake club version that you have to become a silver member to have. Have a look around the mandrake club and have a look at the faq there.If you can get a hold of official version it will have drivers for nvidia and ati cards
built into the kernel and in your case fglrx module will be loaded .
Another way is go to ati homepage and download the right linux driver for your card and try to follow instructions. Itīs not that hard but i couldnīt get ati card to work i had a nvidia before and they are more linux friendly.
Billyc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ati radeon x800 pro driver install problems mellowdog SUSE / openSUSE 4 05-02-2005 10:49 PM
SUSE ATI x800 Pro driver Hell mellowdog Linux - Hardware 3 03-09-2005 02:58 AM
Ati Radeon X600 pro 256mb Manolis Linux - Hardware 2 03-03-2005 10:12 PM
ATI X800 Pro noobtesting Linux - Hardware 3 02-18-2005 03:20 PM
ATI 9800 pro 256mb.... ironwalker Linux - Hardware 0 01-27-2005 03:03 PM


All times are GMT -5. The time now is 04:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration