LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-15-2003, 06:48 AM   #1
robertmarkbram
Member
 
Registered: May 2003
Location: Melbourne, Australia
Distribution: Cygwin, Windows XP
Posts: 69

Rep: Reputation: 15
Assign rights to directory


Howdy All!

I am using RedHat 9 with KDE..

I have mounted a vfat drive to a directory in my linux file system and when I run Konqueror as root, I can read and write files to it.. but I would like to give my normal login the rights to do that so I don't have to act as root.

As superuser, the permissions set on the directory are shown below:

dr-xr-xr-x 12 root root 16384 Jan 1 1970 BigBrain3

Any help would be most appreciated!

Rob
 
Old 08-15-2003, 06:55 AM   #2
robertmarkbram
Member
 
Registered: May 2003
Location: Melbourne, Australia
Distribution: Cygwin, Windows XP
Posts: 69

Original Poster
Rep: Reputation: 15
btw.. I did try chmod as root:

[root@robertmarkbram java]# chmod 777 /BigBrain3/
chmod: changing permissions of `/BigBrain3/' (requested: 0777, actual: 0755): Operation not permitted
 
Old 08-15-2003, 07:39 AM   #3
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Hello! I'm assuming you didn't do a search You should give that a try as there are quite a few threads on this

Ok, so the skinny (for more info, try a search for fat32 )
open your /etc/fstab locate the line corresponding to the partition, edit the umask settings to 000, save exit:
mount -a -o remount (or just reboot)



Cool
 
Old 08-15-2003, 07:55 AM   #4
yuray
Member
 
Registered: Apr 2003
Location: Russia, Khotkovo
Distribution: Debian
Posts: 146

Rep: Reputation: 15
Change the file /etc/fstab

you_disk you_mountdir vfat user,noauto 0 0

from usual user:
mount you_mountdir

and read the man mount for option user!
 
Old 08-15-2003, 07:58 AM   #5
robertmarkbram
Member
 
Registered: May 2003
Location: Melbourne, Australia
Distribution: Cygwin, Windows XP
Posts: 69

Original Poster
Rep: Reputation: 15
Thank you for the suggestion MasterC!

In fact, I did do a search.. but only with the terms "permanent mount".. which is what brought me here!

On your suggestion I did another search with "fstab mount permanent vfat" and found exactly what I was after:
http://linuxquestions.org/questions/history/55033

All I had to do was add this:
/dev/hda6 /BigBrain3 vfat defaults,umask=000 0 0
and everything is fine!

Thank you again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
assign an arbitrary name or letter to a directory Melsync Linux - General 3 10-06-2005 09:48 AM
Assign CHMOD Rights To Mapped Windows Folder, GaneshParam Linux - Security 0 08-03-2005 05:09 AM
win98 assign home directory problem pmdav Linux - Newbie 4 01-12-2004 01:00 PM
Directory rights dtournas Linux - Security 1 09-02-2003 07:23 AM
How to assign directory access to a user linuxfans Linux - General 7 04-16-2003 12:06 PM


All times are GMT -5. The time now is 10:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration