LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Arch w/ SLiM. not loading xfce4 (http://www.linuxquestions.org/questions/linux-newbie-8/arch-w-slim-not-loading-xfce4-4175447599/)

iceman81 01-28-2013 05:51 PM

Arch w/ SLiM. not loading xfce4
 
i've been at this for 2 days now, i have SLiM loading at boot, however when i log in xfce4 doesn't start, it just goes back to the slim login. if it type user: exit and get into command prompt, i can start x or xfce. i didn't have a ~/.xinitrc file so i created a skeleton one using a command i found in the arch wiki. I configured everything the way the wiki says and it still refuses to automatically start xfce. Any suggestions?

Habitual 01-28-2013 06:47 PM

I just installed ArchLinux into Virtualbox and had the very same issue.
does your ~/.xinitrc have
Code:

exec startxfce4
and did you
Code:

systemctl enable slim.service
?

I uninstalled slim and re-installed it, finally it works.
but I had forgot to issue
Code:

chmod +x ~/.xinitrc
before I re-installed.

I used
https://wiki.archlinux.org/index.php/SLiM
https://wiki.archlinux.org/index.php/Xinitrc

Please let us know...

jv2112 01-28-2013 06:50 PM

Did you input instructions in your /home/user/.xinitrc ?


Check out this post for further details -->



https://wiki.archlinux.org/index.php...y_at_boot_time

Code:


exec startxfce4


iceman81 01-28-2013 06:56 PM

@habitual, yes I ran all those commands.

@jv2112, no I didn't, but now it works. Doh!

Thanks for the help guys

Habitual 01-28-2013 07:04 PM

Great!

I look forward to the challenge of learning Arch myself. dhcpd threw me for a loop for about 30 minutes. :)

iceman81 01-28-2013 07:06 PM

Only issue now is I have to run the command dhcpcd to get Internet. Have to figure out how to do it at boot

Habitual 01-28-2013 07:25 PM

Code:

systemctl enable dhcpcd@enp0s3
systemctl start dhcpcd@enp0s3

I think does it.

see https://wiki.archlinux.org/index.php/Dhcpd

iceman81 01-28-2013 07:34 PM

i ran that command, then i rebooted. ping didn't work, so i ran dhcpcd and refreshed. tried that command again and got an error saying job for dhcpcd@enp0s3.service failed see systemctl status

Habitual 01-30-2013 08:39 AM

I gave you the only wiki links I read, here's the last one, sorry for the delay.

https://wiki.archlinux.org/index.php...mic_IP_address
It's the same link as previous, doh!

This was done under VirtualBox (4.1.18r78361) after I installed archlinux-2012.11.01-dual.iso

wrt:
Code:

systemctl enable dhcpcd@enp0s3
systemctl start dhcpcd@enp0s3

I don't remember what steps exactly 'fixed' the issue (numerous (Right) Ctrl+R in Vbox reboots) but one of those finally 'took'

re:
Quote:

ping didn't work
It won't either until you get an IP.

Don't give up. I'm vested now. ;)


All times are GMT -5. The time now is 10:30 PM.