LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-23-2014, 01:43 PM   #1
CamTheSaxMan
Member
 
Registered: Nov 2013
Distribution: Linux Mint 13 Cinnamon Edition 64-bit, Windows 7 Home Premium SP1 64-bit, Arch Linux 32-bit
Posts: 159

Rep: Reputation: 9
Arch Linux insists on reading localtime from the hardware clock.


I recently installed Arch Linux on my PC and I'm having some issues with the wrong time being displayed. The time in BIOS is set to the UTC. I checked it and know it for a fact. However, my system time is 6 hours off. I'm in the US Central timezone (CST). Running sudo hwclock interprets the hardware clock as localtime, even though I've set it to UTC in /etc/adjtime. Any ideas?
BIOS time is about 7:42 at the time of this posting. (slightly off since it takes time to write this post.)
Output of sudo hwclock:
Code:
Thu 23 Jan 2014 07:39:44 AM CST  -0.907002 seconds
Output of cat /etc/adjtime:
Code:
-0.085263 1390482941 0.000000
1390482941
UTC
Output ot timedatectl:
Code:
      Local time: Thu 2014-01-23 07:43:14 CST
  Universal time: Thu 2014-01-23 13:43:14 UTC
        Timezone: America/Chicago (CST, -0600)
     NTP enabled: n/a
NTP synchronized: no
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  Sun 2013-11-03 01:59:59 CDT
                  Sun 2013-11-03 01:00:00 CST
 Next DST change: DST begins (the clock jumps one hour forward) at
                  Sun 2014-03-09 01:59:59 CST
                  Sun 2014-03-09 03:00:00 CDT

Last edited by CamTheSaxMan; 01-23-2014 at 01:44 PM.
 
Old 01-23-2014, 04:40 PM   #2
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,029

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Use the command timedatectl to set the time, also see this for more info.

Regards
 
Old 01-23-2014, 04:49 PM   #3
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,549

Rep: Reputation: 180Reputation: 180
If you are running KDE then click on System Settings -> Date & Time -> Time Zone to get the time zones menu.

-----------------------
Steve Stites
 
  


Reply

Tags
arch linux, timezone


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why system clock runs faster than hardware clock? DavidLiu Linux - Software 2 01-23-2011 07:38 AM
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 07:19 PM
Failed to set system clock to hardware clock jrtayloriv Linux - Newbie 2 09-25-2008 07:06 AM
Slow system clock and stray hardware clock, pleas help! Epox Linux - General 6 01-02-2007 02:43 PM


All times are GMT -5. The time now is 01:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration