LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-10-2010, 01:24 PM   #1
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Arch Install with GNOME, system defaults to GDM, GDM no mouse or keyboard


Well I installed Arch and X and GNOME as per per the Arch Wiki, and now have no mouse or keyboard. This is a significant problem because I configured Arch to boot GDM by default. I do have a Ubuntu LiveCD with me, so what do I do with that to fix the problem?

I have a touchpad and it worked in xterm after I installed the synaptics.

Damn. Please help?

Last edited by lupusarcanus; 01-10-2010 at 01:31 PM.
 
Old 01-10-2010, 01:33 PM   #2
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
WOW. The UBUNTU live cd cannot read the root filesystem IT HAS NO IDEA WTF it is. OMG help!! I need TO START ARCh but NO GDM so the FILESYSTEM can repair itself enough. I tried ARCH FALLBACK to no avail...is hope lost? Is there a way I can TELL GRUB to not load GDM?!

...

Last edited by lupusarcanus; 01-10-2010 at 01:36 PM.
 
Old 01-10-2010, 01:51 PM   #3
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
/usr/bin/tty: no such file or directory. Wow...
 
Old 01-10-2010, 01:54 PM   #4
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Ok, I think the file system was repaired by fsck.jfs after my third reboot.
How do I tell Arch not to start gdm so I can find out whats wrong (and take gdm out of the startup daemons? Please, anyone...
 
Old 01-10-2010, 02:10 PM   #5
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Phew...

I got it back to some kind of normal state. I finally was able to run
"fsck.jfs -a /dev/sda2"
and mount the file system, edit the file, and boot back into the CLI. YAY!

Now what on Earth is the problem with gdm and why isn't the keyboard or mouse working?

Resolution is normal. Colors look good. Everything is rendered is rendered correctly
 
Old 01-10-2010, 02:22 PM   #6
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 82

Rep: Reputation: 16
ok, sorry didnt read your post before!

as for the gdm, i have no idea as i never used it or planning to use it in the near future!

for mouse and keyboard: look for packages xf86-input-keyboard, xf86-input-mouse and xf86-input-evdev; you probably missing one of those packages, install them, restart X!

hope that helps!
 
Old 01-10-2010, 02:47 PM   #7
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Smile

Quote:
Originally Posted by rgistered View Post
ok, sorry didnt read your post before!

as for the gdm, i have no idea as i never used it or planning to use it in the near future!

for mouse and keyboard: look for packages xf86-input-keyboard, xf86-input-mouse and xf86-input-evdev; you probably missing one of those packages, install them, restart X!

hope that helps!
Thanks!!! Fixed. Very much appreciated!
 
Old 01-10-2010, 03:00 PM   #8
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 82

Rep: Reputation: 16
Quote:
Originally Posted by leopard View Post
Thanks!!! Fixed. Very much appreciated!
your welcome

PS. and please set the status of this thread as [SOLVED]
 
Old 01-30-2011, 05:30 PM   #9
dedanna1029
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 1
Everything to be done to install Arch Linux can be found in the Arch install guide at https://wiki.archlinux.org/index.php..._Install_Guide and as well, it is a good idea to read the Arch beginner's guide at https://wiki.archlinux.org/index.php/Beginners'_Guide . It is highly recommended if you have never installed it before, to print these out. They will save a lifetime of hassle. Arch is not something that you can do very well if you don't know what you're doing first. Follow these to the letter (I myself have memorized them now, I've done so many Arch installs), and you will never see a problem. They tell you what to install when, How to set up, everything.

To switch to another login manager, edit /etc/inittab, as so:

Code:
cat /etc/inittab
#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)	Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

## Only one of the following two lines can be uncommented!
# Boot to console
#id:3:initdefault:
# Boot to X11
id:5:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

# -8 options fixes umlauts problem on login
c1:2345:respawn:/sbin/agetty -8 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 38400 tty2 linux
c3:2345:respawn:/sbin/agetty -8 38400 tty3 linux
c4:2345:respawn:/sbin/agetty -8 38400 tty4 linux
c5:2345:respawn:/sbin/agetty -8 38400 tty5 linux
c6:2345:respawn:/sbin/agetty -8 38400 tty6 linux

# Hypervisor Virtual Console for Xen and KVM
#h0:2345:respawn:/sbin/agetty -8 38400 hvc0 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# Example lines for starting a login manager
#x:5:respawn:/usr/bin/xdm -nodaemon
#x:5:respawn:/usr/sbin/gdm -nodaemon
#x:5:respawn:/usr/bin/kdm -nodaemon
(This is the login manager I've chosen)--->x:5:respawn:/usr/bin/slim >/dev/null 2>&1
#x:5:respawn:/usr/bin/slim >& /dev/null

# End of file
... Simply uncomment the one you want to use. If it's not there, add it.

Oh, and Ubuntu cd = no. You're better off to fix with Arch's own live cd. Ubuntu and Arch are two completely different animals. One uses debian, the other tar.xz (source). If you are going to use a live cd to fix something, you need to use one that uses the same file system.

Last edited by dedanna1029; 01-30-2011 at 06:17 PM. Reason: File system information
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome/gdm startup apps: Why are some children of gdm and others children of init? sixerjman Linux - Software 1 07-04-2009 11:48 AM
Problems with GDM (GDM user does not exist error) utkarshrawat Linux - Software 1 09-25-2007 09:39 AM
Trying to install mythtv on feisty fawnbut system crashes when trying to start GDM kopite Ubuntu 2 07-24-2007 02:31 PM
GDM doesn't work: Authdir /usr/var/gdm does not exist jimhap Linux - Newbie 11 06-08-2007 05:22 PM
keyboard not working as expected with gnome/gdm quarry_06 Linux - Software 1 04-03-2006 06:09 PM


All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration