LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2013, 11:00 PM   #1
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Rep: Reputation: 4
APT throwing errors while trying to install or remove packages, related to libasound2


Code:
theif519@ubuntu:~$ sudo apt-get install libqtgui4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqtgui4 is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 bluez-alsa:i386 : Depends: libasound2:i386 (>= 1.0.16) but it is not going to be installed
 ia32-libs-multiarch:i386 : Depends: libasound2:i386 but it is not going to be installed
 libasound2-plugins:i386 : Depends: libasound2:i386 (>= 1.0.25) but it is not going to be installed
 libcanberra0:i386 : Depends: libasound2:i386 (>= 1.0.16) but it is not going to be installed
 libesd0:i386 : Depends: libasound2:i386 (>= 1.0.16) but it is not going to be installed
 libsdl1.2debian:i386 : Depends: libasound2:i386 (>= 1.0.16) but it is not going to be installed
 libvisual-0.4-plugins:i386 : Depends: libasound2:i386 (>= 1.0.16) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
theif519@ubuntu:~$ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
theif519@ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libasound2:i386
Suggested packages:
  libasound2-python:i386
The following NEW packages will be installed:
  libasound2:i386
0 upgraded, 1 newly installed, 0 to remove and 12 not upgraded.
13 not fully installed or removed.
Need to get 0 B/431 kB of archives.
After this operation, 1,408 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 271468 files and directories currently installed.)
Unpacking libasound2:i386 (from .../libasound2_1.0.25-3ubuntu3.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libasound2_1.0.25-3ubuntu3.1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/alsa/cards/USB-Audio.conf', which is different from other instances of package libasound2:i386
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 /var/cache/apt/archives/libasound2_1.0.25-3ubuntu3.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
So, I tried installing another package, unrelated to the problem, but it keeps throwing errors regarding that I have "unmet dependencies", but even if I try to remove those packages, it stills says it's trying to install the packages I'm trying to remove. Is there a way to manually remove those packages without using the package manager to get over this problem? I've tried repairing it with the software center, didn't work. Tried apt-get autoclean, clean, and autoremove (which threw dependency errors) but neither worked... Any help would be greatly appreciated, I can't even use my distro because of this thing.


Edit: Alright, so I just got the common sense to manually make a backup of those files it's had problems with and remove them so libasound2 can do it's thing, and it works. Thing is, I'm unsure if the new i386 config will mess anything up in the long run, and if it may have caused some troubles further down the road... hope not.

Last edited by theif519; 03-30-2013 at 11:05 PM. Reason: Fixed.... for now.
 
Old 03-31-2013, 09:40 PM   #2
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
That is good thing you find a solution, would be helpful also to mark the thread as solved so others would find the solution for similar problem easier.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I remove all packages related to the desktop environment? alarazr Debian 7 07-03-2012 07:22 AM
cannot remove two packages with apt-get Hystoriker Ubuntu 4 05-11-2009 02:05 PM
LXer: Apt-get remove SUSE; apt-get install Etch LXer Syndicated Linux News 0 05-26-2007 08:46 PM
apt-get returns lots of errors and wont install packages... StrangeBiscuit Debian 14 09-25-2006 06:18 PM
apt-get wants to remove need packages fastTalker Linux - Software 1 02-15-2006 08:04 PM


All times are GMT -5. The time now is 01:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration