LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-15-2006, 03:44 PM   #1
1337ln
LQ Newbie
 
Registered: Jun 2006
Location: B-Ville, PA
Distribution: Slackware 13.37
Posts: 15

Rep: Reputation: 0
apt-get returns unmet dependencies error with python2.3-sip4-qt3 package


not to long ago i wanted to configure the AIO Super Karamba widget, so i needed PyQt

no problem, im running debian, so i do an apt-cache search and get all teh relevant packages, well now im having this issue here, which is disabling me from grabbing anything at all with apt

Leviathan:/home/ron1n# apt-get install naim
Reading package lists... Done
Building dependency tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
python2.3-qt3: Depends: python2.3-sip4-qt3 (>= 4.3) but it is not going to be installed
Depends: python2.3-sip4-qt3 (< 4.4) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

so i follow the recommendation

Leviathan:/home/ron1n# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies...Done
The following extra packages will be installed:
python2.3-sip4-qt3
The following NEW packages will be installed
python2.3-sip4-qt3
0 upgraded, 1 newly installed, 0 to remove and 26 not upgraded.
2 not fully installed or removed.
Need to get 0B/68.7kB of archives.
After unpacking 176kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

dpkg-preconfigure: cannot connect to X server :0.0
debconf: unable to initialize frontend: Kde
debconf: (DISPLAY problem?)
debconf: falling back to frontend: Dialog
(Reading database ... 93713 files and directories currently installed.)
Unpacking python2.3-sip4-qt3 (from .../python2.3-sip4-qt3_4.3.1-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/python2.3-sip4-qt3_4.3.1-1_i386.deb (--unpack):
trying to overwrite `/usr/lib/python2.3/site-packages/sipconfig.py', which is also in package python2.3-sip-qt3
Errors were encountered while processing:
/var/cache/apt/archives/python2.3-sip4-qt3_4.3.1-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

i have attempted to apt-get --purge remove the package, dpkg -r --force-remove-reinstreq python2.3-sip4-qt3 the package, and dpkg --purge remove it, they all tell me that the package isnt installed

so i resort to one last final option, i see teh line
/var/cache/apt/archives/python2.3-sip4-qt3_4.3.1-1_i386.deb

and leads me to beleive that if i run apt-get clean it will remedy the issue, but find out that it doesnt

im all out of ideas, if u can help please do
 
Old 06-16-2006, 03:20 PM   #2
Michael_S
Member
 
Registered: Oct 2004
Location: Pennsylvania, USA
Distribution: Debian
Posts: 78

Rep: Reputation: 23
When I get error messages like that, I just plain cheat. From the lines you posted, the conflict is over
/usr/lib/python2.3/site-packages/sipconfig.py
[EDIT] That is, two different packages have their own copies of that file, so apt will not install one of them. [/EDIT]
So I would just move that to /usr/lib/python2.3/site-packages/sipconfig.py.old

And try the installation again. The installation will probably succeed and you should be able to resume using apt normally.

The downside is, if two packages use /usr/lib/python2.3/site-packages/sipconfig.py, it's possible that one won't work correctly. You may be able to find more information about the problem on the Debian mailing lists - maybe with a fix.

Last edited by Michael_S; 06-16-2006 at 03:22 PM.
 
Old 06-16-2006, 05:38 PM   #3
1337ln
LQ Newbie
 
Registered: Jun 2006
Location: B-Ville, PA
Distribution: Slackware 13.37
Posts: 15

Original Poster
Rep: Reputation: 0
Would you by any chance be able to tell me the app that will be crippled?

i have oython2.3 and python2.4 both installed on this system, could that be the issue?
 
Old 06-16-2006, 06:46 PM   #4
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,593

Rep: Reputation: 162Reputation: 162
You won't cripple any packages. You only need one of each file. If dpkg complains that it won't install a package because one of the files in the package already exists on the system, you do:

mv file file.old

Then dpkg will install the file it wouldn't install before, which is the same file you moved to file.old. If something turns out to not work you do:

mv file.old file

and put the old file back.
 
Old 06-16-2006, 08:25 PM   #5
Michael_S
Member
 
Registered: Oct 2004
Location: Pennsylvania, USA
Distribution: Debian
Posts: 78

Rep: Reputation: 23
Quote:
Originally Posted by AwesomeMachine
You won't cripple any packages. You only need one of each file. If dpkg complains that it won't install a package because one of the files in the package already exists on the system, you do:

mv file file.old

Then dpkg will install the file it wouldn't install before, which is the same file you moved to file.old. If something turns out to not work you do:

mv file.old file

and put the old file back.
Well, I think there is always the small but distinct possibility that two packages each contain a file with the same name and the exact same contents. I could be wrong, though.

In this particular case, I think you're right that it won't be a problem. I would bet sipconfig.py is identical between the two packages.
 
Old 06-16-2006, 08:36 PM   #6
Michael_S
Member
 
Registered: Oct 2004
Location: Pennsylvania, USA
Distribution: Debian
Posts: 78

Rep: Reputation: 23
I meant to say the exact same name and totally different contents.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get unmet dependencies, etc. knappster Linux - Software 13 12-14-2005 11:06 PM
apt-get unmet dependencies jeffbarish Debian 9 10-27-2005 01:19 AM
removing package with unmet dependencies in Sarge killy9999 Debian 6 09-08-2005 01:42 PM
apt-get & unmet dependencies! beecee Debian 1 01-09-2004 08:44 AM
apt + KDE3 = unmet dependencies hypermegachi Debian 2 09-29-2003 10:18 AM


All times are GMT -5. The time now is 09:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration