LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-08-2010, 01:09 PM   #1
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
apt-get install command is not able to fetch packages from ubuntu repositary


Hi All,

I have been working on Redhat family of distributions since past 1 year. Two days back I installed Ubuntu 10.04 on my laptop. I am novice to Package Management in Debian family of Linux distributions.

My Internet connection is working fine. But I am not able to install any package with apt-get package Manager.

Here is my /etc/apt/sources.list file
Code:
deb http://in.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://in.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://in.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://in.archive.ubuntu.com/ubuntu/ lucid universe
deb http://in.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://in.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb http://in.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://in.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
Here is output of apt-get install command

Code:
root@vinay-laptop:/etc/init.d# apt-get install mysqld
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package mysqld
What could be the problem ? Is it necessary to make any changes in /etc/apt/sources.list file ?

Thanks in advance..

Last edited by vinaytp; 05-08-2010 at 01:11 PM.
 
Old 05-08-2010, 01:15 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,644

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
did you 'apt-get update' first? always do that.
 
Old 05-08-2010, 01:46 PM   #3
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Many Thanks AlucardZero,

I executed apt-update as you suggested. I got few messages shown below.

I am not posting whole output of apt-update, as it is very long. I have posted a part of the output here, which constitutes two types of lines in my whole output.

Code:
Ign http://in.archive.ubuntu.com lucid/main Sources                          
Ign http://in.archive.ubuntu.com lucid/restricted Sources
Ign http://in.archive.ubuntu.com lucid/universe Packages
Ign http://in.archive.ubuntu.com lucid/universe Sources
Ign http://in.archive.ubuntu.com lucid/multiverse Packages
Ign http://in.archive.ubuntu.com lucid/multiverse Sources
Ign http://in.archive.ubuntu.com lucid-updates/main Packages
Ign http://in.archive.ubuntu.com lucid-updates/restricted Packages
Ign http://in.archive.ubuntu.com lucid-updates/main Sources
Ign http://in.archive.ubuntu.com lucid-updates/restricted Sources
Ign http://in.archive.ubuntu.com lucid-updates/universe Packages
Ign http://in.archive.ubuntu.com lucid-updates/universe Sources
Ign http://in.archive.ubuntu.com lucid-updates/multiverse Packages
Ign http://in.archive.ubuntu.com lucid-updates/multiverse Sources
Err http://in.archive.ubuntu.com lucid/main Packages
  Something wicked happened resolving 'in.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Err http://in.archive.ubuntu.com lucid/restricted Packages
  Something wicked happened resolving 'in.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Err http://in.archive.ubuntu.com lucid/main Sources
  Something wicked happened resolving 'in.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Err http://in.archive.ubuntu.com lucid/restricted Sources
  Something wicked happened resolving 'in.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Err http://in.archive.ubuntu.com lucid/universe Packages
  Something wicked happened resolving 'in.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Err http://in.archive.ubuntu.com lucid/universe Sources
  Something wicked happened resolving 'in.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Err http://in.archive.ubuntu.com lucid/multiverse Packages
  Something wicked happened resolving 'in.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Still I am facing same error when I exeucte apt-get install <AnyPkgName>. What could be the problem ?

Last edited by vinaytp; 05-08-2010 at 01:47 PM.
 
Old 05-08-2010, 02:02 PM   #4
ajeetsinghraina
Member
 
Registered: May 2010
Location: India
Distribution: Ubuntu 7.04/8.04/8.10/10.04, RHEL 6, OpenSUSE,Mandriva,Fedora, CentOS, XandrOS, Slackware, OpenSolar
Posts: 155

Rep: Reputation: 55
Code:
 Something wicked happened resolving 'in.archive.ubuntu.com:http
Seems like your DNS configuration is unable to resolve the address.

Try pinging to this server from Windows/any other Linux DNS Client.
It will inform you with IP.
Put that IP under /etc/hosts or under /etc/apt/source.list instead of hostname.
Do Check /etc/resolv.conf too.
 
Old 05-08-2010, 08:58 PM   #5
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Debian, SL
Posts: 5,315

Rep: Reputation: 1141Reputation: 1141Reputation: 1141Reputation: 1141Reputation: 1141Reputation: 1141Reputation: 1141Reputation: 1141Reputation: 1141
Other than the network issues already mentioned, are you sure that the package name really is "mysqld". I suspect that the package you want is actually mysql-server. Try using "apt-cache search" to find the actual package name.

Evo2.
 
Old 05-10-2010, 11:13 AM   #6
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Original Poster
Rep: Reputation: 55
Thanks everybody for suggestions.

Now names are getting resolved by DNS. But I am caught with bad header error.

Code:
root@vinay-laptop:~# apt-get update
Get:1 http://security.ubuntu.com lucid-security Release.gpg [189B]
Get:2 http://in.archive.ubuntu.com lucid Release.gpg [189B]
Ign http://in.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_IN
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_IN
Err http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_IN
  Bad header line
Get:3 http://in.archive.ubuntu.com lucid-updates Release.gpg [189B]
Ign http://in.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_IN
Get:4 http://in.archive.ubuntu.com lucid Release [57.2kB]
Hit http://in.archive.ubuntu.com lucid-updates Release                 
Err http://in.archive.ubuntu.com lucid Release                         
  
Hit http://in.archive.ubuntu.com lucid-updates/main Packages
Hit http://in.archive.ubuntu.com lucid-updates/restricted Packages
Hit http://in.archive.ubuntu.com lucid-updates/main Sources
Hit http://in.archive.ubuntu.com lucid-updates/restricted Sources
Hit http://in.archive.ubuntu.com lucid-updates/universe Packages
Hit http://in.archive.ubuntu.com lucid-updates/universe Sources
Hit http://in.archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://in.archive.ubuntu.com lucid-updates/multiverse Sources
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_IN                                                                                       
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_IN
Get:5 http://security.ubuntu.com lucid-security Release [32.5kB]
Err http://security.ubuntu.com lucid-security Release
  
Fetched 569B in 18s (31B/s)
Reading package lists... Done
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://in.archive.ubuntu.com lucid Release: The following signatures were invalid: NODATA 1 NODATA 2

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://security.ubuntu.com lucid-security Release: The following signatures were invalid: NODATA 1 NODATA 2

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/restricted/i18n/Translation-en_IN.bz2  Bad header line

W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/lucid/Release  

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/Release  

W: Some index files failed to download, they have been ignored, or old ones used instead.
As evo2 said it is mysql-server

Code:
root@vinay-laptop:~# apt-get install mysql-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package mysql-server
Still facing same error..Could anyone please help me with this...

Thanks again..
 
Old 06-22-2010, 04:51 PM   #7
jrtayloriv
Member
 
Registered: Jun 2004
Location: Inland NW, US
Distribution: Ubuntu
Posts: 365
Blog Entries: 1

Rep: Reputation: 44
---

Last edited by jrtayloriv; 06-22-2010 at 05:03 PM. Reason: duplicate -- admin please remove
 
Old 06-22-2010, 04:52 PM   #8
jrtayloriv
Member
 
Registered: Jun 2004
Location: Inland NW, US
Distribution: Ubuntu
Posts: 365
Blog Entries: 1

Rep: Reputation: 44
This is a known bug that has yet to be solved -- see https://bugs.launchpad.net/ubuntu/+s...pt/+bug/574886 ...
seems that a temporary workaround would be to bypass your router when connected to the internet.
 
Old 11-11-2010, 02:02 AM   #9
Penceyarts
LQ Newbie
 
Registered: Nov 2010
Posts: 8

Rep: Reputation: 0
I'm having a similar issue. I can't get past the login on my computer, and the fix to that needs root with networking. Any manual way to connect to the internet in root? Very new to this.
 
Old 11-11-2010, 02:13 AM   #10
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
put a # in-front of

in sources.list file
 
Old 11-11-2010, 09:20 PM   #11
Penceyarts
LQ Newbie
 
Registered: Nov 2010
Posts: 8

Rep: Reputation: 0
i do believe it already puts a # in front of it automatically when when root is with networking
 
Old 01-23-2011, 02:39 AM   #12
sandworm101
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
I had the same error on a new install. It looked like a DNS issue. So I configured my network connection to use OpenDNS directly, rather than via my router. That seems to have solved the problem.

Right-click network icon, select "edit connections"
Select the connection you are using at the moment.
Click "edit"
Select the "IPv4 settings" tab
Set method to "Automatic (DHCP) addresses only"
Then input "208.67.222.222, 208.67.220.220" into the DNS servers box

Exit, reset the network connection and retry "apt-get update"
 
Old 02-19-2011, 05:04 PM   #13
nossifer
LQ Newbie
 
Registered: Feb 2006
Posts: 2

Rep: Reputation: 0
proxy

you might be required to be at a specific location, or behind a proxy / vpn.

My work gave me a laptop that requires this, and fails for the same reasons. I am trying to find a way to replace their GPG key with a nice one that lets me update anywhere
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Download packages with apt but don't install them yb99 Linux - General 5 02-25-2010 11:15 PM
Can't install packages in either Synaptics or using APT Garry | K | E Linux - Software 1 12-07-2009 11:35 AM
LXer: How To Search For Missing Packages With apt-file On Debian and Ubuntu LXer Syndicated Linux News 0 02-21-2007 07:01 PM
install all available packages with apt-get thinkpadx30 Debian 7 08-27-2006 06:02 AM
APT problem - Cannot install packages... Astral Projection Debian 3 04-22-2006 12:01 AM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration