LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-19-2005, 06:45 PM   #1
newbieX
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Rep: Reputation: 0
apt-get error?


I am working on knoppix 3.6 and i have done something wrong whith apt-get. I was trying to get mplayer-k7 but it gave me an error saying:

Reading Package Lists... Done
Building Dependency Tree... Done
mplayer-k7 is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
mplayer-k7: Depends: mplayer-k6 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


then when i run apt-get -f install i get even more error saying:

Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
mplayer-k6
Suggested packages:
w32codecs libdvdcss mplayer-doc
Recommended packages:
mplayer-fonts
The following NEW packages will be installed:
mplayer-k6
0 upgraded, 1 newly installed, 0 to remove and 788 not upgraded.
39 not fully installed or removed.
Need to get 0B/2467kB of archives.
After unpacking 5128kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 108725 files and directories currently installed.)
Unpacking mplayer-k6 (from .../mplayer-k6_1%3a1.0-pre6cvs20050409-0sarge0.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/mplayer-k6_1%3a1.0-pre6cvs20050409-0sarge0.1_i386.deb (--unpack):
trying to overwrite `/etc/mplayer/mplayer.conf', which is also in package mplayer-codec
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/mplayer-k6_1%3a1.0-pre6cvs20050409-0sarge0.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I have allready deleted the

/var/cache/apt/archives/mplayer-k6_1%3a1.0-pre6cvs20050409-0sarge0.1_i386.deb

file and the

/etc/mplayer/mplayer.conf'

how can i fix this, please anyone?
 
Old 04-19-2005, 11:00 PM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
You have 39 packages not fully installed or removed.

Use dpkg to remove these half-installed packages and try again.
 
Old 04-20-2005, 06:56 AM   #3
newbieX
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I am a newbie in linux so could u be more precise about how to remove these packages.
 
Old 04-20-2005, 08:41 AM   #4
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
'dpkg --purge packagename' will probably do. For more otions read 'man dpkg'
 
Old 04-20-2005, 02:36 PM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
all i can say is that when apt goes awol like that the sollution is sometimes unique to the situation and not always logical. if you can't figure it out look on google for someoneelse who has

first things to try i think are

apt-get remove mplayer-k7
apt-get --purge remove mplayer-k7

dpkg -r exactfilename_of_ mplayer-k7.deb
dpkg -r --purge exactfilename_of_ mplayer-k7.deb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error when using Apt-get patisawsome Ubuntu 7 08-22-2006 06:34 PM
apt-get error abattoir Debian 1 06-22-2005 07:27 AM
apt-get ERROR robramm Linux - General 2 05-21-2005 05:02 PM
apt-get error PsychosisNode Debian 1 08-02-2004 03:02 PM
apt-get error installing xlibs 4.2.1-14, apt-get won't work at all now pib Debian 1 12-11-2003 12:39 AM


All times are GMT -5. The time now is 10:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration