LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-28-2003, 06:27 AM   #1
Toasti
Member
 
Registered: Mar 2003
Location: Stuttgart / Germany
Distribution: mandrake, debian
Posts: 34

Rep: Reputation: 15
apt-get dist-upgrade


perhaps the wrong forum, but i'll try it anyway.

I'm trying to get my dist upgraded. after a few secs i get this error-messages
Code:
Get:1 http://ftp2.de.debian.org testing/main kde3libs3 4:2.2.2-13
Fetched 6617kB in 0s (10.9MB/s)
(Reading database ... 97135 files an directories currently installed.)
Unpacking kdelibs3 (from .../kdelibs3_4%3a2.2.2-13_i386.deb)
dpkg: error processing /var/cache/apt/archives/kdelibs3_4%3a2.2.2-13_i386.deb (--unpack):
 trying to overwrite `/usr/lib/libartsdsp_st.so', which is also in package libarts1-dev
Errors were encountered while processing:
 /var/cache/apt/archives/kdelibs3_4%3a2.2.2-13_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
does anybody know what to do???
 
Old 03-28-2003, 07:50 AM   #2
chambsr
LQ Newbie
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Debian unstable
Posts: 2

Rep: Reputation: 0
unless you are writing software that uses libarts1-dev I'd do a

dpkg -r libarts1-dev

that would remove that package, and allow you to do the dist-upgrade. after which, if i needed the development files (generally just the headers or ".h" files that get included in your code) to recompile my custom application that uses that lib, i'd reinstall it with

apt-get install libarts1_dev

the problem comes from the order that dpkg wants to do the upgrade. i'm sure that libarts1-dev_4%3a2.2.2-13_i386.deb doesn't have libartsdsp_st.so in it anymore, so if dpkg upgraded it before kde3libs you wouldn't have the problem.

of course i actually prefer dselect for this kind of thing, and the easiest way there is to do multiple (I)nstalls. when the first one fails doing the kde3libs part it does the libarts1_dev part in that pass. then when you do the second (I)nstall when it gets to kde3libs there's no conflict and it just works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 02:33 PM
some help with apt-get dist-upgrade MaTrIx709 Debian 2 09-10-2005 12:13 PM
What's the difference between apt-get upgrade and apt-get dist-upgrade? davidas Linux - Newbie 4 04-04-2004 09:19 PM
apt-get dist-upgrade HULLU Debian 1 03-26-2004 11:27 PM
apt-get dist-upgrade Culbert Debian 5 08-26-2003 12:16 AM


All times are GMT -5. The time now is 12:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration