LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2004, 02:23 PM   #1
sanger440
LQ Newbie
 
Registered: Feb 2004
Distribution: Thizlinux
Posts: 10

Rep: Reputation: 0
apt-get configure


I have recently installed thizlinux 7.0 and am pretty happy with it. Really easy install and is very similiar to windoze, which helps for a newbie like myself. It has mozilla intalled, automounts cdroms, etc.Thizlinux has an apt-get feature that get/updates new software similiar to other disto's I have tryed. Synaptic is also installed and working. The problem is that aptget is configured to only get software from the Thizlinux vendor site. This is OK, but I would like to use other sources as well. In synaptic, there is a settings menus for repositories (where you get the software) and I cans see that it is set for rpm's from the thizlinux site. There is a provision to add other url/locations. Here is my questions:

1. What are other update sites I can use in aptget/synaptic?

2. Is it possible to uninstall and then reinstall aptget and synaptic so I can use generic sites?

I believe Thizlinux based on a redhat version of linux (previous versions were) Thanks in advance for any help.
 
Old 02-01-2004, 03:53 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
I don't know the distro you're using and my answers may not be 100% correct, but I'll try to help. I assume your distro uses RPMs (it's hard to confirm this using the website) - you know what kind of packages you use

When it comes to RPMs, using packages for a differenet distro won't work in most cases (there are distro-independent RPMs, but rare). So you can probably use only thizlinux site (or their mirrors - if they have them).

There's a nice site with list of apt-get sites: www.apt-get.org but it won't halp you much, I think. You can enter the sites and probably even download packages, but they won't be installed.

Just a reinstall of aptget and/or synaptic won't change this. The problem is in the packages currently installed by the distro (thir dependencies and so on).

If I am right, the options for you are to upgrade using thizlinux site and/or install binary versions or compile from source if you want to have software not provided in the distro.
 
Old 02-02-2004, 12:53 PM   #3
sanger440
LQ Newbie
 
Registered: Feb 2004
Distribution: Thizlinux
Posts: 10

Original Poster
Rep: Reputation: 0
Thizlinux does use rpm packages and easily downloads and installs them from the Thizlinux site.

I was able to configure the sources.lst file and apt-get update and show the packages.

When using rpm packages, do they have to be applicable to the version of the Distro(redhat) you are running? Thizlinux is a spinoff of Redhat, but I am not sure which version.

I also tried to install mplayer using a rpm file but it failed. Then I tried with binaries, and it failed also. So I am not sure what is up with this Thinlinux Disto.
 
Old 02-04-2004, 05:33 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
You must point to the right distro and version, that's the problem. I'd guess you may try with RH9 packages (don't add them to sources for now, just download one or two RH packages and check if they install).

Where you downloaded mplayer package from? Which version was it?
 
Old 02-04-2004, 07:50 PM   #5
sanger440
LQ Newbie
 
Registered: Feb 2004
Distribution: Thizlinux
Posts: 10

Original Poster
Rep: Reputation: 0
Ok, so I will try some RPM's from RH9. Know of a good link to these rpm's?

I downloaded the mplayer binaries form the hungarian site. They seemed to compile on the ./configure command, but came up with errors on the Make command. I tried both versions of mplayers shown at the site, neither made it through the make/install process.

The only other application I have compiled and installed was gnome-apt. It installed but will now work right because my source.lst file was not right.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure apt-get to install suggested packages? davidas Debian 20 02-25-2013 01:59 AM
apt-get update errors since Debian released ( bad /etc/apt/sources.list ?) forgox Debian 10 06-13-2005 01:28 PM
configure apt-get to work with squid el_pajaro! Debian 2 05-18-2005 12:43 PM
apt-get: python2.3 configure error Captain Harlock Debian 0 08-18-2004 09:59 PM
Network devices won't configure after apt-get upgrade BertBert Linux - Networking 1 05-24-2004 12:36 PM


All times are GMT -5. The time now is 06:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration