LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2014, 10:59 AM   #1
postcd
Member
 
Registered: Oct 2013
Posts: 400

Rep: Reputation: Disabled
apt-get cant install software, unresolved dependencies


I followed this manual to instal XBMC media player and I have an unsolved dependencies there.

Code:
apt-get install xbmc
returns:
Následující balíky mají nesplněné závislosti:
xbmc : Závisí na: xbmc-bin (>= 10.0-0.5+1) ale nebude se
Závisí na: xbmc-data (>= 10.0-0.5+1)
Závisí na: xbmc-skin-confluence (>= 10.0-0.5+1)

Code:
apt-get install xbmc-bin
returns:

Následující balíky mají nesplněné závislosti:
xbmc-bin : Závisí na: libavcodec52 (>= 5:0.7.7) ale 4:0.5.10-1 se bude instalova
Závisí na: libavformat52 (>= 5:0.7.7) ale 4:0.5.10-1 se bude instalov
Závisí na: libpostproc51 (>= 5:0.7.7) ale 4:0.5.10-1 se bude instalov
Závisí na: libswscale0 (>= 5:0.7.7) ale 4:0.5.10-1 se bude instalovat

Please any idea on how to fix?


Code:
uname -a
Linux amnesia 3.10-3-486 #1 Debian 3.10.11-1 (2013-09-10) i686 GNU/Linux
 
Old 02-09-2014, 11:56 AM   #2
redd9
Member
 
Registered: Nov 2013
Location: Canada
Distribution: Ubuntu
Posts: 80
Blog Entries: 4

Rep: Reputation: 42
Well, I don't know what language that's in, but try updating your system and packages with
Code:
sudo apt-get update
Code:
sudo apt-get upgrade
 
Old 02-09-2014, 12:27 PM   #3
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by postcd View Post
I followed this manual to instal XBMC media player and I have an unsolved dependencies there.
Please any idea on how to fix?


Code:
uname -a
Linux amnesia 3.10-3-486 #1 Debian 3.10.11-1 (2013-09-10) i686 GNU/Linux
You don't have the dependencies required to install XBMC. What version of Debian are you using. Based on your kernel it should be Jessie (testing) so the instructions that you looked at for "debian squeeze" are surely out of date.

In the future please provide translations for error messages in languages other than English. Not everyone of this forum understands Czech.
jdk
 
Old 02-09-2014, 01:06 PM   #4
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,037

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
Rule Zero of having a nice time in Linux is to follow directions from trusted websites for the same version you are using.

Directions for Debian Squeeze from some random guy's blog are unlikely to give you satisfactory results. What is linuxg.net's relationship to XBMC or Debian, specifically? Personally I would begin my research on the official XBMC and/or Debian sites.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
python-apt : unresolved dependencies installing packages on Debian squeeze 6.04 marmirelo Linux - Newbie 1 04-27-2012 08:19 PM
apt-get has unmet dependencies, but apt-get -f install doesn't solve problem sophanox Linux - Software 1 02-23-2011 11:07 AM
Azureus install error on Suse 10.1 - Unresolved dependencies suse2166 SUSE / openSUSE 2 07-12-2006 07:57 PM
APT unresolved dependencies pingu Linux - Software 5 05-11-2005 10:47 AM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration