LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-06-2011, 02:50 AM   #1
anishkumarv
Member
 
Registered: Feb 2010
Location: chennai - India
Distribution: centos
Posts: 289

Rep: Reputation: 10
appache configuration issue!!!


Hi all,


Code:
<VirtualHost *:80>
ServerName www.test.anish.com
ServerAlias test.anish.com
DocumentRoot "/usr/local/tomcat/webapps/HCMOne_ver6"
<Directory "/usr/local/tomcat/webapps/HCMOne_ver6">
DirectoryIndex index.jsp index.html
Options Indexes FollowSymLinks
AllowOverride all
Order allow,deny
Allow from all
</Directory>
JkMount /HCMOne_ver6* ajp13
RewriteEngine On
RewriteLogLevel 5
RewriteLog logs/internal_rewrite_log
RewriteCond %{REQUEST_URI} !^/HCMOne_ver6/.*\.(jpe?g|gif|png|css|js)
RewriteRule ^(.*)$ /HCMOne_ver6/$1 [L,PT]
</VirtualHost>
This is my appache configuration entry!!


Actually my problem is when i access the test.anish.com it takes the index.html page as like this

but i want like this what are the configuration i need to change for that?? please guide me to solve this thread!!!
 
Old 06-06-2011, 06:25 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,761

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
Hi,

Since the vhost DocumentRoot is /usr/local/tomcat/webapps/HCMOne_ver6, the rewrite stuff is useless as the RewriteCond will never match.
Unless you mean something else, the URL http://www.test.anish.com/index.html points to the /index.html URI (without a HCMOne_ver6), so no rewrite happens.

Regards
 
Old 06-06-2011, 09:55 AM   #3
anishkumarv
Member
 
Registered: Feb 2010
Location: chennai - India
Distribution: centos
Posts: 289

Original Poster
Rep: Reputation: 10
Hi bathory,

When I call http://test.anish.com/login I see a login form.

When I submit the form I go to http://test.anish.com/auth and get authenticated.

and it should redirect to http://test.anish.com/index but it redirects instead to http://test.anish.com/Context/index

How can I get rid of that context path? Is there anything related to Proxy settings..???

Note this problem iam facing only in Google chrome Alone!!! it works in Firefox, safari and i.e

I am confused!! :-( :-(
 
Old 06-06-2011, 12:23 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,761

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
Hi,

If it works with all browsers except one, you should check the settings of this browser.
Maybe you have to clear its cache and try again. Or maybe you need to configure your application, so it's aware of the chrome user-agent string.

Regards
 
Old 06-06-2011, 08:13 PM   #5
anishkumarv
Member
 
Registered: Feb 2010
Location: chennai - India
Distribution: centos
Posts: 289

Original Poster
Rep: Reputation: 10
Hi bathory,


I too guess the same... but through ip if i access the application means it works great.


http://stackoverflow.com/questions/3...through-apache

pls view the above link...even though i did the changes which they mentioned in the post , but its working some times only...so 100% its not a browser issue..


1. I think for chrome we need to do some extra configuration in appache .

2. or we have to do anything in appache proxy settings!!
 
Old 06-07-2011, 12:32 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,761

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
Hi,

Quote:
I too guess the same... but through ip if i access the application means it works great.
Looks like chrome does some sort of dns prefetching, so try to turn it off and see f it works.

Regards
 
Old 06-07-2011, 02:23 AM   #7
anishkumarv
Member
 
Registered: Feb 2010
Location: chennai - India
Distribution: centos
Posts: 289

Original Poster
Rep: Reputation: 10
Hi bathory,

Still iam facing the Same Problem....:-( :-(
 
Old 06-07-2011, 04:04 AM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,761

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
How is your apache setup now?
You're still using mod_jk to serve jsp pages, or you've changed it to a reverse proxy?
 
Old 06-07-2011, 09:13 AM   #9
anishkumarv
Member
 
Registered: Feb 2010
Location: chennai - India
Distribution: centos
Posts: 289

Original Poster
Rep: Reputation: 10
Hi dude,

Ya we are using MOD_JK only...
 
Old 06-07-2011, 11:27 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,761

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
Doh, it may worth trying to use mod_proxy ajp as in the link you've posted above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Step by step configuration documents of FTP/DNS/MAIL/Appache/SAMBA sidharthasankar.raja Linux - Server 2 04-15-2010 06:31 AM
how to uses mod_proxy_balancer, appache procfs Linux - Software 0 06-13-2007 02:03 AM
Upgrading Appache nyumedic2000 Linux - Newbie 1 03-19-2005 03:15 PM
Appache indexing NewtonIX Linux - Software 7 08-21-2004 08:46 PM
SSI and appache jax8 Linux - Newbie 1 03-23-2004 03:15 AM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration