LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-19-2005, 01:57 PM   #1
fisheromen1031
Member
 
Registered: Jun 2004
Location: Lone Star State
Distribution: WinXP Pro, Puppy Linux, Ubuntu Warty & Hoary
Posts: 46

Rep: Reputation: 15
Angry aplay does nothing


I try using aplay to play .wav and .ogg files and i don't hear a thing nor do i get any error messages.

for example if you do
$aplay /usr/share/sounds/gaim/send.wav

i get a new line, no error messages or 'playing such and such file'. I might think it was looping but top shows it using no CPU time. i have to use ctrl+c or ctrl+alt+z to kill it. is this a device config problem maybe?

i can play things just fine with the Music Player in Gnome (i guess that is a rhythmbox derivative) and the CD player program works fine. I can even use them both at once.

I'm running Ubuntu Hoary, aplay version 1.0.8

Thanks for any help
 
Old 09-19-2005, 04:26 PM   #2
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
you HAVE un-muted the volumes right ???
By Default, all alsa channels are muted.

run alsa-config, un-mute the main channels with the M key, and use the arrow keys to adjust volumes.
 
Old 09-19-2005, 05:26 PM   #3
fisheromen1031
Member
 
Registered: Jun 2004
Location: Lone Star State
Distribution: WinXP Pro, Puppy Linux, Ubuntu Warty & Hoary
Posts: 46

Original Poster
Rep: Reputation: 15
alsa-config is not on my comp, i tried it just to double check

i used the volume control in Gnome and set the Alsa device that showed up with all the volumes unmuted. I still got the same behavior.
 
Old 09-19-2005, 08:01 PM   #4
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
I usually like to have at very least, the following alsa packages installed.

alsa-driver
alsa-libs
alsa-utils

alsa-mixer is part of alsa-utils.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone not working with arecord/aplay shengchieh Linux - Newbie 7 06-15-2009 08:09 AM
wierd problem with aplay and mplayer LinToWinWin Linux - Hardware 1 05-23-2005 06:16 PM
alsa ; compiling aplay.c vose Programming 0 01-13-2005 01:42 AM
New email sound Thunderbird with aplay? Moloko Linux - Software 0 01-02-2005 02:34 PM
APLAY sucks CPU Time brianindium Linux - General 4 06-20-2003 02:10 PM


All times are GMT -5. The time now is 02:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration