LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-01-2004, 06:07 PM   #1
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Rep: Reputation: 15
APIC error: 04(04)


I've just recently installed Mandrakelinux 10.0 on a dual booted, dual processor machine. To get the installation to even run, I had to add in noapic nolapic behind the linux install option. It worked just fine, but now when I run Linux I get the APIC error: 04(04) message scrolling over and over.

What do I do to fix this? Thanks!
 
Old 07-02-2004, 12:30 AM   #2
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Do you have a smp kernel ?

Try to boot with APIC enabled nut Local APIC disabled. So just noloapic (local APIC disabled)
 
Old 07-02-2004, 12:37 AM   #3
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
Thanks for responding, but I'm not sure what you mean.. I'm really new to all this. SMP means a multi-processor mobo, right? Yes, I have a multi-processor board, but only one processor installed. The second processor died on my some time ago. Does this make a difference?

And do I have to reinstall everything and then input just the nolapic instead of both, or is there a way for me to input a boot up command before I run Linux? The only time I input the noapic nolapic stuff was before I installed the OS.

Last edited by theAntic; 07-02-2004 at 12:47 AM.
 
Old 07-02-2004, 04:09 AM   #4
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
Re: I checked that boot thing..

Quote:
Originally posted by Vlad-A
Try to boot with APIC enabled nut Local APIC disabled. So just noloapic (local APIC disabled)
The only way I can input anything at boot up seems to be if I choose Floppy as the startup option instead of Linux, or Windows, or whatever else is listed on the boot screen. Of course, since I don't have a floppy disk in my computer it fails, but I can type in linux nolapic there at least. Unfortunately, it doesn't do anything.. neither does typing linux noapic nolapic or linux noapic.

Is there a different way to input code on a boot that I don't know about?

Last edited by theAntic; 07-02-2004 at 04:10 AM.
 
Old 07-02-2004, 10:04 AM   #5
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
What Bootloader are you using ? GRUB or Lilo ?
What distribution ?
Do you have changed something in your BIOS, w.g. setting higher CPU or bus clock ?

APIC error 40 usualy indicates that the Local APIC send a message which was not accepted
by any APIC on the Bus.

It usually means that either there are (HW) problems with your Motherboard or you increased (overclocked)
CPU and/or Bus speed.
 
Old 07-02-2004, 01:13 PM   #6
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
I believe I'm using Lilo as a Bootloader since it was the default option on the install. And I'm using the Discovery Edition of Mandrakelinux 10.0.

As for the CPU settings in my BIOS, no, I don't believe I'm overclocking since the CPU speed is set to 1600 and I have dual 1.8 Ghz Athlon MPs. My mobo does still reads as a dual processor board even though I have only one processor in it right now. Would that be a problem?
 
Old 07-02-2004, 03:28 PM   #7
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Well I use GRUB so I suggest that you consult LILO manpage on how to set up boot options.

You descibed what problems you have experienced during install. Now you see soem APIC
errors. APIC errors are always caused by Hardware. However the kernel has to be able handle them.

Did your system run for fine a while and then suddenly APIC errors are reported or do you experience
those errors from the begining on ?

Did you change something on your system, so that APIC errors started
being displayed.

An APIC 40 error can also mean that there is noise on the bus.

What additional messages are displayed with APIC error ?

Are you abele to finish the boot process and log in ?

CAn you please set also acpi=off. (Acpi is a different thing from apic)

- Please update your BIOS.
- If this does not help, then boot with a non-smp kernel.

Last edited by Vlad-A; 07-02-2004 at 03:29 PM.
 
Old 07-02-2004, 05:17 PM   #8
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
My system has always run Windows just fine, it's just when I try installing or running Linux that I get the APIC errors.. I've never had Linux work appropriately on my machine.

For instance, when I was installing Linux for the first time, all of the options I tried running (linux, vgalo, expert, text) either black-screened my monitor, or threw an APIC error: 04(04). To get around that, I input the noapic nolapic specifications after linux, and the install worked. Now, however, I get APIC errors whenever I try booting into Linux.. I never even get to the login screen.

I also haven't changed anything in the BIOS, and it's been about a year my computer's had only one processor.

I'm still confused about inputing boot commands... where exactly would I input this apic=off command? Was I correct trying to input stuff under the Floppy boot option, or is there another way to do it?
 
Old 07-03-2004, 01:33 AM   #9
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
1-1 If you have configured your system with the LILO Graphical Boot menu then do following:
As soon as the LILO menu screen is displayed press the TAB Key to stop the count-down
Press then the Escape [ESC] Key to enter the text mode
A list of available kernel images will be presented.
Enter the kernel image you would like to boot (if there is a non SMP Image, then use this) and
after the image name enter acpi=off nolapic (it's not a typo. Boot with ACPI=off. ACPI=Advanced Config and Power Interface.)

1-2 If you have LILO text menu, the press the tab key after menu is displayed to stop count-down.
Select with the arrow keys the kernel you would like to boot and enter the option
Then presss the ENTER Key to boot. You shall use acpi=off nolapic as boot options.

I hope for you that you have an US keyboard, since LILO expects a keyboard with
an US Key mapping. Typing with a non US key mapped keyboard (I have german mapping)
can be a really funny stuff :-))) Guessing what key could be what (e.g. a ")"-Key on a DE Keyboard
is a "(" on a US Keyboard)

2-1 As alraedy said an APIC Error 04 is a hardware error. Operating systems shall handle this.
It's maybe that the kernel version Mandrake 10 provides can't handle this with your motherboard.
However: The fact that an operating system can handle an APIC Error does *not* mean
that there isn't a HW problem.

2-2 If nothing helps: Update your BIOS. There are some SMP Motherboards where Linux installation
is almost impossible. In many cases an BIOS update helped.

2-3 Consider also if nothing helps to chang ethe MP setting in your BIOS from 1.1 to 1.4 or vice versa.
Also disabling IDE DMA Mode can help. Turning off "Legacy USB support" in BIOS can also be helpfull.

After you have succeed to boot into linux I suggest you choose/recompile a more recent kernel.
I *think* Mandrake provides with the Installation Media the 2.6.5 kernel.

Good Luck!

Last edited by Vlad-A; 07-03-2004 at 02:21 AM.
 
Old 07-03-2004, 02:28 PM   #10
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
I've got some good news! Your 1-1 and 1-2 suggestions worked, but only when I used the boot option linux-i686-up-4GB. I typed the acpi=off nolapic code after the boot option, like you said, and it loaded fine...

Now, am I going to have to boot up this way all the time? I don't think it's a BIOS or HW problem. You mentioned changing the kernel in linux.. How would I do that?

I checked out the Linux interface last night and was impressed! I'm starting to get the hang of this. Thanks for the help so far!
 
Old 07-03-2004, 04:16 PM   #11
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
OK. linux-i686-up-4GB is a *non* SMP (so single CPU) kernel with High Mem support.

No, you do not have to eneter acpi=off nolapic every time you boot.
You can make those changes permanent by editing your /etc/lilo.conf.

You will see something similar to following (this is my /etc/lilo.conf)

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

boot=/dev/hdb9
install=menu
default="linux2.6.7-mm2"
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz-2.6.7-mm2
label="linux2.6.7-mm2"
root=/dev/hdb10
initrd=/boot/initrd-2.6.7-mm2.img
append="devfs=mount acpi=ht resume=/dev/hdb8 splash=silent"
vga=794
read-only
image=/boot/vmlinuz-2.6.7-rc2
label="linux_(2.6.7-rc2)"
root=/dev/hdb10
initrd=/boot/initrd-2.6.7-rc2.img
append="devfs=mount acpi=ht resume=/dev/hdb8 splash=silent"
.......


Each option in the boot menu is a section in the lilo.conf starting with image=

In *your* case look for the section starting with
image=/boot/linux-i686-up-4GB

In this section you will find an option called append='.........'
Add there the entry acpi=off nolapic

You may also make linux-i686-up-4GB your default option.
Just change the entry of "default" (lilo global section) so
default='linux-i686-up-4GB'
Save your lilo.conf and run /sbin/lilo
 
Old 07-04-2004, 01:36 AM   #12
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
Wow.. so close, but still problems.

Ok, I found etc/lilo.conf and attempted to modify its contents like you instructed, but everytime I try saving the changes, I get a permissions error, specifically saying:

The document could not be saved, as it was not possilbe to write to file:/etc/lilo.conf
Check that you have write access to this file or that enough disc space is available.


I'm logged in under the admin account I created and I can save the changed file in a different location without any problems. Also, although the permissions options are grayed out, the file properties say: Owner: Can View & Modify Content

Why won't it let me update the file? Is the fact that I'm editting this in KWrite have anything to do with it?

Thank you very much for your help so far!

Last edited by theAntic; 07-04-2004 at 01:38 AM.
 
Old 07-04-2004, 03:32 AM   #13
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
I do not know what you mean by "Administrator Account".

/etc/lilo.conf can only be modified by the root user.

The error messages you see, indicates that you are
editing lilo.conf as a "normal" user, so not as root.

I do not know if you have modified the Log-In Manager so you can log-in into KDE as root,
but by default Mandrake and MdkKDE do not give you that option.

You need to start kwrite as root.

I think that it might be a good idea to replace the MdkKDE Login screen (very restrictive) with the
default KDE log-in screen. Sometimes it's really necessary to log-in as root into KDE.

- 1.0 Log in as normal user
- 1.1 Click the KDE Application button (The button with a yellow star in a blue rectangle in the lower
left corner of the display).
- 1.2 A fly-out menu will be displayed. Select now: System->Configuration->Configure your computer

-1.3 You will be prompted for the root password. Enter the root password, (you have been asked
to enter a root password during the Mandrake installation. I hope you still remember it.)

- 1.4 Now Drakeconfig will be displayed.
- 1.5 Click on the "System Icon" => System Menu is displayed
- 1.6 Click on the "Display Manager" Icon
-1.7 It's very likely that the MdkKDM (Mandrake Display Manger) is selected
Select "KDE" and press the OK Button.
- 1.8 A dialog will be displayed telling you that changes are done and asking you
if you would like to retart the display manager (dm) service
Klick teh YES Button.

- 1.9 KDE will be terminated and restarted and you now shall see the standard KDE login-screen
If KDE is not started for whatever reasons and you are still in the text screen, then simply type
kdm
at the command line and press enter. (kdm=KDE Display Manager)

- 1.10 enter under "username" root and ander password your root password in the "standard" KDE log-in dialog
and log-in

You shall now be loged in as root into KDE.

I *suggest* that you perform followning modification, since the KDE desktop screen has some restrictions in Mandrake for the
root user (e.g. Mandrake disables per default the root user to add Icons to it's KDE-Desktop)

When loged in as root in the KDE:

2.1 Click the KDE Application button (The button with a yellow star in a blue rectangle in the lower
left corner of the display).
2.2 Select System->Configuration->Configure your Desktop
2.3 Select the "LookNFeel" Item from the list in the left windows half.
The "LookNFeel" suboptions list will be expanded.
2.4 Select "Behaviour" from the suboption list. => A dialog in the right window half willl be displayed.
2.5 Check the "Show Icons on Desktop" Option in the dialog in the right window half *and*
take a look on the "Mouse Button Action" Section.
Select there for "Right Button" from the drop-down list for this Button: "Desktop Menu"
2.6 Click on the "Apply" Button and close the KDM Desktop Manager


Now you can start kwrite as root

E.G: Start a console from the KDE Application list
Click the KDE Application Button and select from the fly-out menu:
System->Terminal->Konsole
type into the console window:
kwrite /etc/lilo.conf

CAUTION: The root can access everything, which means he can also destroy everything (in 99.99% of the cases
not by intention but by accident) Therefore log in as root only when absolutely necessary.

Last edited by Vlad-A; 07-06-2004 at 03:02 AM.
 
Old 07-06-2004, 02:02 AM   #14
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
SUCCESS!! This was some excellent help!

Just so you know, I did successfully log into root and altered my boot proceedure like you showed. Linux boots up by default in the non-SMP mode and has included the acpi=off nolapic code you taught me. I can now officially use Linux on my machine, something I wouldn't have done without having fixed this APIC issue I can assure you.

I have just one last question regarding dual processors.. If I ever got both processors going again, would I have to change the way I boot into Linux then, or would it work irregardless?

THANKS AGAIN!

Last edited by theAntic; 07-06-2004 at 02:04 AM.
 
Old 07-06-2004, 02:49 AM   #15
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Firts of all: CONGRATULATIONS!!!!!!!

With a second processor you shall use the smp kernel.

What I would do in this case is:

Boot the system with a second processor inserted. Select from the LILO boot menu the SMP kernel
If there are problems, then use as boot options for the second kernel acpi=off and if this also fails
then acpi=off nolapic.

Once boot is successfull, change your lilo.conf making the smp kernel the default option in the boot menu.
If needed add also the boot options (like acpi=off, etc.) for the smp kernel in lilo.conf.

Now you know how to do this.

Do not forget to run /sbin/lilo after changing lilo.conf.

Also check from time to time with
cat /proc/interrupts
the Errors (ERR) counter (at the end of the displayed list)

Last edited by Vlad-A; 07-06-2004 at 07:14 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone know why i get APIC error on CPU1? methodh2k Linux - General 5 10-13-2005 06:28 AM
kernel: APIC error on CPU1: 02(02) Cronjob Linux - Hardware 1 03-22-2005 10:24 PM
APIC error: 04(04).. theAntic Linux - Software 0 07-01-2004 07:47 PM
APIC error jonfa Linux - General 2 06-10-2004 02:54 PM
XT-PIC vs. IO-APIC-edge vs. IO-APIC-level pebraun Linux - Newbie 0 04-19-2004 05:10 PM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration