LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2012, 10:01 AM   #1
gregAstley
LQ Newbie
 
Registered: Aug 2012
Distribution: ubuntu 11.10
Posts: 27

Rep: Reputation: 4
apache2 still looking at var/www somehow


Hi guys - I have installed apache2 on my system and want to change my default directory from:

/var/www/ to, say
/home/greg/Documents/programming/php/www/

I've done as much searching as I can with google on this problem but I'm still having trouble trying to have my browser look in a different directory than /var/www/ when I visit http://localhost. Indeed I can't see anything (useable that is) that even knows about /var/www/ with all the messing I've done yet still something knows about it

The steps I've carried to do this out are:
0) made the directory above (with a different index.html file)
1) copied (within sites-available) the 000-default file to a file name mySite and changed the directory paths as above (in two instances: DocumentRoot ... and <Directory ...>)
2) run the commands: (I ought to learn exactly what these are doing later) a2dissite default, a2ensite mySite
3) restarted apache2 with service apache2 restart
4) cleared the cache in firefox (because googling for my problem, I found this was a solution for someone else)
5) typed http://localhost in my searchbar

result: I'm still going to var/www/ (because I'm seeing the index.html in there and not my new one)

I've also edited my (previously empty) httpd.conf file such that it reads as follows:

ServerName localhost
DocumentRoot /home/greg/Documents/programming/php/www/

I've tried grepping (recursively) for the string "var/www/" in /etc/ and only found the backup files I made of the files 000-default and default-ssl (and I have renamed these just in case they're somehow being loaded - yeah I'm just trying anything) I'm running out of ideas (and coming up short on google).


Could there be something incredibly simple I've forgotton? Is there perhaps some configuration file associated to apache (or ubuntu itself) that needs to be changed?

Last edited by gregAstley; 08-18-2012 at 10:37 AM. Reason: trying to make my OP make sense
 
Old 08-18-2012, 11:59 AM   #2
j9x.inca
Member
 
Registered: Jul 2012
Location: Fort Drum, NY, US
Distribution: Arch Linux
Posts: 63

Rep: Reputation: 2
Quote:
Originally Posted by gregAstley View Post
Hi guys - I have installed apache2 on my system and want to change my default directory from:

/var/www/ to, say
/home/greg/Documents/programming/php/www/

I've done as much searching as I can with google on this problem but I'm still having trouble trying to have my browser look in a different directory than /var/www/ when I visit http://localhost. Indeed I can't see anything (useable that is) that even knows about /var/www/ with all the messing I've done yet still something knows about it

The steps I've carried to do this out are:
0) made the directory above (with a different index.html file)
1) copied (within sites-available) the 000-default file to a file name mySite and changed the directory paths as above (in two instances: DocumentRoot ... and <Directory ...>)
2) run the commands: (I ought to learn exactly what these are doing later) a2dissite default, a2ensite mySite
3) restarted apache2 with service apache2 restart
4) cleared the cache in firefox (because googling for my problem, I found this was a solution for someone else)
5) typed http://localhost in my searchbar

result: I'm still going to var/www/ (because I'm seeing the index.html in there and not my new one)

I've also edited my (previously empty) httpd.conf file such that it reads as follows:

ServerName localhost
DocumentRoot /home/greg/Documents/programming/php/www/

I've tried grepping (recursively) for the string "var/www/" in /etc/ and only found the backup files I made of the files 000-default and default-ssl (and I have renamed these just in case they're somehow being loaded - yeah I'm just trying anything) I'm running out of ideas (and coming up short on google).


Could there be something incredibly simple I've forgotton? Is there perhaps some configuration file associated to apache (or ubuntu itself) that needs to be changed?
Try this:
Code:
find / | grep httpd.conf
then edit wherever it's at, probably /etc/httpd/httpd.conf, and look for DocumentRoot and change it there, then restart apache.
 
Old 08-18-2012, 12:07 PM   #3
gregAstley
LQ Newbie
 
Registered: Aug 2012
Distribution: ubuntu 11.10
Posts: 27

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by j9x.inca View Post
Try this:
Code:
find / | grep httpd.conf
then edit wherever it's at, probably /etc/httpd/httpd.conf, and look for DocumentRoot and change it there, then restart apache.
Hi, thanks for your response, I tried that and the result was:

greg@greg-Aspire-5742:/$ sudo find / | grep httpd.conf
/etc/apache2/httpd.conf
greg@greg-Aspire-5742:/$

the only thing it found was the one that started off as empty and now contains:

ServerName localhost
DocumentRoot /home/greg/Documents/programming/php/www/
 
Old 08-18-2012, 12:14 PM   #4
j9x.inca
Member
 
Registered: Jul 2012
Location: Fort Drum, NY, US
Distribution: Arch Linux
Posts: 63

Rep: Reputation: 2
Quote:
Originally Posted by gregAstley View Post
Hi, thanks for your response, I tried that and the result was:

greg@greg-Aspire-5742:/$ sudo find / | grep httpd.conf
/etc/apache2/httpd.conf
greg@greg-Aspire-5742:/$

the only thing it found was the one that started off as empty and now contains:

ServerName localhost
DocumentRoot /home/greg/Documents/programming/php/www/
That is weird your httpd.conf is so bare, but you could either try uninstalling apache and reinstalling, or editing the DocumentRoot from /home/greg/Documents/programming/php/www to whatever you want your www dir to be.
 
Old 08-18-2012, 12:26 PM   #5
gregAstley
LQ Newbie
 
Registered: Aug 2012
Distribution: ubuntu 11.10
Posts: 27

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by j9x.inca View Post
That is weird your httpd.conf is so bare, but you could either try uninstalling apache and reinstalling, or editing the DocumentRoot from /home/greg/Documents/programming/php/www to whatever you want your www dir to be.
hi again. Aye it is bare (it started off as empty and now only contains directives I found on google (the first to fix an error restarting apache, and the second trying in vain to look at my new directory)) the file which I think has the stuff httpd.conf would have is /etc/apache2/apache2.conf:

Code:
# Based upon the NCSA server configuration files originally by Rob McCool.
#
# This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.2/ for detailed information about
# the directives.
#
# Do NOT simply read the instructions in here without understanding
# what they do.  They're here only as hints or reminders.  If you are unsure
# consult the online docs. You have been warned.  
#
# The configuration directives are grouped into three basic sections:
#  1. Directives that control the operation of the Apache server process as a
#     whole (the 'global environment').
#  2. Directives that define the parameters of the 'main' or 'default' server,
#     which responds to requests that aren't handled by a virtual host.
#     These directives also provide default values for the settings
#     of all virtual hosts.
#  3. Settings for virtual hosts, which allow Web requests to be sent to
#     different IP addresses or hostnames and have them handled by the
#     same Apache server process.
#
# Configuration and logfile names: If the filenames you specify for many
# of the server's control files begin with "/" (or "drive:/" for Win32), the
# server will use that explicit path.  If the filenames do *not* begin
# with "/", the value of ServerRoot is prepended -- so "foo.log"
# with ServerRoot set to "/etc/apache2" will be interpreted by the
# server as "/etc/apache2/foo.log".
#

### Section 1: Global Environment
#
# The directives in this section affect the overall operation of Apache,
# such as the number of concurrent requests it can handle or where it
# can find its configuration files.
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the LockFile documentation (available
# at <URL:http://httpd.apache.org/docs/2.2/mod/mpm_common.html#lockfile>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
LockFile ${APACHE_LOCK_DIR}/accept.lock

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5

##
## Server-Pool Size Regulation (MPM specific)
## 

# prefork MPM
# StartServers: number of server processes to start
# MinSpareServers: minimum number of server processes which are kept spare
# MaxSpareServers: maximum number of server processes which are kept spare
# MaxClients: maximum number of server processes allowed to start
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# worker MPM
# StartServers: initial number of server processes to start
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadLimit: ThreadsPerChild can be changed to this maximum value during a
#              graceful restart. ThreadLimit can only be changed by stopping
#              and starting Apache.
# ThreadsPerChild: constant number of worker threads in each server process
# MaxClients: maximum number of simultaneous client connections
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75 
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# event MPM
# StartServers: initial number of server processes to start
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadsPerChild: constant number of worker threads in each server process
# MaxClients: maximum number of simultaneous client connections
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_event_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75 
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#

AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being 
# viewed by Web clients. 
#
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy all
</Files>

#
# DefaultType is the default MIME type the server will use for a document
# if it cannot otherwise determine one, such as from filename extensions.
# If your server contains mostly text or HTML documents, "text/plain" is
# a good value.  If most of your content is binary, such as applications
# or images, you may want to use "application/octet-stream" instead to
# keep browsers from trying to display binary files as though they are
# text.
#
DefaultType text/plain


#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel warn

# Include module configuration:
Include mods-enabled/*.load
Include mods-enabled/*.conf

# Include all the user configurations:
Include httpd.conf

# Include ports listing
Include ports.conf

#
# The following directives define some format nicknames for use with
# a CustomLog directive (see below).
# If you are behind a reverse proxy, you might want to change %h into %{X-Forwarded-For}i
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
Include conf.d/

# Include the virtual host configurations:
Include sites-enabled/
and in it there seems to be no reference to the document root (though it includes whatever's in sites-enabled which specifies the document root (in my case not /var/www/ !))

As a sanity check, what follows is the contents of the sites-enabled directory and whats in the one file sitting there:
greg@greg-Aspire-5742:/etc/apache2/sites-enabled$ ls
mySite
greg@greg-Aspire-5742:/etc/apache2/sites-enabled$
Code:
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /home/greg/Documents/programming/php/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/greg/Documents/programming/php/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
I'm thinking a re-install might be the way to go but I haven't got the faintest idea what's telling my browser to look in the wrong place (some hard-coded default!?)

Last edited by gregAstley; 08-18-2012 at 12:30 PM.
 
Old 08-18-2012, 12:29 PM   #6
j9x.inca
Member
 
Registered: Jul 2012
Location: Fort Drum, NY, US
Distribution: Arch Linux
Posts: 63

Rep: Reputation: 2
I'd do a clean install. What Distro are you using?
 
Old 08-18-2012, 12:35 PM   #7
gregAstley
LQ Newbie
 
Registered: Aug 2012
Distribution: ubuntu 11.10
Posts: 27

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by j9x.inca View Post
I'd do a clean install. What Distro are you using?
I'm on Ubuntu 11.10 (I know I could upgrade to 12.04 but since it isn't broken I don't want to fix it (especially not until until the external hardrive I've ordered has arrived))

Last edited by gregAstley; 08-18-2012 at 01:21 PM.
 
Old 08-18-2012, 01:41 PM   #8
gregAstley
LQ Newbie
 
Registered: Aug 2012
Distribution: ubuntu 11.10
Posts: 27

Original Poster
Rep: Reputation: 4
The workaround (just to keep things logical for me) I'm going to go with for now is to make a symlink to /var/www/ from within /home/greg/Documents/programming/php/www/

I don't know if I should mark this as solved since though I can get sort of what I want, I haven't got the foggiest idea what's going wrong trying to do it properly! But thanks again for your help anyway :]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Run php web project on apache2 using /var/www fortran Linux - Server 6 03-29-2012 08:34 AM
Apache2 root server showing directory contents of a symbolic link in the /var/www dir rtoney5 Linux - Server 7 09-03-2010 08:50 PM
/var/www domain name help illNino Linux - Newbie 6 11-05-2009 12:58 AM
apache2 folder 'var/www' is not shareable; can not edit the index.html file mcanallyd Linux - Newbie 2 06-18-2009 06:46 PM
Moving /var/www/ 2-tone-joe Linux - Server 2 12-01-2007 02:27 PM


All times are GMT -5. The time now is 03:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration