LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-03-2008, 05:54 PM   #1
le Stone
LQ Newbie
 
Registered: Sep 2008
Posts: 8

Rep: Reputation: 0
Question Apache2 not working on Debian


New waters for me.

I have Debian setup, and installed apache2 using
apt-get install apache2

However, when I try to view the default page in a web browser from another machine on my network, it doesn't get anything back from the server (unresponsive).

I haven't touched any of the conf files. Not sure why it's not working.
Any help would be greatly appreciated!

TIA
 
Old 10-03-2008, 06:04 PM   #2
klearview
Member
 
Registered: Aug 2006
Location: London
Distribution: Debian, Kubuntu
Posts: 572

Rep: Reputation: 75
It's unlikely to be apache problem. Most likely - networking issue. Make sure apache is running - 'ps ax | grep apache'. If it does -see if you can see it from the server itself - 'lynx localhost' (install lynx if it's not installed already)
 
Old 10-03-2008, 06:15 PM   #3
le Stone
LQ Newbie
 
Registered: Sep 2008
Posts: 8

Original Poster
Rep: Reputation: 0
You're right!

with
lynx 192.168.0.49
it shows "It works!"

So...what could be causing my other machines not to see it? I can ping 192.168.0.49 fine. How would I test whether or not port 80 is sending/receiving data properly?

Last edited by le Stone; 10-03-2008 at 06:18 PM.
 
Old 10-03-2008, 06:27 PM   #4
le Stone
LQ Newbie
 
Registered: Sep 2008
Posts: 8

Original Poster
Rep: Reputation: 0
OK now

For some reason it's working now. Maybe a loose cable or something.

Thanks klearview.
 
Old 10-03-2008, 06:30 PM   #5
klearview
Member
 
Registered: Aug 2006
Location: London
Distribution: Debian, Kubuntu
Posts: 572

Rep: Reputation: 75
Do you have firewall set up on Debian server? Check your firewall rules with 'iptables -L' (as root)
 
Old 10-06-2008, 03:21 PM   #6
le Stone
LQ Newbie
 
Registered: Sep 2008
Posts: 8

Original Poster
Rep: Reputation: 0
No firewall

No, I don't see anything setup when I look at the iptables. And it seems to be working fine now. I think it was a cable issue.
Thanks again.
 
  


Reply

Tags
apache2, debian


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 on Debian Etch not working finferflu Linux - Server 28 02-24-2011 06:03 AM
php5 not working with apache2 in debian 4.0 mohtasham1983 Linux - Server 2 08-08-2007 10:19 PM
apache2 on debian etch: SSL not working t0bias Linux - Server 1 06-01-2007 07:46 AM
debian, apache2, ipcop and vhosts not working TheSpork Linux - Networking 1 06-04-2005 06:01 PM
debian + apache2 alaios Debian 2 05-31-2005 06:05 AM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration