LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2012, 04:43 AM   #1
khun
LQ Newbie
 
Registered: May 2012
Posts: 4

Rep: Reputation: Disabled
Apache2 Configuration or Wordpress Configuration: Wordpress index.php not loading


Hi I'm a newbbe here and I'm new to both apache and wordpress as well. I recently install a wordpress on a debian web server running with apache2. Someone already set up securities configuration on the server and all i need to do is to install a wordpress them and use it. But what i find out is that when i install the wordpress theme, everything is functioning properly but the index.php is not loading. Instead the website load 404.php. I try to add DireactiveIndex index.php in the .htaccess but it show me error. when i check dir.conf in the apache2, DireactiveIndex index.php index.html is there. So, i don't know what to do anymore. Please if there is anyone who can enlighten me, I would be very appreciative.

my english is not good either

regards

Khun
 
Old 05-17-2012, 04:55 AM   #2
rahulchandrak
Member
 
Registered: Apr 2010
Posts: 33

Rep: Reputation: 2
Hi Khun, Welcome to linuxquestions.org portal.

I hope PHP is installed correctly and configured correctly with Apache. To make sure, create a file in htdocs folder of apache and insert the following code

<?php
// Show all information, defaults to INFO_ALL
phpinfo();
?>

Try to access the page and see whether PHP information is getting shown or not.
 
Old 05-17-2012, 05:23 AM   #3
khun
LQ Newbie
 
Registered: May 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
thank you so much for your response. I think the PHP is installed correctly because when i open my wordpress, it load everything except the index.php. it does load all the category pages and posts in each category page. it load pages as well. but in the home page, instead of loading the index.php, it's loading 404.php i think. because it's also displaying headers and sidebar. those functions are called in 404.php.

i don't know if i'm confusing you. But i really appreciate for you help. I hope someone can help me.

regards

Khun aung
 
Old 05-17-2012, 06:41 AM   #4
khun
LQ Newbie
 
Registered: May 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
hi

I tried as rahulchandrak suggested me to. I add phpinfo function and open it. everything seem to be fine.
 
Old 05-18-2012, 05:08 AM   #5
rahulchandrak
Member
 
Registered: Apr 2010
Posts: 33

Rep: Reputation: 2
Hi khun,

Based on your explanation, I guess the problem is with the wordpress theme/plugin which you are using and not with wordpress setup. Generally in wordpress all the pages/posts are driven from index.php only, I would recommend you to take a look at the index.php file and find out which one is missing.
 
Old 05-18-2012, 09:26 AM   #6
khun
LQ Newbie
 
Registered: May 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
dear rahulchandrak,

thank you so much for your help. But the problem is that it's happening in other themes as well. I've tried to uninstall all the plugin installed previously. only a few plug in were installed.

thank

Khun
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu + Apache2 + Wordpress Silver565 Linux - Server 8 12-15-2011 02:34 AM
Multiple Site Installation/Configuration not working on WordPress 3.0 rtoney5 Linux - Software 2 10-19-2010 06:58 PM
How to change the default webpage configuration from index.php to index.htm, etc meema Linux - Server 4 08-22-2008 10:06 PM
wordpress index page is not working as before ilnli General 6 03-28-2007 03:45 PM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration