LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-22-2010, 11:31 PM   #16
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,395
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903

So now we have learned that the router is probably not forwarding from the WAN side of your connection. In a Linux based firewall, we would normally do this in two stages:
1. mangle the packet, so that the destination port is now the port used by the server.
2. re-send the packet on the LAN interface, to the LAN server host.
Do these steps make any sense in terms of how your router setup is done? Are you sure that some other rule is not swallowing the packet in the router, or sending it somewhere else?

--- rod
 
Old 05-22-2010, 11:54 PM   #17
evaristegalois
Member
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 32

Original Poster
Rep: Reputation: 15
I did not change the apache conf files at all except add

Quote:
# added servername to avoid the could not determine fqdn error
ServerName myname.homelinux.org
to apache2.conf

Quote:
sudo apache2ctl start
starts without error message and I can see http://192.168.0.150 just fine (the 'it's working' index file). But that's local. I to doesn't seem to get out on port 80.

I put a screenshot of my router settings at

http://www.streetgreek.com/anderson/di-624.png
 
Old 05-23-2010, 10:34 AM   #18
evaristegalois
Member
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 32

Original Poster
Rep: Reputation: 15
I didn't add anything to my apache configuration files except

# added servername to avoid the could not determine fqdn error
ServerName myname.homelinux.org

to apache2.conf. So if I need to do anything else please let me know. (Although, as I said, apache works locally.)

Here is a screenshot of my router settings:

http://www.streetgreek.com/anderson/di-624.png

(And ssh-ing in works from an external computer, so port 22 is open, which is confirmed by doing a port check on http://ping.eu/port-chk/, whereas port 80 is closed, also confirmed by http://ping.eu/port-chk/ -- )

Last edited by evaristegalois; 05-23-2010 at 10:36 AM.
 
Old 05-23-2010, 10:57 AM   #19
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,933
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
Quote:
Originally Posted by evaristegalois View Post
I didn't add anything to my apache configuration files except

# added servername to avoid the could not determine fqdn error
ServerName myname.homelinux.org

to apache2.conf. So if I need to do anything else please let me know. (Although, as I said, apache works locally.)

Here is a screenshot of my router settings:

http://www.streetgreek.com/anderson/di-624.png

(And ssh-ing in works from an external computer, so port 22 is open, which is confirmed by doing a port check on http://ping.eu/port-chk/, whereas port 80 is closed, also confirmed by http://ping.eu/port-chk/ -- )
You may and or may not what to do this (but it's for debugging purposes only)...

But have you tried turning off your firewall on your gateway/router to see if that works?

That way you can see if its a firewall issue or if its a forwarding issue....
 
Old 05-23-2010, 02:04 PM   #20
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,395
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Quote:
(And ssh-ing in works from an external computer, so port 22 is open, which is confirmed by doing a port check on http://ping.eu/port-chk/, whereas port 80 is closed, also confirmed by http://ping.eu/port-chk/ -- )
So there seems to be some inconsistency between what your router is doing, and what it claims to be doing. Perhaps the router is FUBAR. Can you try power cycling the router?
--- rod.
 
Old 05-23-2010, 04:07 PM   #21
evaristegalois
Member
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 32

Original Poster
Rep: Reputation: 15
I just found out that if I turn on Remote Management on my router (on port 80), it opens up port 80, but the http://myname.homelinux.org goes to my router, not to my apache index page. So the router seems to be fine, now I just need to figure out how to forward it to my desktop.

Last edited by evaristegalois; 05-23-2010 at 04:19 PM.
 
Old 05-23-2010, 04:19 PM   #22
evaristegalois
Member
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 32

Original Poster
Rep: Reputation: 15
I just found out that there is a tiny button I needed to enable on the router, which I failed to do. Problem solved. Many thanks!

Last edited by evaristegalois; 05-23-2010 at 04:35 PM.
 
Old 05-23-2010, 05:45 PM   #23
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,395
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
For the benefit of others who may read this in the future, (and for my curiosity) can you give enough detail about the tiny, but magical, button that others may not fall victim to the same trap?

--- rod.
 
Old 05-25-2010, 12:48 AM   #24
evaristegalois
Member
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 32

Original Poster
Rep: Reputation: 15
You can see it on my screenshot provided above. You need to click on the edit icon for the http virtual server and then click on `enable'. Then the square box next to the virtual server line will be checked rather than unchecked (which it is in the screenshot). Thanks again for your help. Couldn't do it without you guys.
 
  


Reply

Tags
apache, server, web


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 11 - Apache works locally but not from a different machine vuhuynh Linux - Newbie 5 08-26-2009 07:09 AM
sendmail: can receive all; send locally, but not globally gesho Linux - Server 2 09-17-2007 09:34 PM
biff works over ssh but not locally (in Konsole) jashmenn Slackware 0 03-17-2006 07:23 PM
tightVNC works locally but not remotely? mikeli Linux - Software 2 02-01-2005 04:48 AM
sendmail - works locally but not from outside ereeno Linux - Software 5 02-03-2004 12:40 AM


All times are GMT -5. The time now is 10:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration