LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-01-2004, 03:03 AM   #1
ukrainet
Member
 
Registered: Nov 2004
Posts: 108

Rep: Reputation: 15
apache server starting problem


As it is better to restart a apache-server from a name root or apache?
 
Old 12-01-2004, 03:22 AM   #2
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
I think either or is fine. Never really started apache with different user besides root. Even if you started apache as root it will run as the user that is specified in the .conf file.


-twantrd
 
Old 12-01-2004, 04:01 AM   #3
ukrainet
Member
 
Registered: Nov 2004
Posts: 108

Original Poster
Rep: Reputation: 15
I have restarted apache by
/etc/rc.d/init.d/httpd graceful as a root.
But my website doesn't work still. In error_log I have found:
cannot remove module mod_userdir.c not found in module list
Apache configured -- resuming normal operations
Accept mutex: sysvsem (Default: sysvsem)
after restarting.
How to adjust work of website?
 
Old 12-01-2004, 04:57 AM   #4
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
Code:
apachectl configtest
will tell you if theres anything wrong with your syntax in the config files, fix whats wrong.
then
Code:
apachectl stop
apachectl start
should work now.

linux_terror

NOTE: If apachectl is not in your $PATH and you get 'command not found' then locate it
Code:
updatedb
locate apachectl

Last edited by linux_terror; 12-01-2004 at 05:01 AM.
 
Old 12-01-2004, 05:32 AM   #5
ukrainet
Member
 
Registered: Nov 2004
Posts: 108

Original Poster
Rep: Reputation: 15
apachectl configtest such as
/etc/rc.d/init.d/httpd configtest:
Syntax OK
[error] Cannot remove module mod_userdir.c not found in module list
apachectl stop
httpd stopped
apachectl start
httpd started with SSl enabled
But it doesn't work when I try to reflect my website in web-browser (Internal Server Error)
 
Old 12-01-2004, 05:15 PM   #6
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
Is the website that you are trying to reflect in the webroot or is this a user directory such as ~/public_html ? You may just have to add

LoadModule userdir_module modules/mod_userdir.so

to your httpd.conf , customizing the path to your modules directory if need be. Please post a bit more about your configuration if that doesn't work.

linux_terror.
 
Old 12-02-2004, 02:30 AM   #7
ukrainet
Member
 
Registered: Nov 2004
Posts: 108

Original Poster
Rep: Reputation: 15
LoadModule userdir_module libexec/mod_userdir.so is present in httpd.conf.

A website on the Internet www.credo-capital.com. It works under management apache which is established on Linux9 (kernel 2.4). All this time the site worked normally. But on Monday, on November, 29, when I tried to load a site by web-browser (Opera 7.54) on a workstation which is in a local network, I have received mistake Internal Server Error on the screen.
I tried to overload a computer and service httpd (/etc/rc.d/init.d/httpd graceful). But it has not helped.
I have seen log-files and something have found:
/usr/local/apache/logs/access_log
192.168.0.9 - - 25 Nov 17:16 "\x80L\x01\x03" 501
192.168.0.9 - - 25 Nov 17:16 "\x80L\x01\x03" 501 "-" "-"
/usr/local/apache/logs/error_log
Thu Nov 25 [192.168.0.9] error invalid metod in request x80L\x01\x03
cannot remove module mod_userdir.c not found in module list
Apache configured - resuming normal operations
Accept mutex: sysvsem (Default: sysvsem)
192.168.0.9 IP-address in LAN
/var/www/sites/credo-capital.com/logs/error_log
Mon Nov 29 09:50 2004 [error] [client 207.46.98.75] File does not exist:/var/www/sites/...
Mon Nov 29 09:50 2004 [error] mod_ruby: error in ruby
/var/www/sites/... 'connect': could not connect to server: connection refused (SQL::ConnError)
Is the server running on host localhost and accepting TCP/IP connection on port 5432?

There 3 sites in /var/www/sites/: credo-capital.com, mail.credo-capital.com, tc.credo-capital.com. tc.credo-capital.com works quite good.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache server not starting waelaltaqi Linux - Software 5 11-08-2005 08:53 PM
Starting Apache web server automatically gslater Linux - Newbie 4 05-09-2004 02:44 PM
Problem Starting Apache with SSL -- URGENT kaplan71 Linux - General 0 02-09-2004 08:10 AM
Problem starting apache nrmx Linux - Networking 2 03-13-2003 11:31 PM
Problem starting Apache Web Server kutubjt Linux - Newbie 2 04-04-2001 01:31 AM


All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration