LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2016, 02:20 PM   #1
irish2
LQ Newbie
 
Registered: May 2015
Posts: 6

Rep: Reputation: Disabled
Apache running but not serving pages.


I have just done a clean install of apache on RedHat. In the httpd.conf file, I have changed the ServerName to the IP address of the computer. From the command line, when I use xdg-open I cannot view the test page from the apache server (when using the public IP in the address bar), however I can see it when I open 127.0.0.1. I have a rule in my firewall to allow traffic on port 80.

Is there a way to debug this?
 
Old 05-19-2016, 04:56 PM   #2
TenTenths
Senior Member
 
Registered: Aug 2011
Location: Dublin
Distribution: Centos 5 / 6 / 7
Posts: 2,339

Rep: Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825
First steps I usually try:
Ensure your "Listen" directives in your config file are correct.
Ensure you've restarted apache after any config change and that the syntax is correct. apachectl configtest and (in a production environment) apachectl graceful are your friends here.
Run httpd -S to show what configs and domains etc. apache is listening for.
Run netstat -lnp and confirm that apache is listening on the addresses it should be.
 
Old 05-19-2016, 05:24 PM   #3
Habitual
LQ Addict
 
Registered: Jan 2011
Posts: 7,826
Blog Entries: 11

Rep: Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111Reputation: 2111
Code:
ServerName localhost
in /etc/httpd/conf/httpd.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache on Debian Virtualbox guest serving old pages after reboot austinium Linux - Newbie 5 10-10-2014 05:45 AM
Apache serving blank pages??? Any ideas helptonewbie Linux - Server 15 08-22-2008 05:37 AM
Apache not serving PHP5 pages rfw62 Linux - Newbie 3 03-06-2008 07:55 PM
Apache not serving pages bcf2 Linux - Software 1 11-22-2005 03:46 AM
Redhat 9, apache + frontpage not serving pages except admin page JRinOKC Linux - Newbie 5 01-12-2004 02:58 AM


All times are GMT -5. The time now is 02:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration