LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2006, 06:22 PM   #1
cashton2k
Member
 
Registered: May 2004
Posts: 46

Rep: Reputation: 15
apache on UNIX


where is the httpd.conf file in apache on UNIX? i cant find it lol

apache appears to installed under /var/www

but that directory only contains cgi-bin, error, html, manual

cheers for any help
 
Old 01-12-2006, 06:25 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
On a Debian GNU/Linux system, it's under /etc/apache (or /etc/apache2).
 
Old 01-12-2006, 06:35 PM   #3
silmaril8n
Member
 
Registered: May 2004
Location: Vancouver, WA
Distribution: Mint, Debian, Slackware
Posts: 123

Rep: Reputation: 15
Same goes for Slackware.
 
Old 01-12-2006, 06:36 PM   #4
cashton2k
Member
 
Registered: May 2004
Posts: 46

Original Poster
Rep: Reputation: 15
how can i edit the httpd file?
 
Old 01-12-2006, 06:39 PM   #5
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
apache runs on Linux?? who woulda known...lol... are you in a terminal or wanting to edit in an gui app? in a terminal as root type nano /etc/apache/httpd.conf <- (nano is easier for newbies) edit it then exit and save. In gedit, kedit, etc. Browse to it and edit it, again as root
 
Old 01-12-2006, 06:43 PM   #6
cashton2k
Member
 
Registered: May 2004
Posts: 46

Original Poster
Rep: Reputation: 15
there isnt a /etc/apache folder

httpd is in the /etc directory

accessing a unix box thru ssh

there isnt nano,gedit,kedit
 
Old 01-12-2006, 06:48 PM   #7
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
then vi, vim, or emacs....... i would read over the commands real quick though before you start
 
Old 01-12-2006, 07:15 PM   #8
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
Have you tried running:

Code:
find / -type f -name 'httpd.conf'
It's slow, but it'll work.
 
Old 01-12-2006, 08:57 PM   #9
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
pico is another good editor y that.(clone of nano). Tr
 
Old 01-12-2006, 09:03 PM   #10
cashton2k
Member
 
Registered: May 2004
Posts: 46

Original Poster
Rep: Reputation: 15
any idea where htpasswd might be?
 
Old 01-12-2006, 09:26 PM   #11
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
On my system it's under /usr/local/apache2/bin. If you found the httpd.conf file with the find command earlier, then from that directory type:

Code:
cd ../bin
I'd suggest running find again if that doesn't work:

Code:
find / -type f -name 'htpasswd'
 
Old 01-13-2006, 09:52 AM   #12
cashton2k
Member
 
Registered: May 2004
Posts: 46

Original Poster
Rep: Reputation: 15
cheers for the help guys

next question lol

i cant update my index.htm file, everythime i vi a updated one i still get ther original when i try and browse the server

any ideas?

cheers
 
Old 01-13-2006, 10:32 AM   #13
muha
Member
 
Registered: Nov 2005
Distribution: xubuntu, grml
Posts: 451

Rep: Reputation: 37
hmm, these settings are for linux ... dont know what will work for you ...
1. make sure your pages in the right place.
view the setting for your apache over here (for apache2):
cat /etc/apache2/default-server.conf
Code:
<SNIP>
DocumentRoot "/srv/www/htdocs"
<SNIP>
2. So what do you get when you go to:
http://localhost/
Is it the same as what's in this dir: /srv/www/htdocs ?

3. clear the cache in your browser and restart your browser

4. check the permissions in /srv/www/htdocs to see whether it's not a permissions problem.

5. what version apache is it?

Last edited by muha; 01-13-2006 at 10:34 AM.
 
Old 01-13-2006, 10:35 AM   #14
cashton2k
Member
 
Registered: May 2004
Posts: 46

Original Poster
Rep: Reputation: 15
i dont have a /srv/www/htdocs directory
 
Old 01-13-2006, 10:42 AM   #15
muha
Member
 
Registered: Nov 2005
Distribution: xubuntu, grml
Posts: 451

Rep: Reputation: 37
have you found httpd.conf? Which document-root does it point to?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache/1.3.31 (Unix) Startup, NEED help w0lv3rin3 Linux - Software 1 10-24-2004 12:11 PM
Making apache .htaccess use unix passwords Mikessu Linux - Networking 0 07-01-2004 02:05 AM
Why did you experienced users of Unix change to unix over Windows? Laptop2250 Linux - General 11 10-28-2003 12:51 PM
The Best Method to install Set up a Unix System with PERL, PHP and Apache rhuser Linux - Software 1 03-01-2003 11:31 PM
man.linuxquestions.org is running Apache/1.3.24 (Unix) PHP/4.2.0 rverlander LQ Suggestions & Feedback 3 09-08-2002 01:50 AM


All times are GMT -5. The time now is 04:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration