LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-20-2012, 03:05 PM   #1
babar546
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Rep: Reputation: Disabled
Lightbulb apache not working through external ip


i install apche on windows xp, and it works fine @ localhost

but when i try to access it through my ip from internet, it shows my router page, i open my port 80 for forwarding data.
and i also check this port through asoftware and it shows me that port 80 is open and reachable. but yet i am not connect to apache through external ip.

when i try to open port 80 , it tells me as port 80 is in use so port 80 move to 8080.

i check pid no application is using port 80 but when i try to open it it tells me port 80 is being in use

plz any one can help me what should i do. my port is open and forwarding well, but i am accessing my router page through external ip or through my domain.



plz tell me as my ip move to 8080 how i can configure apache for port 8080

Last edited by babar546; 12-20-2012 at 03:08 PM.
 
Old 12-20-2012, 03:50 PM   #2
babar546
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
plzzz help
 
Old 12-20-2012, 06:27 PM   #3
sharadchhetri
Member
 
Registered: Aug 2008
Location: INDIA
Distribution: Redhat,Debian,Suse,Windows
Posts: 179

Rep: Reputation: 23
Quote:
Originally Posted by babar546 View Post
plzzz help
(1) check your firewall or any antivirus software settings related to port
(2)from remote machine check is port no. is open or not.by below given command -
telnet ip-addressOfApache_server port_no

(3) Read this page for configuring port no. 80 and 8080

http://httpd.apache.org/docs/2.2/vhosts/examples.html
 
Old 12-20-2012, 06:38 PM   #4
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,082

Rep: Reputation: Disabled
Quote:
Originally Posted by babar546 View Post
but when i try to access it through my ip from internet, it shows my router page, i open my port 80 for forwarding data.
Like most routers, your router is running a web server on port 80. You should be able to select a different port number, and then you can forward port 80 to your internal web server.
 
Old 12-22-2012, 03:57 AM   #5
babar546
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
thanks for reply,
i already check firewall, security issues, every thing is fine , bcz when i start apahe i disable the windows firewall, and i check port 80 with a software and it show me that port 80 is open and reachable, i do everything myself.but not working,


i have a problem when i try to open port 80 it show me that as port 80 is in use so port 80 moved to 8080.

before this is check netstat -ao and find pid of that service which are using port 80 but there is no apps which using port 80.

but every time when i try to open port 80 it show me that port 80 is in use and moved to 8080.

Last edited by babar546; 12-22-2012 at 03:59 AM.
 
Old 12-24-2012, 01:50 AM   #6
sharadchhetri
Member
 
Registered: Aug 2008
Location: INDIA
Distribution: Redhat,Debian,Suse,Windows
Posts: 179

Rep: Reputation: 23
Quote:
Originally Posted by babar546 View Post
thanks for reply,
i already check firewall, security issues, every thing is fine , bcz when i start apahe i disable the windows firewall, and i check port 80 with a software and it show me that port 80 is open and reachable, i do everything myself.but not working,


i have a problem when i try to open port 80 it show me that as port 80 is in use so port 80 moved to 8080.

before this is check netstat -ao and find pid of that service which are using port 80 but there is no apps which using port 80.

but every time when i try to open port 80 it show me that port 80 is in use and moved to 8080.
OK, I got a doubt, can you paste the screenshot of your web browser after opening your Apache.
 
Old 12-24-2012, 08:17 AM   #7
babar546
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
sharadchhetri, please give me your skype id i want to disscuss my issue.thanks
 
Old 12-24-2012, 08:24 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Quote:
Originally Posted by babar546 View Post
sharadchhetri, please give me your skype id i want to disscuss my issue.thanks
This would be a very bad idea. This is an open forum. Solve your issues here so that others with similar problems will find it easier to solve it.

@Issue:

On your router settings, forward some random port to port 80 on your system running apache. And then access the link from external IP by connecting to that random port. This should you the apache default webpage or any page you have configured apache to throw.
 
Old 12-24-2012, 08:38 AM   #9
babar546
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
by default my port 80 is not open,so before opening port 80 i check pid of the applications which r using port 80 , then after checking i am sue there is no application which r using port80 , so when i try to make my port 80 open , my router told me that port 80 is in use , so port 80 moved to 8080.

then i edit my https.conf file and change the port 80 to port 8080 in http.default.config file every where.

still when i access apache through my external ip or through my domain only router page shows.

another thing , as when i try to open port 80 , it told me port 80 is in use and will move to 8080 , but when i check it throgh a software , it shows me port 80 is open ,and port 8080 is not open.while my router telling me port 80 moved to 8080


i contact my isp and they told me port 80 is open and working well.

soooooooooooooooooooooooooooooooooooooooooooo plzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
 
Old 12-24-2012, 12:22 PM   #10
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,082

Rep: Reputation: Disabled
You talk about "opening a port", but then you describe something quite different: forwarding a port from your router to a web server on the inside. Is that indeed what you are trying to accomplish?

If so, you will have to move the internal web server on the router out of the way before you can start forwarding port 80 to some other system.
 
Old 12-24-2012, 01:10 PM   #11
babar546
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
my problem is only apache is working fine on my local pc, when i access this server through my external ip it shows me my router configration page, some one told me that my router not forwarding data either its port 80 is not open.
i check all these issue but still my router page is opening when access through external ip
 
Old 12-24-2012, 03:28 PM   #12
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,150

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
With most home routers basic NAT features you can't access your web server via the external ip-address from the LAN side of the router. If you forward port 80 (assuming your ISP does not block it) on the router to your server LAN IP address it will be available if someone external to the LAN accesses it via your external IP address.

However, if your router has NAT loopback capability then you can use your external IP address to access your server from within your network.
 
1 members found this post helpful.
Old 12-24-2012, 07:33 PM   #13
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,082

Rep: Reputation: Disabled
Quote:
Originally Posted by babar546 View Post
my problem is only apache is working fine on my local pc, when i access this server through my external ip it shows me my router configration page, some one told me that my router not forwarding data either its port 80 is not open.
i check all these issue but still my router page is opening when access through external ip
As michaelk says, accessing the web server through the external IP is only likely to work for clients that are actually on the outside. Unless the router specifically supports this scenario (often called "hairpin NAT"), it just won't work. That's not really a problem, as clients on the outside will still be able to access the server.

If you are indeed trying to access the server from outside your network and are getting the router configuration page, it just means that the internal web server on the router must be moved to another port. This too is quite common. Look for a setting on your router that allows you to specify the HTTP port, and where the value is currently 80.

Last edited by Ser Olmy; 12-24-2012 at 07:34 PM.
 
Old 12-25-2012, 02:16 AM   #14
sharadchhetri
Member
 
Registered: Aug 2008
Location: INDIA
Distribution: Redhat,Debian,Suse,Windows
Posts: 179

Rep: Reputation: 23
Quote:
Originally Posted by Ser Olmy View Post
As michaelk says, accessing the web server through the external IP is only likely to work for clients that are actually on the outside. Unless the router specifically supports this scenario (often called "hairpin NAT"), it just won't work. That's not really a problem, as clients on the outside will still be able to access the server.

If you are indeed trying to access the server from outside your network and are getting the router configuration page, it just means that the internal web server on the router must be moved to another port. This too is quite common. Look for a setting on your router that allows you to specify the HTTP port, and where the value is currently 80.
I prefer to answer here only ,it is open forum. no skype id plz.

Can you change the port no. to 8180 of your router configuration page.
the problem is not so tough ,either we are not able to understand or you are not able to do what we are saying here.
I asked for screenshot but no answer from your side.** hide the information in screenshot which you believe is confidential
 
Old 12-25-2012, 07:52 AM   #15
babar546
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
thnks problem has been solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Load Balancing - ipvsadm with apache (mod_proxy) to another apache not working romeo_tango Linux - Server 1 01-12-2012 04:21 AM
Had apache working, then set up vsftpd, now apache is refusing my connections beetle_boy66 Linux - Newbie 4 01-25-2006 09:57 PM
Apache external access iRiSH_LoCo Linux - Networking 13 03-02-2004 01:41 PM
can't get SSLl working on Apache. Apache won't start bentman78 Linux - Software 1 08-10-2003 07:17 PM
Apache canīt listen to external IP Baalbeck Linux - Networking 4 03-07-2003 04:42 PM


All times are GMT -5. The time now is 02:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration