LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-20-2005, 11:59 PM   #1
sarmad
LQ Newbie
 
Registered: Sep 2004
Location: Montreal - Canada
Distribution: Mandrake 10.0
Posts: 11

Rep: Reputation: 0
apache: http://localhost (work) http://ipaddress (not working)


Hi all,

I am trying to get my webserver working !!!

I know that my internet provider block the port 80 and i am using a router (with a firewall) so i forward the the port :8080 to :8080

Under Windows XP it works well

http://localhost:8080 works and http://xx.yy.zz:8080 works too (xx.yy.zz is my ip address)


but under Linux FC3
http://localhost:8080 wors but http://xx.yy.zz:8080 does not working !!! and i got a Timeout error

my httpd.conf is the same as the original one i just changed

Listen 80 to Listen 8080


I dont know where is the error !

Please help

Last edited by sarmad; 01-21-2005 at 12:02 AM.
 
Old 01-21-2005, 12:32 AM   #2
Libu
Member
 
Registered: Oct 2003
Location: Chennai
Distribution: Slackware 12.1
Posts: 165

Rep: Reputation: 36
What is the /etc/hosts contents ?
 
Old 01-21-2005, 12:43 AM   #3
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
How about http://127.0.0.1:8080
 
Old 01-21-2005, 02:11 AM   #4
DaHammer
Member
 
Registered: Oct 2003
Location: Planet Earth
Distribution: Slackware, LFS
Posts: 561

Rep: Reputation: 30
Quote:
I know that my internet provider block the port 80 and i am using a router (with a firewall) so i forward the the port :8080 to :8080
foward port :8080 to :8080? If you meant 80 to 8080, then that isn't going to work if you ISP blocks 80. Since port 80 is blocked there will never be anything coming in on it to foward, as it's blocked by the ISP long before it ever gets to you.

And are you trying to connect to your IP from behind the router? That's probably not going to work either. That would mean the packet would go out to the router (who holds a lease on the external IP) where it's most likely NAT'ed, then tries to come back in using the same IP. Anyway, try connecting to the IP from some other PC outside your network.
 
Old 01-21-2005, 02:33 AM   #5
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Rep: Reputation: 52
What IP address are you using? The linux ip address or your WAN?

-twantrd
 
Old 01-21-2005, 05:22 PM   #6
sarmad
LQ Newbie
 
Registered: Sep 2004
Location: Montreal - Canada
Distribution: Mandrake 10.0
Posts: 11

Original Poster
Rep: Reputation: 0
Solved

Hi all,

thank you for your participation.

as i said above the problem is not from my router niether my isp because it works under windows and poeple can access to my server through the internet


so the problem is from my linux !!!

and finaly i found the solution :-)

under linux FC3 there is a firewall that block all access throught the WWW(HTTP) !!
the solution is:
(Genome) Application > System Settings > Security Level
(KDE) Menu > System Settings > Security Level

and put the WWW(HTTP) as a Trusted services
and put eth(0) {my network card} as a Trusted devices


and now it works :-)
 
Old 01-21-2005, 05:44 PM   #7
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Rep: Reputation: 52
Ahh, totally forgot about that one. That didn't come to my mind at the moment. Good catch. You might as well just turn firewall off on FC3 and input your own allow/reject rules with iptables.

-twantrd
 
Old 02-05-2013, 07:47 AM   #8
arun5002
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 549
Blog Entries: 5

Rep: Reputation: Disabled
Changing of below line in httpd.conf file .Resolved the issue

Listen 127.0.0.1:80

Last edited by arun5002; 02-05-2013 at 07:49 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Samba: http://localhost:901 doesn't work lagu2653 Linux - Networking 5 06-29-2005 03:13 PM
apache http://localhost/mysite ---> http://localhost/mysite/index.php how? ilnli Linux - General 8 06-04-2005 03:23 PM
Apache blank screen at http://localhost/ Steel Shepherd Linux - Software 9 04-10-2004 02:39 AM
http://localhost apache matt3333 Linux - Software 16 05-25-2003 01:55 PM
http://localhost does not work! Rajasekhar Atte Linux - Networking 1 12-17-2001 03:06 PM


All times are GMT -5. The time now is 11:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration