LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   apache: http://localhost (work) http://ipaddress (not working) (http://www.linuxquestions.org/questions/linux-newbie-8/apache-http-localhost-work-http-ipaddress-not-working-280389/)

sarmad 01-20-2005 11:59 PM

apache: http://localhost (work) http://ipaddress (not working)
 
Hi all,

I am trying to get my webserver working !!!

I know that my internet provider block the port 80 and i am using a router (with a firewall) so i forward the the port :8080 to :8080

Under Windows XP it works well

http://localhost:8080 works and http://xx.yy.zz:8080 works too (xx.yy.zz is my ip address)


but under Linux FC3
http://localhost:8080 wors but http://xx.yy.zz:8080 does not working !!! and i got a Timeout error

my httpd.conf is the same as the original one i just changed

Listen 80 to Listen 8080


I dont know where is the error !

Please help

Libu 01-21-2005 12:32 AM

What is the /etc/hosts contents ?

scuzzman 01-21-2005 12:43 AM

How about http://127.0.0.1:8080

DaHammer 01-21-2005 02:11 AM

Quote:

I know that my internet provider block the port 80 and i am using a router (with a firewall) so i forward the the port :8080 to :8080
foward port :8080 to :8080? If you meant 80 to 8080, then that isn't going to work if you ISP blocks 80. Since port 80 is blocked there will never be anything coming in on it to foward, as it's blocked by the ISP long before it ever gets to you.

And are you trying to connect to your IP from behind the router? That's probably not going to work either. That would mean the packet would go out to the router (who holds a lease on the external IP) where it's most likely NAT'ed, then tries to come back in using the same IP. Anyway, try connecting to the IP from some other PC outside your network.

twantrd 01-21-2005 02:33 AM

What IP address are you using? The linux ip address or your WAN?

-twantrd

sarmad 01-21-2005 05:22 PM

Solved
 
Hi all,

thank you for your participation.

as i said above the problem is not from my router niether my isp because it works under windows and poeple can access to my server through the internet


so the problem is from my linux !!!

and finaly i found the solution :-)

under linux FC3 there is a firewall that block all access throught the WWW(HTTP) !!
the solution is:
(Genome) Application > System Settings > Security Level
(KDE) Menu > System Settings > Security Level

and put the WWW(HTTP) as a Trusted services
and put eth(0) {my network card} as a Trusted devices


and now it works :-)

twantrd 01-21-2005 05:44 PM

Ahh, totally forgot about that one. That didn't come to my mind at the moment. Good catch. You might as well just turn firewall off on FC3 and input your own allow/reject rules with iptables.

-twantrd

arun5002 02-05-2013 07:47 AM

Changing of below line in httpd.conf file .Resolved the issue

Listen 127.0.0.1:80


All times are GMT -5. The time now is 10:46 AM.