LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2004, 11:46 PM   #16
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58

Try that ip on the box itself, that's the real test of the webserver.

http://ipaddress

and for secure connections..

https://ipaddress

Now that that's working look at where your coming from on the other box, is it through the internet? maybe you have a firewall or you ISP or router has one.


port 80 must be open for http, port 443 for https


your ip resolves to this..

64-4-118-166.va.mvl.ntelos.net


pinging your machine is successful.


Your webserver ports appear to not have a webserver running on them from the internet.

Generally a link to your site is not the way to set it up. You should setup the Document Root to be the path to your site folder.

Depending on your Virtual Domain or other settings things may result in different web locations depending on the address or name your connecting with in your browser address bar.

http://68.63.76.175/

Last edited by DavidPhillips; 11-06-2004 at 12:04 AM.
 
Old 11-07-2004, 11:20 PM   #17
rasgward
Member
 
Registered: May 2004
Location: Virginia
Distribution: ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Well...

Well, I don't know if i'm behind a router or network. I know I have DSL and installed Mandrake on my system. I am not sure what you mean and how would I know? -Greg
 
Old 11-07-2004, 11:35 PM   #18
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
We need to know if you can use the ip on the server and get your web page.

If you can then there is something blocking it, if not apache is not running or configured incorrectly.


As I said before try 127.0.0.1 and also your ip from the server to see if it works. It's pointless to guess at the problem if we don't check that first.
 
Old 11-08-2004, 01:58 PM   #19
roefelkop
LQ Newbie
 
Registered: Oct 2004
Location: Belgium
Distribution: gentoo
Posts: 5

Rep: Reputation: 0
maybe you can run ifconfig to see wether your ip begins with 192.168. or not. If it is so, you're behind a network, router. If not, you're point-to-point connected to the internet.

I've got another question. I've installed apache 2.0. If I enter the url http://127.0.0.1, he gives a nice page about apache (good installed). Now I wanted to change the documentroot in /home/roel (that's my user) I did it and mozilla said:
Forbidden

You don't have permission to access / on this server.
Apache/2.0.52 (Gentoo/Linux) Server at Roel.Werkgroep Port 80

What can I do?
 
Old 11-08-2004, 02:22 PM   #20
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
chmod all your folders to 755 and all your files to 644, you have your permissions wrong
 
Old 11-08-2004, 08:57 PM   #21
rasgward
Member
 
Registered: May 2004
Location: Virginia
Distribution: ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
well...i tried...

Okay I typed the loopback address and it said it couldn't find it. So, I'm not sure what to do.
I have another question though. SO, is my address 64.4.118.166 or is it
64-4-118-166.mvl.ntelos.net Nothing seems to work. Do i need to do something in the mandrake configuration files, like change the proxy to something, and if so, to what? It asks for http and ftp addresses. -Greg
 
Old 11-09-2004, 10:24 AM   #22
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
An ip is always ###.###.###.###

You can also omit leading zero's in each octet.

The other address you have is a name just like yahoo.com that is registered in DNS.

If you get connection refused from 127.0.0.1, and your ip 64.4.118.166 on the server itself then you do not have apache runnning or you have it firewalled.

It's not to likely that it's a firewall on the loopback address so we will guess that apache is not running.


What is the exact error in your browser?

Also try this..


/etc/init.d/httpd restart


let us know what you get.

Last edited by DavidPhillips; 11-09-2004 at 10:33 AM.
 
Old 11-09-2004, 05:33 PM   #23
rasgward
Member
 
Registered: May 2004
Location: Virginia
Distribution: ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
this is what iget still

An error occurred while loading http://127.0.0.1/:


Could not connect to host 127.0.0.1 -greg
 
Old 11-09-2004, 09:04 PM   #24
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
how about the rest?

/etc/init.d/httpd restart


let us know what you get.



also this...


netstat -lpnt


Last edited by DavidPhillips; 11-09-2004 at 09:07 PM.
 
Old 11-10-2004, 07:12 AM   #25
rasgward
Member
 
Registered: May 2004
Location: Virginia
Distribution: ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
here's the output. thanks.

Okay,
Here's the output. Since i stopped the server since the last time i restarted it, I just typed in start, then the other thing that lists the servers status' THanks.
[root@64-4-118-166 greg]# /etc/init.d/httpd start
[root@64-4-118-166 greg]# netstat -lpnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:32768 0.0.0.0:* LISTEN 1972/xinetd
tcp 0 0 127.0.0.1:5703 0.0.0.0:* LISTEN 2006/ptal-photod
tcp 0 0 127.0.0.1:10026 0.0.0.0:* LISTEN 2351/master
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1389/portmap
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN 1964/X
tcp 0 0 0.0.0.0:784 0.0.0.0:* LISTEN 1450/rpc.statd
tcp 0 0 0.0.0.0:631 0.0.0.0:* LISTEN 2037/cupsd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2351/master
tcp 0 0 :::6348 :::* LISTEN 11297/java
tcp 0 0 :::45100 :::* LISTEN 11297/java

On the screen though, the LISTEN is the last thing on the right. Then the 1972/xinetd and the rest are under the tcp's. THanks again for the help. -Greg
 
Old 11-10-2004, 11:59 AM   #26
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
I don't see it,


we should have this...

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN -

and maybe this for secure connections if it's enabled...

tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN -


normally apache will run on both ports by default.

If you use restart you can see if it's actually runnning. Sometimes you may get a good start but it crases immediately. restart will tell you if it's runnning. Or try stop then start.


There are some log files in /var/log/httpd that we need to check for errors.


Last edited by DavidPhillips; 11-10-2004 at 12:03 PM.
 
Old 11-10-2004, 01:02 PM   #27
rasgward
Member
 
Registered: May 2004
Location: Virginia
Distribution: ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
alright, i did restart and then stopped then started

Aright,
well, I did originally restart it then got no error messages, but since I couldn't get the page to show up, I stopped it so it wouldn't be open to the world. What I posted was after I started it again. not restart but start. So, I will when I get home post the logs, thanks for all the help, anyway I can make a donation to you through paypal? Thanks. -Greg
 
Old 11-12-2004, 10:27 AM   #28
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
If you find an error in the log files most of the time it's going to be in the config file for apache (httpd.conf). Maybe post the error and the config file if it's not something obvious to you.

If it's related to ssl see what this says...

openssl version



Also you may try to run this then restart apache...


ldconfig
 
Old 11-14-2004, 10:49 PM   #29
rasgward
Member
 
Registered: May 2004
Location: Virginia
Distribution: ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
I can't find the logs

I went to usr/local/apache2/logs and nothing was there then I went to /etc/httpd/logs and nothing was there. I looked everywhere. What is the file I'm looking for?-Greg
also the ldconfig didn't work, it said command not found
thanks.
 
Old 11-15-2004, 10:21 AM   #30
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Normally there would be some logs in /var/log/httpd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail from Apache being rejected - Cannot route to sender apache@localhost.localdomain jimwillsher Linux - Networking 2 01-19-2006 01:41 AM
Apache 1.3.33 (debian built) and Apache SSL does not respond to the proper ports lqorg_user Linux - Networking 0 11-06-2005 05:11 PM
Strange apache trailing / problem - Slack-current, apache 1.3.33 vamp Linux - Networking 1 01-30-2005 08:28 PM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 06:30 AM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 11:53 AM


All times are GMT -5. The time now is 04:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration