LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2010, 06:04 AM   #1
sysrez
Member
 
Registered: Aug 2010
Distribution: Debian
Posts: 35

Rep: Reputation: 0
Apache help


Not sure if this was the right place to post this.

Recently installed Ubuntu Netbook remix on my netbook. On Windows I used IIS and pointed my website to a directory full of video files all in .avi containers, enabled directory browsing and could watch files in the browser on my PS3.

I'm wondering how I go about doing this in Apache? Since there isn't any GUI to do it for me like in IIS :P.
 
Old 09-22-2010, 07:53 AM   #2
suprstar
Member
 
Registered: Aug 2010
Location: Atlanta
Distribution: ubuntu, debian
Posts: 142
Blog Entries: 2

Rep: Reputation: 22
You could install webmin

http://www.webmin.com/

It's a pretty common nice polished gui. Or learn what the stuff in /etc/httpd/conf means!
 
Old 09-22-2010, 08:05 AM   #3
sysrez
Member
 
Registered: Aug 2010
Distribution: Debian
Posts: 35

Original Poster
Rep: Reputation: 0
Yea I found that But unfortunately I have stumbled onto another problem.

When I go to the designated address to the directory I don't have permission to access it. And I can't seem to find out how to configure read permissions for the directory, also just to complicate things the directory is on an NTFS partition on my hard drive. I have enable directory browsing and I have tested this by using a directory on my Ubuntu partition.

If anybody could tell me how to set Permissions on my NTFS partition for www-data user or more simply all users to read that would be great .

Last edited by sysrez; 09-22-2010 at 09:16 AM.
 
Old 09-22-2010, 10:31 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 12,140
Blog Entries: 14

Rep: Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070Reputation: 3070
Quote:
Originally Posted by sysrez View Post
When I go to the designated address to the directory I don't have permission to access it. And I can't seem to find out how to configure read permissions for the directory, also just to complicate things the directory is on an NTFS partition on my hard drive. I have enable directory browsing and I have tested this by using a directory on my Ubuntu partition.
When you imported the directory, it may have brought its old permissions with it. I have had this happen. Today I copied a file over my network from a Ubuntu box to a Slackware box and it ended up as owned by "nobody" in "nogroup."

Since you are using Ubuntu, you could open a terminal, than "sudo nautilus" to use nautilus to change the permissions.

Or you could open a terminal, enter "sudo su" to go into super user mode, then use "ls -l" to check the permissions and ownership and "chown" and "chmod" to change the ownership and permissions.

Last edited by frankbell; 09-22-2010 at 10:32 PM. Reason: grammar
 
Old 09-22-2010, 10:44 PM   #5
leejohnli
Member
 
Registered: Sep 2010
Posts: 66

Rep: Reputation: 2
Ubuntu default user account for apache is "apache". Better check the permission of the directory using command parameter ls -l to see the permission.

Ubuntu default directory is under "/var/www"
 
Old 09-22-2010, 11:15 PM   #6
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,143
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
http://www.ubuntugeek.com/ubuntu-710...ver-setup.html

See this link and refer end of the page
 
Old 09-23-2010, 01:29 AM   #7
sysrez
Member
 
Registered: Aug 2010
Distribution: Debian
Posts: 35

Original Poster
Rep: Reputation: 0
Thank you for the suggestions guys, but this isn't what I'm looking for. Let me try and explain again.

I have the server setup fine and I can access directories that are configured to the website, but these directories are on my Ubuntu partition.

I have a Windows NTFS partition that cannot be accessed because from what I gather Apache doesn't have permissions to this directory (in fact it doesn't have access to the whole partition). It is impossible to change permissions via Nautilus or Sudo GUI Nautilus on an NTFS partition.

I'm asking if there is a way to have the permissions changed on the whole NTFS partition or it's directories so it is readable to any user or have it readable for the account Apache is using , which I believe is www-data Leejohnli because I can't find any user named 'Apache'.
 
Old 09-23-2010, 02:10 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Okay. Why not mount your ntfs partitions on Ubuntu and give permissions on the mount? Eg:

mount -t ntfs /dev/<ntfs-partition> /mnt/mount-point

And then give permissions on this mount-point for complete read write or what ever you like.
 
Old 09-23-2010, 02:49 AM   #9
sysrez
Member
 
Registered: Aug 2010
Distribution: Debian
Posts: 35

Original Poster
Rep: Reputation: 0
Sorry to be a noob but.. How?

Also can I add a line into fstab so it mounts /dev/sda2 automatically with the permissions I want?

All I want is read permissions, rather not open up any needless security holes.
 
Old 09-23-2010, 02:57 AM   #10
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,143
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
vim /etc/fstab
Quote:
/dev/sda2 /mnt/cdrive ro 0 0
 
Old 09-23-2010, 03:20 AM   #11
sysrez
Member
 
Registered: Aug 2010
Distribution: Debian
Posts: 35

Original Poster
Rep: Reputation: 0
Beautiful. Missed the File system type switch but no biggie.

For anyone who runs into this thread searching for answers.
Quote:
/dev/sda2 /mount/Data auto ro 0 0
Thank you very much for the help guys .
 
Old 09-23-2010, 04:28 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
If this got you working, please mark the thread as solved from thread tools at the top of thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setting up apache from scratch on a linux machine, apache failed message upon bootup dramous43 Linux - Enterprise 2 01-26-2010 07:53 AM
Apache Webserver on Slackware - Failed to Start Apache - 'no listening sockets .." CCTVGuru Linux - Server 4 10-11-2009 01:14 AM
Mail from Apache being rejected - Cannot route to sender apache@localhost.localdomain jimwillsher Linux - Networking 2 01-19-2006 12:41 AM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 05:30 AM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 10:53 AM


All times are GMT -5. The time now is 12:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration