LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-07-2009, 10:38 AM   #1
gordymann
LQ Newbie
 
Registered: Mar 2009
Location: Ct
Distribution: SuSe & RH
Posts: 2

Rep: Reputation: 0
Apache Error 403 - CentOS 5.2 with Apache 2.2.3


I am installing Big Brother on a CentOS 5.2 running the default Apache 2.2.3.

When I try to access any web page I get the following error:
Forbidden

You don't have permission to access /bb/ on this server.
Apache/2.2.3 (CentOS) Server at fmsubbnix Port 80

So far I have:
1) Set the Directory options to FollowSymLinks
2) Verified all directory and file permissions are at 755
3) Set permissions temporarily to 777 and received same error so I am assuming the issue is in a config file somewhere
4) in hhtpd.conf verified <Files ~ "^\.ht"> is correct
5) verified the "default" directory is correct (/var/www/html)

I have read and tried several ideas in posts listed on the web but to no avail and am at a loss as to what to look for next.
 
Old 04-07-2009, 11:46 AM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
If you take BB out of equation and just try to setup a basic virtualhost that serves up something simple like:
<html>
<head>
<title>Hi World</title>
</head>
<body>
I rule
</body>
</html>

to see if your server is setup correctly?

-Chad
 
Old 04-08-2009, 08:57 AM   #3
gordymann
LQ Newbie
 
Registered: Mar 2009
Location: Ct
Distribution: SuSe & RH
Posts: 2

Original Poster
Rep: Reputation: 0
Issue Resolved

I feel silly but the problem was not the Symbolic Links it was the permissions to the paths along the way. In particular /home/bbnix/ was restricting user access and causing the problem. I modified these to 711 and the site now functions properly.
 
  


Reply

Tags
apache, centos52, linux


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
403 error in Apache watcher69b Linux - Server 3 05-27-2008 08:13 AM
Apache / Error 403 Issues bosworthj Linux - Software 3 09-07-2006 09:23 AM
Apache 403 Error?? jlsain Linux - Software 4 05-08-2004 03:45 PM
Apache 403 error with Mandrake 9.0 Skywolf Linux - Newbie 11 07-15-2003 07:46 AM
apache 403 error forbidden? bulliver Linux - General 4 01-31-2003 07:47 AM


All times are GMT -5. The time now is 01:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration