LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2004, 02:03 PM   #1
rjcmi
LQ Newbie
 
Registered: Feb 2004
Location: Michigan
Distribution: Ubuntu
Posts: 21

Rep: Reputation: 15
Apache Cgi-Bin confguration on debian distro


I'm attempting to install movable type on my personal apache server. I am currently unable to execute cgi scripts with my current apache configuration and would like to learn how i get apache to execute cgi scripts that are located withn /var/www/cgi-bin.

I beleive that I need to add/modify the httpd.conf file to make this happen, I'm just kind of lost as to what to add, or if i need to place my cgi scripts in a different location.
 
Old 07-15-2004, 04:53 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,276

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Do you have a ScriptAlias directive pointing to your cgi-bin dir -- it would look something like:

ScriptAlias /cgi-bin/ "/var/www/cgi-bin"

and the access controls:

<Directory /var/www/cgi-bin>
AllowOverride None
Options None
Order allow,deny
Allow from all
</Direcory>

In general, make sure that you have all the packages you need to run CGI installed (as the default install may not have CGI support) -- you'll need to consult the Debian documentation for Apache to be sure.
 
Old 07-15-2004, 09:11 PM   #3
rjcmi
LQ Newbie
 
Registered: Feb 2004
Location: Michigan
Distribution: Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for the help here is what my httpd.conf looks like:

ScriptAlias /cgi-bin/ /var/www/cgi-bin/

#
# "/usr/lib/cgi-bin" could be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory /var/www/cgi-bin/>
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>
</IfModule>

and I uncommented the line
AddHandler cgi-script .cgi

Thanks again for the assist.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 9 / Apache / cgi-bin ???? jeff0628 Linux - General 16 10-18-2003 07:50 AM
Apache server and cgi-bin? WorldBuilder Linux - Networking 15 09-18-2003 01:13 PM
.htaccess and cgi-bin (apache of course) finegan Linux - Software 4 05-01-2003 05:21 PM
no access to cgi-bin within Apache Mackeral Linux - Software 6 05-14-2002 06:15 AM
apache cgi-bin roadie Linux - General 6 06-16-2001 08:15 PM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration