LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2007, 02:25 AM   #1
krypticchaos
LQ Newbie
 
Registered: Aug 2007
Posts: 2

Rep: Reputation: 0
Apache and Perl configuration not working together


I have Apache configured and running because when I visit the server url it shows the IT Works! page.

However when I put a .pl file into the cgi-bin and then go to that page it does nothing and complains that it can't find the file with an error saying HTTP 500.

Any help would be appreciated or even just a kick up the backside into the right location would help.

Many Thanks
Dave
 
Old 08-23-2007, 03:59 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
Try this page: http://httpd.apache.org/docs/2.0/howto/cgi.html
 
Old 08-26-2007, 11:46 AM   #3
krypticchaos
LQ Newbie
 
Registered: Aug 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Unhappy Apologies for thickness

Well I read through that site and found some interesting things that I didn't know, but then worked out that I had it set to the wrong Perl interpretter on the main line of the .pl file.

After working out the wrong directory it all kicked in

Thanks for pointing me there anyways Much appreciated.

Dave
 
Old 08-27-2007, 02:04 AM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
It's always the small things that catch you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache / mysql / Perl configuration outshined Fedora 1 05-24-2006 06:40 AM
Perl working at command line, but not in Apache nutthick Linux - Software 3 04-12-2006 08:02 AM
[perl] getting apache::mp3 module working deus1 Programming 4 08-06-2005 06:47 PM
chrooting apache v2 (php, ssl, perl support) ; perl configuration markus1982 Linux - Security 3 01-26-2003 07:15 PM
Apache Perl configuration Swene Linux - General 0 04-14-2002 12:18 PM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration