LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-23-2003, 07:49 AM   #1
sitemaster
LQ Newbie
 
Registered: Jun 2003
Location: Edmonton, AB
Distribution: RedHat 9
Posts: 2

Rep: Reputation: 0
Angry Apache 2 configuration issues


I have set up a web server to test my sites, using redhat 9.
It works fine on my network with IP address 192.168.1.99 and delivers the default site.
As soon as I use the configuration tool to add a virtual host 192.168.1.12 the links to documentation in the default site cease to work. I kept a backup of the original httpd.conf file and re-instated it - everything then worked again.
I know I can't edit the httpd.conf file AND use the config utility.

What I want to know initially is whether there are issues with the configuration tool or is it simply me that's not using it properly.

& getting nowhere fast

Alan
 
Old 06-23-2003, 10:12 AM   #2
sitemaster
LQ Newbie
 
Registered: Jun 2003
Location: Edmonton, AB
Distribution: RedHat 9
Posts: 2

Original Poster
Rep: Reputation: 0
I've made some progress - this will be so obvious to those of you who are experienced. I pinged the network and found that my IP addresses were not responding, some more reading and I found out that I have to set up the network addresses as Eth1 etc. This is now done, so I have 192.168.1.10 . . . 12
10 and 11 deliver the default site - great
12 gives a FORBIDDEN you don't have permission to access / on this server (12 points to /home/alan/www) it also says Additionally a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request

This sounds like I need to set some permissions

I used the Apache configuration tool to set up my virtual host

Alan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache vhost issues (client denied by server configuration) bpk Linux - Software 8 02-16-2005 08:02 PM
TCP/IP configuration issues falconkid Linux - Networking 17 12-22-2004 05:10 PM
Xorg configuration issues.... crm Linux - Hardware 3 09-10-2004 01:54 PM
Cedega Configuration Issues Danzig Linux - Games 0 07-03-2004 11:06 PM
Font configuration issues Poprocks Linux - Newbie 1 09-09-2003 12:14 AM


All times are GMT -5. The time now is 10:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration