LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-12-2003, 07:42 PM   #1
FlamingoJeff
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 5

Rep: Reputation: 0
Apache 2.0.40 troubleshooting


I've just installed RH 9 (my first experience with Linux) as a dual-boot with Win2K on an old machine to use as a server for web page and scrpting tester and as backup for my main Win2K computer.

So far, everything has gone fairly smoothly, with the exception of configuring Apache 2.0.40.

My network hardware configuration seems to work, as I can reach the Internet through my router and cable modem. I can acces locahost both through the computer name and by localhost. However, I can't reach it from the other connected machine by computername or IP. I can ping it only by IP.

I've spent over eight hours searching for a solution, often reading how-tos, manuals, threads, etc. that were way beyond my knowledge level and often totally irrelevant. I suspect that this problem has been posted here before, but I can't find the specific answer I need, so I would appreciate your help.

I've also tried reconfiguring with Webmin, and, as a result of all of the searching and trying on my own I've changed numerous files. Nothing else seems to be not working though.

What more information wouold be useful?

Last edited by FlamingoJeff; 08-12-2003 at 08:06 PM.
 
Old 08-13-2003, 02:25 AM   #2
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Rep: Reputation: 15
Apache 2.xx - Arrrgh!

Been having a few not uncommon problems with that myself of late - would suggest removing 2.x and replacing it with 1.3.x - however that may be beyond you at the moment.

So with that in mind here are a couple of things for you to try:

1) Make sure the httpd service is running.
a: /etc/rc.d/init.d/httpd restart

2) Running but still can't see it from the localhost or by IPADDR?
a: Check the firewall settings to see if you are blocking port 80 a quick way to test this is by dropping your firewall by /etc/rc.d/init.d/iptables stop

3) The service is started and it's not my firewall!
a: How about posting your /etc/httpd/conf/httpd.conf file for us to pick through to spot any major errors.

I sincerely hope that helped you out. Usually it works a charm on a clean install of RH9 not heard of your problem before.. Just to check when requesting the page you are http://localhost/ <-- from the linux box and http://<linux box ip address> <-- from your windows box...

Bleah
 
Old 08-13-2003, 02:27 AM   #3
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Rep: Reputation: 15
Incidentally windows won't see your Linux box by name unless you are running smb. - well that's what I found - however some bright spark will no doubt come and correct me. - live and learn.
 
Old 08-13-2003, 08:58 AM   #4
FlamingoJeff
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by bleah-man


2) Running but still can't see it from the localhost or by IPADDR?
a: Check the firewall settings to see if you are blocking port 80 a quick way to test this is by dropping your firewall by /etc/rc.d/init.d/iptables stop

Thanks - that worked, so the problem is with the firewall. Which file do I look at to correct that? I want to block all access except from my main Win2k machine.

Your help is appreciated.

[edit] Well, DUH! That would be /etc/sysconfig/iptables (not enough coffe yet this morning)

Quote:
# Manual customization of this file is not recommended.
# Note: ifup-post will punch the current nameservers through the
# firewall; such entries will *not* be listed here.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Lokkit-0-50-INPUT - [0:0]
-A INPUT -j RH-Lokkit-0-50-INPUT
-A FORWARD -j RH-Lokkit-0-50-INPUT
-A RH-Lokkit-0-50-INPUT -i lo -j ACCEPT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 0:1023 --syn -j REJECT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 2049 --syn -j REJECT
-A RH-Lokkit-0-50-INPUT -p udp -m udp --dport 0:1023 -j REJECT
-A RH-Lokkit-0-50-INPUT -p udp -m udp --dport 2049 -j REJECT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 6000:6009 --syn -j REJECT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 7100 --syn -j REJECT
COMMIT
# Generated by webmin
*mangle
:FORWARD ACCEPT [0:0]
:INPUT ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:PREROUTING ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
COMMIT
# Completed
# Generated by webmin
*nat
:OUTPUT ACCEPT [0:0]
:PREROUTING ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
COMMIT
# Completed
This looks like where I'd open the port? Which line?
Then, where would I restrict access by IP?

[/edit]

Last edited by FlamingoJeff; 08-13-2003 at 09:10 AM.
 
Old 08-13-2003, 09:08 AM   #5
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Rep: Reputation: 15
Firewalls can be particular.

Try having a quick look around the netfiler site for more info or post something on the security thread. It's fairly easy.. you should always accept all connections from your windowsbox IPADDR regardless of port. Would do the trick and be the easiest to implement.

All the best

Bleah
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting apache, php, and mysql. IssacT Slackware 21 08-20-2005 01:58 AM
Troubleshooting my network muppski Linux - Networking 6 02-07-2005 01:54 PM
troubleshooting how-to? chilehead Linux - Hardware 2 02-06-2005 04:58 PM
Postfix troubleshooting davee Linux - Networking 0 09-03-2003 07:10 AM
Installation Troubleshooting Lucifa Linux - General 5 06-15-2002 11:04 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration