LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-25-2003, 08:37 AM   #1
Makyver
LQ Newbie
 
Registered: Apr 2003
Location: Austin, TX.
Distribution: Gentoo
Posts: 14

Rep: Reputation: 0
Anyone get GTK:Perl installed with Gnome2


I wan't Acidrip back but after my upgrade to slack 9 with gnome 2 I can't load gtkerl or at least I think that's the problem it.

Never the less every time I try to make and install GTKerl it errors out and of course Acidrip won't work without it.

Any one get this to work or should I just go back to gnome 1.? and for get the nice log-on ... that's all I use it for any way.

Hey Acid ... you ever think about writing it in some other language and tool kit ??

Thanks All

Makyver
 
Old 04-25-2003, 08:42 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
howdy.

the fact that's it's gnome2 will not be relevant, i'd only guess that it's because gtk itself is not installed. is it? if that's there then it should work no problem.

i use perl cos i want to learn perl
i use gtk cos it's great
i use gtk-perl as it exists
i don't use gtk2-perl as it's still very very beta, but i will certainly port it when possible.
 
Old 04-25-2003, 10:36 AM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
I'm not running Slack9 but I am running Gnome2 on my machine in which GTK:Perl is working fine.

If you kindly post the errors you recieve here, we might be more of help. I do explain the process of installing GTK:Perl in the Installation HowTo I wrote for acidrip which is included with the package and linked off his main site..

Let us know!
 
Old 04-25-2003, 04:57 PM   #4
Makyver
LQ Newbie
 
Registered: Apr 2003
Location: Austin, TX.
Distribution: Gentoo
Posts: 14

Original Poster
Rep: Reputation: 0
Ok I tried the install of gtk-perl and it dosen't like me

Here is what I got from it.

Gtk-Perl-0.7008$ perl Makefile.PL
Can't exec "gnome-config": No such file or directory at Makefile.PL line 141.
Can't exec "imlib-config": No such file or directory at Makefile.PL line 141.
Can't exec "gnome-config": No such file or directory at Makefile.PL line 141.
Submodule gdkimlib is needed to build gnome but it appears
it's misdetected or not selected for compilation.
Available modules: gtk gtkhtml gtkglarea gdkimlib gdkpixbuf gtkxmhtml gnome gnomeprint glade applets.

You can disable the inclusion of a module using --without-pkgname.
If a package is misdetected and you still want it to compile
use --with-pkgname-force.
To disable autodetection of modules use --without-guessing.

.... the big question is really did you intall GTK ontop of GTK2 or also .... or did you just install GTK2 so that GTK was still there

and is that even possible

thanks guys I really want my Acidrip back... Oh yeah I tried the --without-guessing thing and it still errored out. Well any help would be great....
 
Old 04-25-2003, 05:09 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you've just not got the devel packages installed. i still have no idea how slack deals with that... drew will tell you no doubt. gtk2 and gtk are separate libraries, they do not use any common file names etc, they can exist fine side by side.
 
Old 04-25-2003, 05:50 PM   #6
Makyver
LQ Newbie
 
Registered: Apr 2003
Location: Austin, TX.
Distribution: Gentoo
Posts: 14

Original Poster
Rep: Reputation: 0
Well okay

So after your last post I am trying to install gtk+ 1.2.10 so that I can is tall gtk-perl .... All I wanted was acidrip even though this did effect something else I wanted to play... the important one was Acidrip... that should be something you put up on the wall or at least make you a little happy.... I'll tell you what happens after the installs.....

Thanks for all the input.....
 
Old 04-25-2003, 05:56 PM   #7
Makyver
LQ Newbie
 
Registered: Apr 2003
Location: Austin, TX.
Distribution: Gentoo
Posts: 14

Original Poster
Rep: Reputation: 0
and after that I screamed

Well really I didn't but ... after the install of gtk+-1.2.10 it still gives me that error .... What devel packages do I need ?
 
Old 04-25-2003, 06:37 PM   #8
Makyver
LQ Newbie
 
Registered: Apr 2003
Location: Austin, TX.
Distribution: Gentoo
Posts: 14

Original Poster
Rep: Reputation: 0
So I've put gtk+-1.2.10 on my system that didn't work and I looked and looked for devel packages put can't find them on the Gtk web site all I can find is rpms of the devel ..... Ok TrickyKid ... I got to know why didn't you upgrade yet and which version of Slack do you like best. .... thanks again for all your help
 
Old 04-25-2003, 06:54 PM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Its going to sound like a pain the arse but read this thread: http://www.linuxquestions.org/questi...threadid=56744 , your probably going to need the majority of these files as well that are listed in this thread. Its a list of the gnome 1.4 libs and files that are needed to install most gtk1.2 compatible programs that slack 9 doesn't install by default.
 
Old 04-26-2003, 10:18 AM   #10
Makyver
LQ Newbie
 
Registered: Apr 2003
Location: Austin, TX.
Distribution: Gentoo
Posts: 14

Original Poster
Rep: Reputation: 0
Unhappy I still get an error abot xml parsing

I'm still getting a congif error that seems to be about libxml but I installed that off my slackware 8.1 cd. I may have shoot my self in the foot almost been a week since I reloaded everything so it may be that time again .... All grab the text of the error when I get home and post it here also... thanks again for all the help .. I really want my acidrip back all this so I don't have to take my DVD's with me isn't that silly. ... Hey Acid I was running Acidrip on my pII 366 with 256 mb of ram it really dosen't add any overhead to the ripping process and makes life so much simpler thanks for the great little prog ... I have since upgraded my laptop to a pIII 650 mhz 256 mb ram and mencoder of course works much better I use to have to turn every thing down and deal with the skipping audio but that's better than what it did in WinBlows on either machine unless I put the margi DVD to-go card in .... there's another thread I need to look for. Well I will get that info up here soon and thanks again.

Kinda ... still Hackin away
 
Old 04-26-2003, 02:54 PM   #11
Makyver
LQ Newbie
 
Registered: Apr 2003
Location: Austin, TX.
Distribution: Gentoo
Posts: 14

Original Poster
Rep: Reputation: 0
/home/packages/Gtk-Perl-0.7008$ perl Makefile.PL
Can't exec "libglade-config": No such file or directory at Makefile.PL line 141.
Unknown library `applets'
Packages to compile: Gtk GdkImlib GdkPixbuf GtkXmHTML Gnome.
Checking if your kit is complete...
Looks good
Warning: prerequisite XML::Parser 0 not found.
Warning: prerequisite XML::Writer 0 not found.
Subroutine MY:ostamble redefined at ./Makefile.PL line 172.
Use of uninitialized value in string eq at ./Makefile.PL line 35.
Located Gtk version 1.2.10...
Invoking gendefs.pl with [gtk-0.99.defs, gtk-1.0.defs, gtk-1.1.defs, gtk-1.1.1.d efs, gtk-1.1.3.defs, gtk-1.1.4.defs, gtk-1.1.6.defs, gtk-1.2.defs].
Please wait, this may take a moment...
Loading gtk-0.99.defs
Loading gtk-1.0.defs
Loading gtk-1.1.defs
Loading gtk-1.1.1.defs
Loading gtk-1.1.3.defs
Loading gtk-1.1.4.defs
Loading gtk-1.1.6.defs
Loading gtk-1.2.defs
Dir ||
Overriding object `GtkButton'
Overriding flags `GtkSpinButtonUpdatePolicy'
Overriding object `GtkProgressBar'
Overriding enum `GdkEventType'
Dir ||
Overriding flags `GtkSpinButtonUpdatePolicy'
Overriding object `GtkProgressBar'
Overriding enum `GtkScrollType'
Overriding enum `GtkTroughType'
Overriding enum `GtkVisibility'
Overriding object `GtkProgress'
Overriding object `GtkProgressBar'
Dir ||
Dir ||
Overriding enum `GdkEventType'
Dir ||
Dir ||
Overriding flags `GtkSignalRunType'
Overriding enum `GtkPolicyType'
Dir ||
Overriding flags `GtkSpinButtonUpdatePolicy'
Overriding object `GtkProgressBar'
Overriding object `GtkProgress'
Overriding enum `GtkCTreePos'
Overriding enum `GtkCTreeLineStyle'
Overriding enum `GtkCTreeExpansionType'
Overriding flags `GtkDebugFlag'
Overriding flags `GtkAccelFlags'Overriding enum `GtkMatchType'
Overriding enum `GtkPathPriorityType'
Overriding enum `GtkPathType'
Overriding enum `GtkReliefStyle'
Overriding enum `GtkResizeMode'
Overriding flags `GtkSignalRunType'
Overriding enum `GtkScrollType'
Overriding enum `GtkTroughType'
Overriding enum `GtkVisibility'
Overriding enum `GtkFontMetricType'
Overriding flags `GtkObjectFlags'
Overriding boxed `GtkAccelGroup'
Overriding object `GtkAccelLabel'
Overriding object `GtkCTree'
Overriding object `GtkFontSelection'
Overriding object `GtkFontSelectionDialog'
Overriding object `GtkItemFactory'
Overriding object `GtkProgress'
Overriding object `GtkProgressBar'
Overriding enum `GtkProgressBarStyle'
Overriding enum `GtkProgressBarOrientation'
Overriding boxed `GtkCTreeNode'
Overriding boxed `GtkCTreeRow'
Overriding enum `GdkFunction'
Overriding flags `GdkWindowHints'
Dir ||
print() on closed filehandle T at ../tools/gendefs.pl line 379.
readline() on closed filehandle T at ../tools/gendefs.pl line 417.
ERROR from evaluation of /home/packages/Gtk-Perl-0.7008/Gtk/Makefile.PL: Unable to write to build/GtkTypemap: No such file or directory at ../tools/gendefs.pl l ine 602.

Ok so I still have problems and I can't get this to work yet I still need your help...... There is the last error from Perl Makefile.Pl to install Gtk-Perl

thanks for the help all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk or perl not installed? surrealism Linux - Software 5 04-25-2004 07:29 AM
Just installed Gnome2.6 ababkin Linux - Software 2 04-04-2004 09:25 PM
GTK-Perl Install mrant Linux - Software 9 01-07-2004 06:31 PM
Gtk-Perl Pougan Linux - Software 0 12-02-2003 08:57 PM
GTK-Perl UB_KMA Linux - Software 5 12-31-2002 06:07 AM


All times are GMT -5. The time now is 02:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration