LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2006, 12:16 PM   #1
jborn
Member
 
Registered: Oct 2005
Distribution: FC 8
Posts: 53

Rep: Reputation: 15
another yum upgrade error this one for libvorbis


The following output is received when trying to upgrade libvorbis. At the very bottom I tried to disable atrpms but that didn't do anything.

Most of the libraries it is complaining about are already installed in /usr/lib or /usr/lib64.

So question is how do I fix this? Uninstall stuff? Force updates? Manually update dependancies? This has happened a few times before to me and it always seems to clear up if I wait for a couple of days, but not this time. I would like to understand the yum upgrade process, but have not seem a consice summary of how it works.


yum update libvorbis
Setting up Update Process
Setting up repositories
atrpms 100% |=========================| 951 B 00:00
freshrpms 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 433 kB 00:01
updates-re: ################################################## 1213/1213
Added 2 new packages, deleted 0 old in 0.95 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libvorbis.x86_64 1:1.1.2-4.rhfc4.at set to be updated
---> Package libvorbis.i386 1:1.1.2-4.rhfc4.at set to be updated
--> Running transaction check
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: kdelibs
--> Processing Dependency: libvorbis.so.0 for package: kdebase
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: vorbis-tools
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: sox
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: libquicktime
--> Processing Dependency: libvorbisfile.so.3 for package: kdebase
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: gstreamer-plugins
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: kdepim
--> Processing Dependency: libvorbis.so.0()(64bit) for package: kdepim
--> Processing Dependency: libvorbis.so.0()(64bit) for package: gstreamer-plugins
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: mythmusic
--> Processing Dependency: libvorbis.so.0()(64bit) for package: vorbis-tools
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: kdebase
--> Processing Dependency: libvorbisfile.so.3 for package: arts
--> Processing Dependency: libvorbisfile.so.3 for package: kdelibs
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: sox
--> Processing Dependency: libvorbis.so.0()(64bit) for package: kdelibs
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: arts
--> Processing Dependency: libvorbis.so.0()(64bit) for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0()(64bit) for package: transcode
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: kdeartwork
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: kdeaddons
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: kdelibs
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: kdeartwork
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: arts
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: transcode
--> Processing Dependency: libvorbisenc.so.2 for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0()(64bit) for package: sox
--> Processing Dependency: libvorbis.so.0 for package: arts
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: libquicktime
--> Processing Dependency: libvorbisfile.so.3 for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0()(64bit) for package: libquicktime
--> Processing Dependency: libvorbis.so.0 for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0 for package: kdelibs
--> Processing Dependency: libvorbis.so.0()(64bit) for package: kdenetwork
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: kdepim
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: kdebase
--> Processing Dependency: libvorbis.so.0()(64bit) for package: kdeaddons
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: kdeaddons
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: kdenetwork
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: mythmusic
--> Processing Dependency: libvorbis.so.0()(64bit) for package: kdebase
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0()(64bit) for package: arts
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: kdenetwork
--> Processing Dependency: libvorbisfile.so.3()(64bit) for package: kdemultimedia
--> Processing Dependency: libvorbisenc.so.2 for package: kdelibs
--> Processing Dependency: libvorbisenc.so.2 for package: arts
--> Processing Dependency: libvorbisenc.so.2 for package: kdebase
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: vorbis-tools
--> Processing Dependency: libvorbis.so.0()(64bit) for package: mythmusic
--> Processing Dependency: libvorbis = 1:1.1.0 for package: libvorbis-devel
--> Processing Dependency: libvorbis.so.0()(64bit) for package: kdeartwork
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kdemultimedia.x86_64 6:3.5.0-0.1.fc4 set to be updated
---> Package kdepim.x86_64 6:3.5.0-0.2.fc4 set to be updated
---> Package kdebase.x86_64 6:3.5.0-0.1.fc4 set to be updated
---> Package mythmusic.x86_64 0:0.18.1-115.rhfc4.at set to be updated
---> Package kdeartwork.x86_64 0:3.5.0-0.1.fc4 set to be updated
---> Package libvorbisenc2.x86_64 1:1.1.2-4.rhfc4.at set to be updated
---> Package kdelibs.x86_64 6:3.5.0-0.2.fc4 set to be updated
---> Package libvorbisfile3.x86_64 1:1.1.2-4.rhfc4.at set to be updated
---> Package arts.x86_64 8:1.5.0-0.2.fc4 set to be updated
---> Package kdeaddons.x86_64 0:3.5.0-0.1.fc4 set to be updated
---> Package libvorbis-devel.x86_64 1:1.1.2-4.rhfc4.at set to be updated
---> Package kdenetwork.x86_64 7:3.5.0-0.1.fc4 set to be updated
---> Package libvorbis0.x86_64 1:1.1.2-4.rhfc4.at set to be updated
--> Running transaction check
--> Processing Dependency: libvorbisenc.so.2 for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0 for package: arts
--> Processing Dependency: libvorbisenc.so.2 for package: kdelibs
--> Processing Dependency: libvorbisenc.so.2 for package: arts
--> Processing Dependency: libvorbis.so.0 for package: kdebase
--> Processing Dependency: libvorbisfile.so.3 for package: arts
--> Processing Dependency: libvorbisfile.so.3 for package: kdemultimedia
--> Processing Dependency: libvorbisenc.so.2 for package: kdebase
--> Processing Dependency: libvorbisfile.so.3 for package: kdelibs
--> Processing Dependency: libvorbis.so.0 for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0 for package: kdelibs
--> Processing Dependency: libvorbisfile.so.3 for package: kdebase
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Dependency: libvorbisenc.so.2 for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0 for package: arts
--> Processing Dependency: libvorbisenc.so.2 for package: kdelibs
--> Processing Dependency: libvorbisenc.so.2 for package: arts
--> Processing Dependency: libvorbis.so.0 for package: kdebase
--> Processing Dependency: libvorbisfile.so.3 for package: arts
--> Processing Dependency: libvorbisfile.so.3 for package: kdemultimedia
--> Processing Dependency: libvorbisenc.so.2 for package: kdebase
--> Processing Dependency: libvorbisfile.so.3 for package: kdelibs
--> Processing Dependency: libvorbis.so.0 for package: kdemultimedia
--> Processing Dependency: libvorbis.so.0 for package: kdelibs
--> Processing Dependency: libvorbisfile.so.3 for package: kdebase
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package kdemultimedia needs libvorbisenc.so.2, this is not available.
Error: Package arts needs libvorbis.so.0, this is not available.
Error: Package kdelibs needs libvorbisenc.so.2, this is not available.
Error: Package arts needs libvorbisenc.so.2, this is not available.
Error: Package kdebase needs libvorbis.so.0, this is not available.
Error: Package arts needs libvorbisfile.so.3, this is not available.
Error: Package kdemultimedia needs libvorbisfile.so.3, this is not available.
Error: Package kdebase needs libvorbisenc.so.2, this is not available.
Error: Package kdelibs needs libvorbisfile.so.3, this is not available.
Error: Package kdemultimedia needs libvorbis.so.0, this is not available.
Error: Package kdelibs needs libvorbis.so.0, this is not available.
Error: Package kdebase needs libvorbisfile.so.3, this is not available.

###########################################################################
# DISABLE ATRPMS
###########################################################################

yum --disablerepo=atrpms update libvorbis
Setting up Update Process
Setting up repositories
freshrpms 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Could not find update match for libvorbis
No Packages marked for Update/Obsoletion

############################################################################

Thanks for the help
 
Old 01-14-2006, 01:41 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Went thru a simular experience myself, hint get the libvorbis rpms from http://rpm.pbone.net/ ;

$ rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'libvorbis*'
libvorbis-1.1.0-1.x86_64.rpm
libvorbis-devel-1.1.0-1.x86_64.rpm
libvorbis-1.1.0-1.i386.rpm
 
Old 01-14-2006, 02:50 PM   #3
jborn
Member
 
Registered: Oct 2005
Distribution: FC 8
Posts: 53

Original Poster
Rep: Reputation: 15
I got the three recommended packages and it says they are already installed:

rpm -Uvh libvorbis-1.1.0-2.x86_64.rpm
Preparing... ########################################### [100%]
package libvorbis-1.1.0-2 is already installed

rpm -Uvh libvorbis-devel-1.1.0-2.x86_64.rpm
Preparing... ########################################### [100%]
package libvorbis-devel-1.1.0-2 is already installed

rpm -Uvh libvorbis-1.1.0-2.i386.rpm
Preparing... ########################################### [100%]
package libvorbis-1.1.0-2 is already installed

Whats next?
 
Old 01-14-2006, 03:43 PM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Look again, yours are libvorbis-1.1.0-2 rpm's and I (meant to say) try the libvorbis-1.1.0-1 rpm's.
 
Old 01-15-2006, 08:30 AM   #5
jborn
Member
 
Registered: Oct 2005
Distribution: FC 8
Posts: 53

Original Poster
Rep: Reputation: 15
OK.. I attempted to get the -1 versions. All returned this just with different file names:

FILE WASN'T FOUND IN ANY RPM FILE. TRYING TO SEARCH THIS FILE ON FTP SERVERS
You have chosen search rpm in world FTP resources.
Your search libvorbis-1.1.0-1.i386.rpm did not match any entry in database.
If you didn't do it, try add to searched space more distributions and repositories

So if that worked for you that means that packages like kdebase currently don't have the newest libvorbis as a dependency, but an older one. It also seems to mean that I installed a package that required a newer libvorbis. Does that sound correct?

Can they both be installed at the same time since they seem to be library files?
Can I update the dependencies manually? Idea here is to force packages like kdebase to use the newest library?

Another other solutions? Remove packages that used libvorbis in the first place? How would I figure out what package needed that?

Thanks again for all the information.
 
Old 01-15-2006, 10:42 AM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
The libvorbis packages are needed by a large variety of other packages, for the list type; rpm -e libvorbis libvorbis --allmatches --test See 'man rpm' minus the single quotemarks for the details and other options.But your list is posted in your first message (sox, transcode and other packages)

Taking the time to check something (after downloading the FC4 libvorbis packages);
$ ls -l lib*
-rw-r--r-- 1 lenard lenard 195954 Jan 15 10:21 libvorbis-1.1.0-2.i386.rpm
-rw-r--r-- 1 lenard lenard 228978 Jan 15 10:21 libvorbis-1.1.0-2.x86_64.rpm
-rw-r--r-- 1 lenard lenard 603302 Jan 15 10:21 libvorbis-devel-1.1.0-2.x86_64.rpm

$ rpm -Uvh libvorbis*.rpm --test
warning: libvorbis-1.1.0-2.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing... ########################################### [100%]

Which means the FC4 kde-3.5 rpms (and all other packages on my system) are OK with these FC4 libvorbis packages. So the problem is with your libvorbis packages, see;

---> Package libvorbis0.x86_64 1:1.1.2-4.rhfc4.at set to be updated

Which libvorbis packages do you have installed???? Use the command below to find out;

$ rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'libvorbis*'
 
Old 01-15-2006, 11:14 AM   #7
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Yep, you have a problem with those libvorbis rpms supplied by atrpms;

$ ls
libvorbis-1.1.2-4.rhfc4.at.i386.rpm
libvorbis-1.1.2-4.rhfc4.at.x86_64.rpm
libvorbis-devel-1.1.2-4.rhfc4.at.x86_64.rpm

$ rpm -Uvh libvorbis*.rpm --test
warning: libvorbis-1.1.2-4.rhfc4.at.i386.rpm: Header V3 DSA signature: NOKEY, key ID 66534c2b
error: Failed dependencies:
libvorbis0 = 1:1.1.2-4.rhfc4.at is needed by libvorbis-devel-1.1.2-4.rhfc4.at.x86_64
libvorbisenc2 = 1:1.1.2-4.rhfc4.at is needed by libvorbis-devel-1.1.2-4.rhfc4.at.x86_64
libvorbisfile3 = 1:1.1.2-4.rhfc4.at is needed by libvorbis-devel-1.1.2-4.rhfc4.at.x86_64
libvorbis.so.0()(64bit) is needed by (installed) sox-12.17.5-3.x86_64
libvorbis.so.0()(64bit) is needed by (installed) xmms-1.2.10-11.1.2.el4.rf.x86_64
libvorbis.so.0()(64bit) is needed by (installed) k3b-0.12.10-1.x86_64
libvorbis.so.0()(64bit) is needed by (installed) arts-1.5.0-0.2.fc4.x86_64
libvorbis.so.0()(64bit) is needed by (installed) kdelibs-3.5.0-0.2.fc4.x86_64

<snip> you get the idea....

It seems that you need to replace the atrpms packages. It also seems that you have additional libvorbis from atrpms also installed (libvorbis0 = 1:1.1.2-4.rhfc4.at is needed by libvorbis-devel-1.1.2-4.rhfc4.at.x86_64). Will wait to see which libvoris rpms you have installed. Hopefully we can correct this issue fairly easy so you can install the FC4 KDE-3.5 packages.
 
Old 01-15-2006, 12:37 PM   #8
jborn
Member
 
Registered: Oct 2005
Distribution: FC 8
Posts: 53

Original Poster
Rep: Reputation: 15
I've been using yum to do the installs so I don't believe I have all the rpms you would need to see tested. I did find this however:

locate rpm | grep libvorbis
/var/cache/yum/atrpms/headers/libvorbis-1.1.1-0_3.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbis-1.1.2-4.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbis0-1.1.1-0_3.rhfc4.at.i386.hdr
/var/cache/yum/atrpms/headers/libvorbis-1.1.1-0_3.rhfc4.at.i386.hdr
/var/cache/yum/atrpms/headers/libvorbis0-1.1.2-4.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbisfile3-1.1.2-4.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbisfile3-1.1.1-0_3.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbisenc2-1.1.1-0_3.rhfc4.at.i386.hdr
/var/cache/yum/atrpms/headers/libvorbisfile3-1.1.1-0_3.rhfc4.at.i386.hdr
/var/cache/yum/atrpms/headers/libvorbis0-1.1.2-4.rhfc4.at.i386.hdr
/var/cache/yum/atrpms/headers/libvorbisenc2-1.1.2-4.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbisenc2-1.1.1-0_3.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbis-devel-1.1.2-4.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbis0-1.1.1-0_3.rhfc4.at.x86_64.hdr
/var/cache/yum/atrpms/headers/libvorbis-1.1.2-4.rhfc4.at.i386.hdr
/var/cache/yum/atrpms/headers/libvorbis-devel-1.1.1-0_3.rhfc4.at.x86_64.hdr

For the rpms that I found earlier and tried to install here is the information I could pull about them:

ls
libvorbis-1.1.0-2.i386.rpm
libvorbis-1.1.0-2.x86_64.rpm
libvorbis-devel-1.1.0-2.x86_64.rpm

And here is the rpm test information:
rpm -Uvh libvorbis*.rpm --test
Preparing... ########################################### [100%]
package libvorbis-1.1.0-2 is already installed
package libvorbis-devel-1.1.0-2 is already installed

Here is the only other piece of information I could think to include:
locate libvorbis
/usr/lib/libvorbis.so.0
/usr/lib/libvorbisenc.so.2
/usr/lib/libvorbis.so.0.3.0
/usr/lib/libvorbisenc.so.2.0.0
/usr/lib/libvorbisfile.so.3
/usr/lib/libvorbisfile.so.3.1.0
/usr/lib64/libvorbis.so.0
/usr/lib64/libvorbisenc.so.2
/usr/lib64/libvorbis.a
/usr/lib64/libvorbisfile.a
/usr/lib64/libvorbisenc.a
/usr/lib64/libvorbisenc.so
/usr/lib64/libvorbisfile.so
/usr/lib64/libvorbis.so.0.3.0
/usr/lib64/libvorbisenc.so.2.0.0
/usr/lib64/libvorbisfile.so.3
/usr/lib64/libvorbisfile.so.3.1.0
/usr/lib64/libvorbis.so

I really appreciate the help here Lenard because I'm lost. Shouldn't be but I am.
 
Old 01-15-2006, 12:59 PM   #9
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
OK, I see that you have a fair number of vorbis packages that may be already installed, we need to find out which ones and what we need to remove (safely) then re-install to fix the broken packages. Step one if finding out which vorbis packages you have installed. Use the command below to find out, it will list every package that has 'vorbis' in the name of the package;

rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' '*vorbis*'

Then we can test remove the packages to see what may be broken and if we can use the standard FC4 vorbis packages to fix the broken dependencies (the packages that need libvorbis and so on).

Will wait to see the output from the above rpm command so I can offer the next step(s).
 
Old 01-15-2006, 01:19 PM   #10
jborn
Member
 
Registered: Oct 2005
Distribution: FC 8
Posts: 53

Original Poster
Rep: Reputation: 15
Here is the output:

rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' '*vorbis*'
libvorbis-1.1.0-2.x86_64.rpm
vorbis-tools-1.0.1-6.x86_64.rpm
libvorbis-devel-1.1.0-2.x86_64.rpm
libvorbis-1.1.0-2.i386.rpm
 
Old 01-15-2006, 01:51 PM   #11
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Those rpm packages should be OK, so now lets download the KDE-3.5 updates and see how installing them goes, without using yum. So lets generate a list of the KDE rpm packages you already have installed;

rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'arts*'

(you need to update arts for KDE-3.5)

rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'kde*' | sort

(a nice sorted list of the installed KDE packages which can use for getting the updated packages)

Download the updated arts and kde packages from the generated lists into a common locations. The download site (or one of the mirrors to use);

If you open Konqueror and place the following in the Location: bar it will make it somewhat easy to get then packages, or you can use your choice of browser.

ftp://download.fedora.redhat.com/pub...dates/4/x86_64

If you used Konqueror then you can select (by Ctrl+single-click on each rpm) all the arts and kde packages you need then save them to a commom location (right-click on a selected package and using the Copy To menu).

After downloading all the packages, try and test install then all at once;

rpm -Uvh *.rpm --test

If you get no errors then as root from the console only install all of them (remove the --test switch from the command) then re-boot your system.

If you get any errors post them.
 
Old 01-15-2006, 02:14 PM   #12
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
You will need an additional rpm also, please see;

http://www.linuxquestions.org/questi...d.php?t=402987
 
Old 01-15-2006, 02:35 PM   #13
jborn
Member
 
Registered: Oct 2005
Distribution: FC 8
Posts: 53

Original Poster
Rep: Reputation: 15
Well I'm not getting errors... They are already installed.

rpm -Uvh *.rpm --test
Preparing... ########################################### [100%]
package libvorbis-1.1.0-2 is already installed
package arts-1.4.2-0.fc4.1 is already installed
package kdelibs-3.4.2-0.fc4.1 is already installed
package kdebase-3.4.2-0.fc4.1 is already installed
package kdemultimedia-3.4.2-0.fc4.1 is already installed
package kdepim-3.4.2-0.fc4.3 is already installed
package kdeaddons-3.4.2-0.fc4.1 is already installed
package kdeadmin-3.4.2-0.fc4.1 is already installed
package kdeartwork-3.4.2-0.fc4.1 is already installed
package kdegraphics-3.4.2-0.fc4.2 is already installed
package kdenetwork-3.4.2-0.fc4.2 is already installed
package kdeutils-3.4.2-0.fc4.1 is already installed
package libvorbis-devel-1.1.0-2 is already installed

Here are the outputs of the rpm queries:
rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'arts*'
arts-1.4.2-0.fc4.1.i386.rpm
arts-1.4.2-0.fc4.1.x86_64.rpm

rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'kde*'
kdegraphics-3.4.2-0.fc4.2.x86_64.rpm
kdelibs-3.4.2-0.fc4.1.i386.rpm
kdebase-3.4.2-0.fc4.1.x86_64.rpm
kdemultimedia-3.4.2-0.fc4.1.i386.rpm
kdeutils-3.4.2-0.fc4.1.x86_64.rpm
kdeartwork-3.4.2-0.fc4.1.x86_64.rpm
kdenetwork-3.4.2-0.fc4.2.x86_64.rpm
kdelibs-3.4.2-0.fc4.1.x86_64.rpm
kdepim-3.4.2-0.fc4.3.x86_64.rpm
kdeaddons-3.4.2-0.fc4.1.x86_64.rpm
kdeadmin-3.4.2-0.fc4.1.x86_64.rpm
kdemultimedia-3.4.2-0.fc4.1.x86_64.rpm
kdebase-3.4.2-0.fc4.1.i386.rpm

I originally went down the path of updating the libvorbis after attempting to use yumex when yum failed on me. I thought I had nailed down my dependency problem, but in retrospec maybe I should have started with the following question: When I run yum with the atrpms disabled I only get the following log with one error message:

yum --disablerepo=atrpms update
Setting up Update Process
Setting up repositories
freshrpms 100% |=========================| 951 B 00:00
http://ftp.uni-bayreuth.de/linux/fed...ta/repomd.xml: [Errno 4] IOError: <urlopen error (111, 'Connection refused')>
Trying other mirror.
extras 100% |=========================| 1.1 kB 00:00
updates-released 100% |=========================| 951 B 00:00
http://linux.admin.uillinois.edu/pub...ta/repomd.xml: [Errno 4] IOError: HTTP Error 403: Date: Sun, 15 Jan 2006 19:24:12 GMT
Server: Apache/2.0.46 (Red Hat)
Content-Length: 355
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package acl.x86_64 0:2.2.32-1.FC4.2 set to be updated
---> Package netpbm.x86_64 0:10.31-1.FC4 set to be updated
---> Package attr.x86_64 0:2.4.24-1.FC4.1 set to be updated
---> Package kdemultimedia.x86_64 6:3.5.0-0.1.fc4 set to be updated
---> Package kdepim.x86_64 6:3.5.0-0.2.fc4 set to be updated
---> Package util-linux.x86_64 0:2.12p-9.13 set to be updated
---> Package dhclient.x86_64 10:3.0.2-28.FC4 set to be updated
---> Package tetex.x86_64 0:3.0-9.FC4 set to be updated
---> Package sudo.x86_64 0:1.6.8p8-2.4 set to be updated
---> Package kdebase.x86_64 6:3.5.0-0.1.fc4 set to be updated
---> Package tetex-fonts.x86_64 0:3.0-9.FC4 set to be updated
---> Package kdelibs.i386 6:3.5.0-0.2.fc4 set to be updated
---> Package curl.x86_64 0:7.13.1-5.fc4 set to be updated
---> Package kdegraphics.x86_64 7:3.5.0-0.1.fc4 set to be updated
---> Package kdelibs.x86_64 6:3.5.0-0.2.fc4 set to be updated
---> Package curl-devel.x86_64 0:7.13.1-5.fc4 set to be updated
---> Package lftp.x86_64 0:3.2.1-10_FC4 set to be updated
---> Package kdemultimedia.i386 6:3.5.0-0.1.fc4 set to be updated
---> Package sane-backends.x86_64 0:1.0.17-0.fc4.1 set to be updated
---> Package less.x86_64 0:394-1.fc4 set to be updated
---> Package kbd.x86_64 0:1.12-10.fc4.1 set to be updated
---> Package mysql.i386 0:4.1.16-1.FC4.1 set to be updated
---> Package libavc1394.x86_64 0:0.5.1-0.2.fc4 set to be updated
---> Package sane-backends.i386 0:1.0.17-0.fc4.1 set to be updated
---> Package cups-libs.i386 1:1.1.23-15.3 set to be updated
---> Package cups-libs.x86_64 1:1.1.23-15.3 set to be updated
---> Package xterm.x86_64 0:207-2.FC4 set to be updated
---> Package openoffice.org-graphicfilter.i386 1:2.0.1.1-4.1 set to be updated
---> Package ruby-libs.x86_64 0:1.8.4-1.fc4 set to be updated
---> Package arts.i386 8:1.5.0-0.2.fc4 set to be updated
---> Package openoffice.org-math.i386 1:2.0.1.1-4.1 set to be updated
---> Package kernel-devel.x86_64 0:2.6.14-1.1656_FC4 set to be installed
---> Package mysql.x86_64 0:4.1.16-1.FC4.1 set to be updated
---> Package openoffice.org-writer.i386 1:2.0.1.1-4.1 set to be updated
---> Package openoffice.org-impress.i386 1:2.0.1.1-4.1 set to be updated
---> Package netpbm-progs.x86_64 0:10.31-1.FC4 set to be updated
---> Package gjdoc.x86_64 0:0.7.7-0.FC4 set to be updated
---> Package postgresql-libs.i386 0:8.0.6-1.FC4.1 set to be updated
---> Package eclipse-ecj.x86_64 1:3.1.1-1jpp_1fc.FC4.12 set to be updated
---> Package flex.x86_64 0:2.5.4a-35.fc4 set to be updated
---> Package gimp.x86_64 2:2.2.10-0.fc4.1 set to be updated
---> Package kdeadmin.x86_64 7:3.5.0-0.1.fc4 set to be updated
---> Package kernel.x86_64 0:2.6.14-1.1656_FC4 set to be installed
---> Package hpijs.x86_64 1:0.9.7-4.2 set to be updated
---> Package kdebase.i386 6:3.5.0-0.1.fc4 set to be updated
---> Package curl.i386 0:7.13.1-5.fc4 set to be updated
---> Package openoffice.org-core.i386 1:2.0.1.1-4.1 set to be updated
---> Package mysql-server.x86_64 0:4.1.16-1.FC4.1 set to be updated
---> Package cups.x86_64 1:1.1.23-15.3 set to be updated
---> Package mysql-devel.x86_64 0:4.1.16-1.FC4.1 set to be updated
---> Package selinux-policy-targeted.noarch 0:1.27.1-2.16 set to be updated
---> Package kdeartwork.x86_64 0:3.5.0-0.1.fc4 set to be updated
---> Package system-config-nfs.noarch 0:1.3.11-0.fc4.2 set to be updated
---> Package openoffice.org-draw.i386 1:2.0.1.1-4.1 set to be updated
---> Package caching-nameserver.noarch 0:7.3-4.FC4 set to be updated
---> Package poppler.x86_64 0:0.4.4-1.1 set to be updated
---> Package tzdata.noarch 0:2005r-3.fc4 set to be updated
---> Package arts.x86_64 8:1.5.0-0.2.fc4 set to be updated
---> Package kdeaddons.x86_64 0:3.5.0-0.1.fc4 set to be updated
---> Package perl.x86_64 3:5.8.6-22 set to be updated
---> Package libc-client.i386 0:2002e-17 set to be updated
---> Package ruby-libs.i386 0:1.8.4-1.fc4 set to be updated
---> Package yum.noarch 0:2.4.1-1.fc4 set to be updated
---> Package libattr.i386 0:2.4.24-1.FC4.1 set to be updated
---> Package libacl.i386 0:2.2.32-1.FC4.2 set to be updated
---> Package netpbm.i386 0:10.31-1.FC4 set to be updated
---> Package alsa-utils.x86_64 0:1.0.10-1.FC4 set to be updated
---> Package libacl-devel.x86_64 0:2.2.32-1.FC4.2 set to be updated
---> Package openoffice.org-calc.i386 1:2.0.1.1-4.1 set to be updated
---> Package alsa-lib.i386 0:1.0.10-2.FC4 set to be updated
---> Package libattr-devel.x86_64 0:2.4.24-1.FC4.1 set to be updated
---> Package fetchmail.x86_64 0:6.2.5.5-1.fc4 set to be updated
---> Package openoffice.org-xsltfilter.i386 1:2.0.1.1-4.1 set to be updated
---> Package libattr.x86_64 0:2.4.24-1.FC4.1 set to be updated
---> Package kdeutils.x86_64 6:3.5.0-0.1.fc4 set to be updated
---> Package libacl.x86_64 0:2.2.32-1.FC4.2 set to be updated
---> Package alsa-lib.x86_64 0:1.0.10-2.FC4 set to be updated
---> Package kdenetwork.x86_64 7:3.5.0-0.1.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libhpip.so.0()(64bit) for package: hpijs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libsane-hpaio.x86_64 0:0.9.7-4.2 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
kernel x86_64 2.6.14-1.1656_FC4 updates-released 14 M
kernel-devel x86_64 2.6.14-1.1656_FC4 updates-released 4.2 M
Updating:
acl x86_64 2.2.32-1.FC4.2 updates-released 65 k
alsa-lib i386 1.0.10-2.FC4 updates-released 376 k
alsa-lib x86_64 1.0.10-2.FC4 updates-released 381 k
alsa-utils x86_64 1.0.10-1.FC4 updates-released 1.0 M
arts i386 8:1.5.0-0.2.fc4 updates-released 1.1 M
arts x86_64 8:1.5.0-0.2.fc4 updates-released 1.2 M
attr x86_64 2.4.24-1.FC4.1 updates-released 48 k
caching-nameserver noarch 7.3-4.FC4 updates-released 22 k
cups x86_64 1:1.1.23-15.3 updates-released 1.6 M
cups-libs i386 1:1.1.23-15.3 updates-released 113 k
cups-libs x86_64 1:1.1.23-15.3 updates-released 110 k
curl x86_64 7.13.1-5.fc4 updates-released 259 k
curl i386 7.13.1-5.fc4 updates-released 262 k
curl-devel x86_64 7.13.1-5.fc4 updates-released 271 k
dhclient x86_64 10:3.0.2-28.FC4 updates-released 242 k
eclipse-ecj x86_64 1:3.1.1-1jpp_1fc.FC4.12 updates-released 7.8 M
fetchmail x86_64 6.2.5.5-1.fc4 updates-released 575 k
flex x86_64 2.5.4a-35.fc4 updates-released 127 k
gimp x86_64 2:2.2.10-0.fc4.1 updates-released 10 M
gjdoc x86_64 0.7.7-0.FC4 updates-released 1.2 M
hpijs x86_64 1:0.9.7-4.2 updates-released 192 k
kbd x86_64 1.12-10.fc4.1 updates-released 1.1 M
kdeaddons x86_64 3.5.0-0.1.fc4 updates-released 2.5 M
kdeadmin x86_64 7:3.5.0-0.1.fc4 updates-released 1.2 M
kdeartwork x86_64 3.5.0-0.1.fc4 updates-released 5.9 M
kdebase x86_64 6:3.5.0-0.1.fc4 updates-released 28 M
kdebase i386 6:3.5.0-0.1.fc4 updates-released 28 M
kdegraphics x86_64 7:3.5.0-0.1.fc4 updates-released 6.6 M
kdelibs i386 6:3.5.0-0.2.fc4 updates-released 18 M
kdelibs x86_64 6:3.5.0-0.2.fc4 updates-released 18 M
kdemultimedia x86_64 6:3.5.0-0.1.fc4 updates-released 6.6 M
kdemultimedia i386 6:3.5.0-0.1.fc4 updates-released 6.5 M
kdenetwork x86_64 7:3.5.0-0.1.fc4 updates-released 11 M
kdepim x86_64 6:3.5.0-0.2.fc4 updates-released 19 M
kdeutils x86_64 6:3.5.0-0.1.fc4 updates-released 3.8 M
less x86_64 394-1.fc4 updates-released 98 k
lftp x86_64 3.2.1-10_FC4 updates-released 730 k
libacl i386 2.2.32-1.FC4.2 updates-released 17 k
libacl x86_64 2.2.32-1.FC4.2 updates-released 17 k
libacl-devel x86_64 2.2.32-1.FC4.2 updates-released 81 k
libattr i386 2.4.24-1.FC4.1 updates-released 9.7 k
libattr x86_64 2.4.24-1.FC4.1 updates-released 9.9 k
libattr-devel x86_64 2.4.24-1.FC4.1 updates-released 29 k
libavc1394 x86_64 0.5.1-0.2.fc4 freshrpms 37 k
libc-client i386 2002e-17 updates-released 479 k
mysql i386 4.1.16-1.FC4.1 updates-released 2.8 M
mysql x86_64 4.1.16-1.FC4.1 updates-released 2.8 M
mysql-devel x86_64 4.1.16-1.FC4.1 updates-released 2.1 M
mysql-server x86_64 4.1.16-1.FC4.1 updates-released 6.9 M
netpbm x86_64 10.31-1.FC4 updates-released 128 k
netpbm i386 10.31-1.FC4 updates-released 128 k
netpbm-progs x86_64 10.31-1.FC4 updates-released 1.9 M
openoffice.org-calc i386 1:2.0.1.1-4.1 updates-released 6.5 M
openoffice.org-core i386 1:2.0.1.1-4.1 updates-released 83 M
openoffice.org-draw i386 1:2.0.1.1-4.1 updates-released 1.1 M
openoffice.org-graphicfilter i386 1:2.0.1.1-4.1 updates-released 170 k
openoffice.org-impress i386 1:2.0.1.1-4.1 updates-released 1.5 M
openoffice.org-math i386 1:2.0.1.1-4.1 updates-released 1.3 M
openoffice.org-writer i386 1:2.0.1.1-4.1 updates-released 2.7 M
openoffice.org-xsltfilter i386 1:2.0.1.1-4.1 updates-released 74 k
perl x86_64 3:5.8.6-22 updates-released 12 M
poppler x86_64 0.4.4-1.1 updates-released 439 k
postgresql-libs i386 8.0.6-1.FC4.1 updates-released 181 k
ruby-libs x86_64 1.8.4-1.fc4 updates-released 1.5 M
ruby-libs i386 1.8.4-1.fc4 updates-released 1.5 M
sane-backends x86_64 1.0.17-0.fc4.1 updates-released 3.0 M
sane-backends i386 1.0.17-0.fc4.1 updates-released 3.0 M
selinux-policy-targeted noarch 1.27.1-2.16 updates-released 921 k
sudo x86_64 1.6.8p8-2.4 updates-released 192 k
system-config-nfs noarch 1.3.11-0.fc4.2 updates-released 137 k
tetex x86_64 3.0-9.FC4 updates-released 14 M
tetex-fonts x86_64 3.0-9.FC4 updates-released 29 M
tzdata noarch 2005r-3.fc4 updates-released 439 k
util-linux x86_64 2.12p-9.13 updates-released 1.6 M
xterm x86_64 207-2.FC4 updates-released 195 k
yum noarch 2.4.1-1.fc4 updates-released 386 k
Installing for dependencies:
libsane-hpaio x86_64 0.9.7-4.2 updates-released 109 k

Transaction Summary
=============================================================================
Install 3 Package(s)
Update 76 Package(s)
Remove 0 Package(s)
Total download size: 382 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error: file /usr/share/man/man1/dvcont.1.gz from install of libavc1394-0.5.1-0.2.fc4 conflicts with file from package libavc1394-0.4.1-8

When I don't have atrpms disabled I get the kde dependencies errors. Which is what I've been attempting to solve. However maybe solving the proceding error is the way to go.
 
Old 01-15-2006, 03:17 PM   #14
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Quote:
Originally Posted by jborn
Well I'm not getting errors... They are already installed.

rpm -Uvh *.rpm --test
Preparing... ########################################### [100%]
package libvorbis-1.1.0-2 is already installed
package arts-1.4.2-0.fc4.1 is already installed
package kdelibs-3.4.2-0.fc4.1 is already installed
package kdebase-3.4.2-0.fc4.1 is already installed
package kdemultimedia-3.4.2-0.fc4.1 is already installed
package kdepim-3.4.2-0.fc4.3 is already installed
package kdeaddons-3.4.2-0.fc4.1 is already installed
package kdeadmin-3.4.2-0.fc4.1 is already installed
package kdeartwork-3.4.2-0.fc4.1 is already installed
package kdegraphics-3.4.2-0.fc4.2 is already installed
package kdenetwork-3.4.2-0.fc4.2 is already installed
package kdeutils-3.4.2-0.fc4.1 is already installed
package libvorbis-devel-1.1.0-2 is already installed

Here are the outputs of the rpm queries:
rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'arts*'
arts-1.4.2-0.fc4.1.i386.rpm
arts-1.4.2-0.fc4.1.x86_64.rpm

rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'kde*'
kdegraphics-3.4.2-0.fc4.2.x86_64.rpm
kdelibs-3.4.2-0.fc4.1.i386.rpm
kdebase-3.4.2-0.fc4.1.x86_64.rpm
kdemultimedia-3.4.2-0.fc4.1.i386.rpm
kdeutils-3.4.2-0.fc4.1.x86_64.rpm
kdeartwork-3.4.2-0.fc4.1.x86_64.rpm
kdenetwork-3.4.2-0.fc4.2.x86_64.rpm
kdelibs-3.4.2-0.fc4.1.x86_64.rpm
kdepim-3.4.2-0.fc4.3.x86_64.rpm
kdeaddons-3.4.2-0.fc4.1.x86_64.rpm
kdeadmin-3.4.2-0.fc4.1.x86_64.rpm
kdemultimedia-3.4.2-0.fc4.1.x86_64.rpm
kdebase-3.4.2-0.fc4.1.i386.rpm

OK, lets start again.......

Are you attempting to install the updates for KDE-3.5 correct??? Then why did you down load the KDE-3.4.2 rpms that you already have installed. The list you want to download is (based on your 3.4.2 installed list);

arts-1.5.0-0.2.fc4.x86_64.rpm
kdeaddons-3.5.0-0.1.fc4.x86_64.rpm
kdeadmin-3.5.0-0.1.fc4.x86_64.rpm
kdeartwork-3.5.0-0.1.fc4.x86_64.rpm
kdebase-3.5.0-0.1.fc4.x86_64.rpm
kdegraphics-3.5.0-0.1.fc4.x86_64.rpm
kdelibs-3.5.0-0.2.fc4.x86_64.rpm
kdemultimedia-3.5.0-0.1.fc4.x86_64.rpm
kdenetwork-3.5.0-0.1.fc4.x86_64.rpm
kdepim-3.5.0-0.2.fc4.x86_64.rpm
kdeutils-3.5.0-0.1.fc4.x86_64.rpm

Place only these files in a common location where they are the only rpm packages in the location. Then try the test installation again;

rpm -Uvh *.rpm --test

If you have any errors then post the errors from the output of the command.


Please keep yum out of the picture for now OK??? Yum is just a tool to help with updating rpm packages and resolving dependency problems, it does nothing more then call rpm in specific ways to accomplish this. We are basically doing the same thing manually and bypassing the problem your having with yum.
 
Old 01-15-2006, 05:06 PM   #15
jborn
Member
 
Registered: Oct 2005
Distribution: FC 8
Posts: 53

Original Poster
Rep: Reputation: 15
np. Since you have been so kind as to help me through this I wanted to make sure I'm following your directions to the "t". Anyway here is what is happening now; this message is duplicated many times for each package.

file /usr/share/servicetypes/krec_exportitem.desktop from install of kdemultimedia-3.5.0-0.1.fc4 conflicts with file from package kdemultimedia-3.4.2-0.fc4.1

My assumption is I want to remove 3.4.2-0.fc4.1. Then install 3.5.0-0.1.fc4
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libvorbis 1.0 compiler error eNTi Linux - General 3 01-04-2006 01:01 PM
Error after upgrade from FC3 to FC4 with yum mwpeng Linux - Newbie 1 08-22-2005 07:38 PM
Error at the end of a yum upgrade to FC2 stefaandk Fedora 1 07-26-2005 03:43 AM
libvorbis + error littlemidget Linux - Software 2 08-20-2004 01:09 AM
How to upgrade oggenc/libvorbis? colelinux Linux - Newbie 0 03-15-2004 08:38 PM


All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration