LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-22-2003, 01:09 PM   #1
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Rep: Reputation: 30
another gtk related enquiry ;-)


Hi there...

Here's another gtk related enquiry for you to try and resolve...

As with many of the other posts in here, people are trying to install gtk 2.0.0 or higher [on mandrake 9.1] and aren't having much luck. As far as I can tell i have it installed and have installed everything I can. When working frrom the guide on the gtk website I download all the dependants and all the files I need... do the usual ./configure - make - make install - but nothing seems to work. I eventually manage to get ATK into the compiler and it returns this error message:

checking for C compiler default output... configure: error: C compiler cannot create executables

I'm at a loss... Gaim looks like a really useful tool and I would be real greatful if someone would be able to help me install gtk.

Thanks a lot
 
Old 06-22-2003, 01:40 PM   #2
evilmonkey
Member
 
Registered: Jun 2003
Location: Toronto, Canada
Distribution: Ubuntu 10.04 LTS; CentOS 5.5
Posts: 199

Rep: Reputation: 30
I have the same problem. I install Glib, and when I try to install ATK, it tells me Glib is not installed. I'm running Mandrake 9.1.

Cheers!

Jack.
 
Old 06-22-2003, 01:43 PM   #3
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
Hi...

I Think I have managed to have all the glib files I need installed through the GnoRPM installation manager... I think. I have managed to do the usual as far as ./configure etc etc goes but then it shows that my compiler was not able to produce executables.

I was at the stage you are at now only a few hours ago... sucks major doesn't it? :-/

I'm sure someone will help us out soon enough ;-)
 
Old 06-22-2003, 01:53 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
this has nothign at all to do with gtk. you simply haven't installed the necessary devel packages to compile *any* code. glibc-devel etc...

why are you trying to install from source though? gtk2 is on your cd's as an rpm no problem, moreoever though, it probably *IS* installed already...
 
Old 06-22-2003, 01:59 PM   #5
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
I saw one of your previous threads earlier. I am trying to install GTK 2.2.2. However, 2.0.0 would be adequate. I believe already that I have GTK installed, unfortunately Gaim doesn't ;-)

I have installed everything I can possibly think of. Also, learning to compile source is something I would like to learn as this would come in useful for future reference, either for new kernel releases or softwares etc etc.

Thanks for your help
 
Old 06-22-2003, 02:19 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
try this:
Code:
[user@linux user]$ rpm -qa | grep gtk
i'd be confident you'll find gtk+2-2.2.1 listed in there. that's what comes as standard with mandrake 9.1. if you're compiling from source on an rpm based system, then like i said above, you'll need the delveopment package for gtk, libgtk-devel.
 
Old 06-22-2003, 02:28 PM   #7
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
You are correct. GTK is there. Which is what i believed but as I sdaid earlier, Gaim doesn't believe it... is there any way of installing gaim. It's an RPM based install that fails each time saying I need gtk version 2.0.0 which makes no sense. I presme that later versions of GTK are backwards compatible?

Thanks a lot
 
Old 06-22-2003, 02:35 PM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
oh, that's rang a bit of a bell actually. think someone got stuck on that recently. am i right in thinking that if you run "rpm -ivh gaim-0.64.i586.rpm" (ish) then it says that "gtk2 = 2.0.0" is required, rather than "gtk2 >= 2.0.0"? if so then i'd suggest you got the rpm directly from the gsim.sf.net site (unless that WAS were it came from. seems that someone made a duff rpm. can't believe that it wouldn't run fine with 2.2.1 or newer.

alternatively you *should* be ok to actually force the installation (IF that is the only error you're getting). with "rpm -ivh gaim.rpm --nodeps"

isn't this thread more civilized than certain others?
 
Old 06-22-2003, 02:41 PM   #9
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
ha ha... definately :-D

and thanks for the help. Yeah, i downloaded the rpm from the gaim website. I will try the other link and let you know how it goes.

thanks
 
Old 06-22-2003, 02:44 PM   #10
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
poop... nevermind. The link "http://gsim.sourceforge.net" isn't available. Is there anywhere else I could find an RPM of a slightly older version?

Thanks
 
Old 06-22-2003, 02:48 PM   #11
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
ahh come, that was sooooo a typo!!

http://gaim.sf.net
 
Old 06-22-2003, 02:51 PM   #12
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
ha ha.. I feel dumb for not even clicking when I saw that! :-| ha ha

gaim.sf.net is where I got it from. And upon trying to install it just says that I need 2.0.0. I'm guessing there's no older rpm's lying around?

thanks
 
Old 06-22-2003, 02:54 PM   #13
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
I remember a similar faulty dependancy as acid reported, and forcing it worked. Similar story with another MSN clone, KMess. This one has working file transfers

Try rpms from the Mandrake Cooker for up-to-date Distro-official releases of software.

Last edited by Proud; 06-22-2003 at 02:56 PM.
 
Old 06-22-2003, 03:03 PM   #14
breakerfall
Member
 
Registered: Jun 2003
Location: Manchester, UK
Distribution: Gentoo
Posts: 306

Original Poster
Rep: Reputation: 30
hmmmm... forcing.

I select the rpm that I download [tried redownloading aswell] and it asks for CD 3 [international CD]... so place that in the drive, ok.

Then I see this:
"The Signature of the package 'gaim-0.64-blahblah.rpm is not correct

No GPG signature in package

Do you want to install it anyway?"


I select yes of course and another error message:

"Conflicts were detected:

gtk2 = 2.0.0 is needed by gaim-0.64-1

install aborted"


I'm guessing that gaim doesn't like anything higher than gtk 2.0.0

Thanks a lot proud. Will check out the others :-)
 
Old 06-22-2003, 03:07 PM   #15
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
You'll get the package signature warnings if you have your security setting at Higher or Paranoid iirc. You can choose which package distributors to trust by installing their encryption keys (most explain this when they provide it on their pages).
KMess doesnt use the original MSN fonts incase it's a copyright issue, but you can download 'themes' for it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile issues related to GTK, pkg-config Snivek Slackware 7 11-01-2005 10:28 AM
GTK+ Related I *think* GNOME won't load, no graphical element to RedHat 9... nutnut Linux - Software 2 02-26-2005 07:33 AM
libexif-gtk-0.3.3 dependency related error? resaguk Linux - Software 1 09-07-2004 07:49 AM
After installing qsynth, everything gtk-related stopped working purplecow Mandriva 0 09-03-2004 07:55 AM
shell script enquiry chuck77 Linux - General 3 06-12-2003 08:16 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration