LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2001, 01:45 PM   #1
3Designer
LQ Newbie
 
Registered: Nov 2001
Posts: 2

Rep: Reputation: 0
Question Another floppy mount question


Hi all!

Please bear with me on this. I've read the relevant man pages, searched and read any and all the posts I could find on this subject on more than one forum. I also tried to look it up on Google.com. I know I must've missed it somewhere but I give up, so here goes:

I have Windows 2000 Pro and Mandrake 8.1 installed on my new system. System components info (just in case it's relevant):
EPOX 8KHA+ Retail
AMD TBIRD 1.4GHZ/266 PGA AYHJA OEM
2x DDR 256MB 32X64 PC2100 Crucial = 512MB
MAXTOR DiamondMax Plus D740X 60GB Hard Drive 7200RPM ATA 133 OEM
Gainward/Cardexpert GeForce3 64MB VIVO+DVI Retail
Samsung Syncmaster 700ift 17" Monitor
CD-RW Lite-On 16x10x40 LTR-1610B Retail
DVD-ROM Lite-On 16x/48x LTD-163 Retail
Voyetra Turte Beach Santa Cruz DSP PCI OEM
Boston Acoustics BA4800 4.1 5-piece speaker set
LinkSYS LNE100TX Etherfast 10/100 LAN Card - OEM

I have Mandrake on the last 12 GBytes of my HD. I have the following partitions:

hda0: Windows 2000 C 10GB
hda1: Windows 2000 D 10GB
hda2: Windows 2000 E 28GB
hda7: /boot ~8MB
hda8: / 2GB
hda9: /var 5GB
hda10: /home 3GB
hda11: /tmp 512MB
hda12: /swap 768MB

Pretty much everything works fine except I can't mount the floppy device.

My /etc/fstab has this entry in it:

"/dev/fd0 /mnt/floppy auto
user,iocharset=iso8859-1,unmask=0,sync,exec,codepage=850,noauto 0 0"

I use the following command logged in as root:
"mount dev/fd0 /mnt/floppy"

This is the message I get:
"mount: /dev/fd0: unknown device"

The /var/log/messages file contains this entry afterwards:
"Can't locate module block-major-2"

(Obviously all without the ")

I do not know what to do next. This must be a common problem but it's new to me. Any help will be greatly appreciated.

Regards,
3Designer
 
Old 11-20-2001, 04:21 PM   #2
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
When you boot, do you see your floppy being loaded? I can't say about your fstab as mine doesn't have an entry for the floppy at all. As for mandrake, it may need one, but it could be that setup didn't find it correctly or you could check to see if floppy support is enabled in the kernel config. You could go to your /dev directory and type a ls fd* and see if there are any block devices of the type. If not you can create one using MAKEDEV. That's the only reason I can see that it would give you the error. Type man MAKEDEV and read what this option does and the options you may need. Hope this did something for you. If anything, print this message and use it for toilet paper. Make sure you use the photo gloss quality.
 
Old 11-21-2001, 08:44 AM   #3
3Designer
LQ Newbie
 
Registered: Nov 2001
Posts: 2

Original Poster
Rep: Reputation: 0
Lightbulb Found it!

taz.devil,

Thanks for your help! Just when I gave up on the problem I found the solution. Figures... It was where I should've looked first, the Mandrake Errata on their [website. Anyways, it seems there is a problem with the BIOS not configuring PnP devices. This can be remedied if I type "linux nobiospnp" at the boot prompt. The strange thing is that my BIOS even has a PnP OS setting where I can tell it if the OS should configure PnP devices or the BIOS. This was set to "Disable" which means the BIOS should take care of it but apparently it does not. I also tried "Enable" just to see what happens but it didn't cure the problem.

It'd be nice to know how to make that parameter (nobiospnp) added automagically so I wouldn't have to type it every time I reboot the computer. Does anyone know?

3Designer
 
Old 11-21-2001, 11:23 AM   #4
DFrey
LQ Newbie
 
Registered: Nov 2001
Posts: 6

Rep: Reputation: 0
Don't take my word for it, since I'm a newbie too, but I believe you can edit the lilo.conf file to add in your boot parameters.
 
Old 11-21-2001, 12:15 PM   #5
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
add this to your lilo.conf file just below the 'label=blahblah'

Code:
append="nobiospnp"
that should get things working nicely

Alex
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot mount floppy killercrazyeyes Linux - Newbie 5 04-13-2005 11:40 AM
Why can't I mount a floppy!? Talon107 Linux - Newbie 11 08-03-2004 06:09 AM
Can mount a floppy but... beginner16 Linux - Newbie 2 11-21-2003 12:53 PM
trying to mount floppy juanb Linux - General 3 01-02-2003 06:19 AM
can't mount floppy loganwva Linux - General 7 08-19-2001 12:22 AM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration