LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-03-2010, 12:29 AM   #1
meandsushil
Member
 
Registered: Feb 2010
Posts: 143

Rep: Reputation: 14
Unhappy Anonymous problem


Hi all,
I have setup ftp server with 4 users a1 a2 a3 a4

and set anonymous=YES in vsftpd.conf file

copied some files in /var/ftp/pub/ directory

gave chmod 777 /var/ftp/pub/

also made

[root@station24 ~]# getsebool -a | grep ftp
allow_ftpd_anon_write --> on
allow_ftpd_full_access --> on
allow_ftpd_use_cifs --> off
allow_ftpd_use_nfs --> off
allow_tftp_anon_write --> off
ftp_home_dir --> on
ftpd_connect_db --> off
ftpd_disable_trans --> off
ftpd_is_daemon --> on
httpd_enable_ftp_server --> off
tftpd_disable_trans --> off

but

when i login from other machine to this machine(172.16.99.24)

like

lftp anonymous@172.16.99.24

i get logged in

but when i try to put anyfile which is created in local machine in /pub/ directory i am getting permission denied message.

why this happening and what's the solution?

Last edited by meandsushil; 06-03-2010 at 12:30 AM.
 
Old 06-03-2010, 12:56 AM   #2
getviswa
LQ Newbie
 
Registered: May 2010
Posts: 23

Rep: Reputation: 0
permission

u used chmod 777 <folder>

try command chmod -R 777 <folder>

then try to put files
 
Old 06-03-2010, 01:47 AM   #3
meandsushil
Member
 
Registered: Feb 2010
Posts: 143

Original Poster
Rep: Reputation: 14
Unhappy

i tried with chmod -R 777 /var/ftp/pub/ command too.

but anonymous is not able to put files in this pub directory.


any solution.


tell me plz.
 
Old 06-03-2010, 02:15 AM   #4
sohail0399
Member
 
Registered: Oct 2008
Location: Pakistan, Islamabad
Distribution: CentOS, Fedora, Solaris
Posts: 154

Rep: Reputation: 23
check you FTP configuration file,
and also check all Anonymous settings in the same file

# Disallow anonymous users to upload new files (no = upload is allowed)

AnonymousCantUpload yes
 
Old 06-03-2010, 03:16 AM   #5
digsecurity
Member
 
Registered: Apr 2010
Posts: 54

Rep: Reputation: 18
Uncomment the line 'anon_upload_enable=YES' in vsftpd.conf, restart the service and try again. May help!!!
 
1 members found this post helpful.
Old 06-04-2010, 11:57 PM   #6
Karl Godt
Member
 
Registered: Mar 2010
Location: Kiel , Germany
Distribution: once:SuSE6.2,Debian3.1, aurox9.2+3,Mandrake?,DSL? then:W7st,WVHB, #!8.10.02,PUPPY4.3.1 now:Macpup
Posts: 308

Rep: Reputation: 45
there is a fourth number to "777" like "0777" or "7770" for the archive, group and owner bit (sticky1 setgid2 setuid4)
"anonymous" should be member of group perhaps and might be at some linuxOS also have already a number like root=0 nobody=99
(I googled for that a while ago and found some answers but do not know exactly anymore)
 
Old 06-07-2010, 04:16 AM   #7
meandsushil
Member
 
Registered: Feb 2010
Posts: 143

Original Poster
Rep: Reputation: 14
hello all I got solution
just ls at prompt
then cd /pub
then it will get any data to be uploaded
 
  


Reply

Tags
anonymous, write


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp user anonymous problem kishore.ieg Linux - Server 0 07-29-2009 02:11 AM
Problem in anonymous ftp upload sunils1973 Linux - Server 1 07-02-2009 02:16 AM
Problems with anonymous login proftp 1.3.1: 530-Unable to set anonymous priviliges. gentooox Linux - Server 3 05-03-2009 02:46 PM
Problem on running anonymous proxy satimis Linux - Security 1 09-20-2007 09:08 AM
files uploaded to anonymous ftp not readable by anonymous TheOneAndOnlySM Linux - Software 2 11-04-2004 07:42 AM


All times are GMT -5. The time now is 12:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration