LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-17-2008, 07:09 PM   #1
xichengy
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Rep: Reputation: 0
Annoying console message: Disabling IRQ #XXX.


I met a strange console message: Disabling IRQ #217 every half hour once. I search the google and put "noapic & acpi=off" in grub.conf, but it doesn't work. The message will change to "Last message repeated N times", when I singly use noapic, the warning changes to IRQ #5, when I use acpi=off, it changes to IRQ #193. Does it have any method to avoid showing this message as I know it doesn't effect the system?
 
Old 09-18-2008, 03:41 AM   #2
xichengy
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
does anyone can help?
 
Old 09-18-2008, 04:02 AM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Don't use the acpi=off boot option. That will cause more problems than it will fix. It could help during the initial installation if the install program will otherwise lock up, but on modern computers you won't have interrupt support for some of your devices if you disable acpi support.

Are normally logging in as root? I don't think other users would get these messages.

Look in /etc/syslog-ng.conf or /etc/syslog-ng/syslog-ng.conf.
Code:
# Enable this, if you want that root is informed immediately,
# e.g. of logins:
#
#destination root { usertty("root"); };
#log { source(src); filter(f_alert); destination(root); };
My system has these lines commented out. Do you have something similar which sends messages to root's tty? The "filter(...)" part may be different.
 
Old 09-18-2008, 04:07 AM   #4
xichengy
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
other user will also receive this message once half hour. Not only root user.
 
Old 09-18-2008, 07:14 PM   #5
xichengy
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
I only have syslog.conf in my /etc directory. And the code are:
# Log all kernel messages to the console.
# Logging much else clutters up the screen.
#kern.* /dev/console

# Log anything (except mail) of level info or higher.
# Don't log private authentication messages!
*.info;mail.none;authpriv.none;cron.none /var/log/messages

# The authpriv file has restricted access.
authpriv.* /var/log/secure

# Log all the mail messages in one place.
mail.* -/var/log/maillog


# Log cron stuff
cron.* /var/log/cron

# Everybody gets emergency messages
*.emerg *

# Save news errors of level crit and higher in a special file.
uucp,news.crit /var/log/spooler

# Save boot messages also to boot.log
local7.* /var/log/boot.log
 
Old 09-18-2008, 08:05 PM   #6
xichengy
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
can I use 'mesg n' to avoid seeing it? where should I put it to set it permanent?
 
Old 09-18-2008, 09:34 PM   #7
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I think this is the source:
Code:
# Everybody gets emergency messages
*.emerg *
I'm afraid that if you disable all emergency messages to all users, you may miss more important ones. You might want to look at what the root cause of the message is. Look in /var/log/messages for a matching message. Is it an emergency message?
You could put the "mesg n" in /etc/profile ( or /etc/profile.local if /etc/profile sources it ).

Run "mesg" by itself to see what the current settings are. I don't know if "mesg n" will block messages from syslog however but it's worth a try.

Last edited by jschiwal; 09-18-2008 at 09:38 PM.
 
Old 09-18-2008, 10:35 PM   #8
xichengy
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
It seems that 'mesg n' doesn't do any help. I have looked up to redirect the *.emerg to /dev/null from google and it told me that it won't make any sense.
The message in /var/log/message repeated XXX times
code:
Quote:
Sep 19 11:29:20 labrnc173 kernel: irq 217: nobody cared! (screaming interrupt?)
Sep 19 11:29:20 labrnc173 kernel: irq 217: Please try booting with acpi=off and report a bug
Sep 19 11:29:20 labrnc173 kernel: [<c0107f64>] __report_bad_irq+0x3a/0x77
Sep 19 11:29:20 labrnc173 kernel: [<c0108425>] note_interrupt+0x191/0x1b7
Sep 19 11:29:20 labrnc173 kernel: [<c010894d>] do_IRQ+0x209/0x2bf
Sep 19 11:29:20 labrnc173 kernel: [<c03198c4>] common_interrupt+0x18/0x20
Sep 19 11:29:20 labrnc173 kernel: [<c01040d6>] mwait_idle+0x32/0x40
Sep 19 11:29:20 labrnc173 kernel: [<c010408f>] cpu_idle+0x1f/0x34
Sep 19 11:29:20 labrnc173 kernel: [<c03cf700>] start_kernel+0x214/0x216
Sep 19 11:29:20 labrnc173 kernel: handlers:
Sep 19 11:29:20 labrnc173 kernel: [<c0276ce7>] (ide_intr+0x0/0x396)
Sep 19 11:29:20 labrnc173 kernel: Disabling IRQ #217
Does it mean that there is some hardware conflict with the OS? thanks
 
Old 09-19-2008, 05:45 AM   #9
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
What devices do you have plugged in? I can't boot up my computer with a flash card inserted in the slot. I can insert it afterwards.

You might try disconnecting unneeded devices such as external drives or flash devices and see if the problem persists.
Look at the output of dmesg or boot.log to see when the first indication of a problem is. Is is associated with loading a particular kernel module?

Look in the text file kernel-parameters.txt in the kernel source. There are several noacpi options that offer more granularity.
What is the make of your mobo? Does google turn up similar messages for that motherboard?

Try a different kernel version.

Look at "grep 'irq=127' /etc/modprobe.conf" and "lspci -v | grep 'IRQ 127'"

This mailing list post may help:
http://lkml.org/lkml/2006/8/3/168

It would entail recompiling your kernel enabling debugging for usb and file system access.

I was hoping the modinfo would show possible interupts for a device.
Code:
modinfo uhci_hcd
filename:       /lib/modules/2.6.25.16-0.1-default/kernel/drivers/usb/host/uhci-hcd.ko
license:        GPL
description:    USB Universal Host Controller Interface driver
author:         Linus 'Frodo Rabbit' Torvalds, Johannes Erdfelt, Randy Dunlap, Georg Acher, Deti Fliegl, Thomas Sailer, Roman Weissgaerber, Alan Stern
srcversion:     75F0FC60FEDBC418AC9D808
alias:          pci:v*d*sv*sd*bc0Csc03i00*
depends:        usbcore
supported:      yes
vermagic:       2.6.25.16-0.1-default SMP mod_unload
parm:           ignore_oc:ignore hardware overcurrent indications (bool)
I didn't know that Linus' nickname was Frodo Rabbit.

Last edited by jschiwal; 09-19-2008 at 05:52 AM.
 
Old 09-22-2008, 02:57 AM   #10
xichengy
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
this is what shown in lspci of IRQ 217, it's the sata hard disk! what should I do to disconnect this?
Code:
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Dell: Unknown device 01ad
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 217
        I/O ports at fe00 [size=8]
        I/O ports at fe10 [size=4]
        I/O ports at fe20 [size=8]
        I/O ports at fe30 [size=4]
        I/O ports at fea0 [size=16]
        Capabilities: [70] Power Management version 2
And I have tried several ways to avoid showing this message,but all failed. Is there any command can help me to prevent seeing it?As it do no harm to the system. Thanks.
 
  


Reply

Tags
irq


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error, some other host already uses address xxx.xxx,xxx,xxx ryan462 Linux - Networking 20 01-24-2010 11:14 PM
localhost kernel disabling IRQ #21 message after trying a Maxim mp3 player tethysgods Linux - Hardware 3 05-22-2008 12:14 PM
Host XXX.XXX.XXX.XXX is not allowed to connect to this MySQL server ocavid Linux - Newbie 2 03-16-2005 09:40 AM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 08:01 AM
installing Fedora Core 2- disabling IRQ #10 loop message Sardaukar Linux - Newbie 1 06-05-2004 06:55 PM


All times are GMT -5. The time now is 09:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration