LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-22-2005, 07:05 AM   #16
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101

You register the name server under your domain with your domain registrar, this is different to changing the name servers for your domain, this you will change to your newly reigistered name servers.

You need the static IP first, it is highly likely that your static IP that will be given to you will be different to the dynamic one you currently have, it will cause a bit of a headache to go round changing all the IPs later on, especially if you lose the connection whilst testing and sod's law says it wil happen.

duh, am I stupid or what! postfix is only listening on your loopback interface (127.0.0.1) you need to edit your configuration file (/etc/postfix/main.cf ?) and you need a line like
Code:
inet_interfaces = all
. Sorry for not telling you before; it never registered in my brain.

It is Okay to use ns1.fast-hosts.org as the secondary DNS server if you can change the records to match what your own DNS server says. You should not use the same machine for your secondary DNS, ideally the two DNS servers should be as physically far as part as possible, using different ISPs. Your best bet is to use ns1.fast-hosts.org or sign up with someone from this page or similar http://www.free-webhosts.com/free-dns-hosting.php.

Static IP before you before you register the name server and change the name server for your domain is a must. Of course you can set up the DNS server and test to make sure it is working and serving up test records whilst still using the dynamic IP
 
Old 07-22-2005, 08:25 AM   #17
steve007
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3
Posts: 96

Original Poster
Rep: Reputation: 15
hmm im a little confused about this registering of my name server... at first you said i need to register it with my ISP then you said to register it under my domain with my domain registrar.... this is what has been done:
1. my collegue bought a domain from UkReg
2. the defaul name servers were given as ns1.fast-hosts.org and ns2.fast-hosts.org
3. i changed the first one to be ns1.my-example.org.uk xx.xx.xx.xx
4. this has seemed to taken effect if you run the whois command for the domain i told you about, it has got it as ns1.my-example.org.uk

does this mean that is correct as it is or not then?:S im pretty confused now lol

Steve

PS.
you have been extreemly helpful and im very grateful for the support you have given me, its deffinatley been pretty clear and straight forward so thank you very much for it.
 
Old 07-22-2005, 08:47 AM   #18
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
Sorry about the confusion, I was busy with other things last night and very tired. It is definately the domain registrar you need to register the name servers with.

From what you just said it seems you change your name servers and regsiter it one step. When I did mine (with easyspace) I first had to register the name server and its IP address then I had to go and change the name servers for my domain to my newly registered name servers.

Right so you've got the name server registered and the name server for the domain changed. Next step.

When I used http://192.220.90.71/cgi-bin/DoDig to check your DNS, I entered your router's IP for the name server and your-domain.com for your domain and did a A record lookup and it timed out, didn't give me an answer. Which means BIND isn't configured properly. I've never used BIND nor webmin before so its a case of the blind leading the blind. In webmin delete all zones for BIND and we'll start again. Add a new zone 'your-domain.com' and add an A record for ns1.your-domain.com, one for mail.your-domain.com and one for your-domain.com in all three cases use your routers IP address. Then add an MX record for your-domain.com, the level can be whatever you want - 10 sounds good and the server is mail.your-domain.com. Then compile the zone and restart BIND, or follow the correct procedure to get BIND to notice and load the new zone. There might be a button in webmin to do this. Once you have done that try and query the DNS server, or reply here and I'll do it

It seems the IP for ns1.your-domain.com has not yet propogated through the rest of the world, my DNS server can't find it, nor can the http://192.220.90.71's DNS servers find it, we'll have to wait a while on that.
 
Old 07-22-2005, 09:44 AM   #19
steve007
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3
Posts: 96

Original Poster
Rep: Reputation: 15
right then, do your tests now to see if my DNS is working ok, i done it on that site you gave me and it didnt time out... thank you so much for your help.... just need to figure out how to open port 25 now.... i used the iptables command to do it but it hasnt seemed to make any difference.

cheers
 
Old 07-22-2005, 09:55 AM   #20
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
Excellent, all is well.

right now the mail server.

set up a temp user on your server and try and mail yourself
Code:
sudo useradd temp
sudo passwd temp
enter password ...
reenter...
su temp
password:
mail youruserid -s test
hello
`ctrl-d` <- key combination to end message
exit
mail
hopefully you should see the mail you just sent as the temp user, if you don't have sudo you can just `su -` to switch to root to add the user
 
Old 07-22-2005, 09:59 AM   #21
steve007
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3
Posts: 96

Original Poster
Rep: Reputation: 15
is this going to work though because it still says port 25 is closed....?
 
Old 07-22-2005, 10:40 AM   #22
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
I don't know, I am trying to find out

if it doesn't what happens if you disable the firewall and scan your ports, does it still say port 25 is closed
 
Old 07-22-2005, 10:48 AM   #23
steve007
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3
Posts: 96

Original Poster
Rep: Reputation: 15
lol, my firewall IS disabled the whole time so far.... hence the privacy i dont want it bombarded with a load of crap, the least amount of people who know about the real side of things the better, ill secure it later.
 
Old 07-22-2005, 10:55 AM   #24
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
oh thats it, I mentioned it before:

Quote:
Originally posted by phil.d.g
duh, am I stupid or what! postfix is only listening on your loopback interface (127.0.0.1) you need to edit your configuration file (/etc/postfix/main.cf ?) and you need a line like
Code:
inet_interfaces = all
. Sorry for not telling you before; it never registered in my brain.
Have you made these changes? Do so and then post `netstat -an --inet` again

remember to restart postfix
 
Old 07-22-2005, 11:09 AM   #25
steve007
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3
Posts: 96

Original Poster
Rep: Reputation: 15
I made that change ages ago... the results from two commands are as follows:

Code:
[root@sbcdc1 ~]# netstat -an --inet
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State
tcp        0      0 0.0.0.0:1025                0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:139                 0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:5900                0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:10000               0.0.0.0:*                   LISTEN
tcp        0      0 192.168.1.12:53             0.0.0.0:*                   LISTEN
tcp        0      0 127.0.0.1:53                0.0.0.0:*                   LISTEN
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN
tcp        0      0 127.0.0.1:5335              0.0.0.0:*                   LISTEN
tcp        0      0 127.0.0.1:953               0.0.0.0:*                   LISTEN
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:445                 0.0.0.0:*                   LISTEN
tcp       10      0 192.168.1.12:5900           192.168.1.20:3274           ESTABLISHED
udp        0      0 0.0.0.0:1024            0.0.0.0:*
udp        0      0 0.0.0.0:1031            0.0.0.0:*
udp        0      0 192.168.1.12:137        0.0.0.0:*
udp        0      0 0.0.0.0:137             0.0.0.0:*
udp        0      0 192.168.1.12:138        0.0.0.0:*
udp        0      0 0.0.0.0:138             0.0.0.0:*
udp        0      0 0.0.0.0:10000           0.0.0.0:*
udp        0      0 192.168.1.12:53         0.0.0.0:*
udp        0      0 127.0.0.1:53            0.0.0.0:*
udp        0      0 0.0.0.0:68              0.0.0.0:*
udp        0      0 0.0.0.0:850             0.0.0.0:*
udp        0      0 0.0.0.0:5353            0.0.0.0:*
udp        0      0 0.0.0.0:111             0.0.0.0:*
udp        0      0 0.0.0.0:631             0.0.0.0:*
Code:
[root@sbcdc1 ~]# nmap -P0 xx.xxx.xxx.x

Starting nmap 3.70 ( http://www.insecure.org/nmap/ ) at 2005-07-22 16:08 BST
Interesting ports on dialxx-xxx-xxx-x.in-addr.btopenworld.com (xx.xxx.xxx.x):
(The 1658 ports scanned but not shown below are in state: filtered)
PORT     STATE  SERVICE
25/tcp   closed smtp
3389/tcp open   ms-term-serv

Nmap run completed -- 1 IP address (1 host up) scanned in 298.949 seconds
 
Old 07-22-2005, 11:31 AM   #26
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
For some reason postfix is only listening on the loopback interface, we need it listening on eth0.

Did you initially configure this with webmin? If so is there anything on the webmin page that allows you to specify what interface postfix listens on.
 
Old 07-22-2005, 11:35 AM   #27
steve007
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3
Posts: 96

Original Poster
Rep: Reputation: 15
yea initially set it up using webmin.... i dont think there is anything there to do that.... i will have a look but i dont think you will get a response til monday as im finishing work in a moment.

i hope you have a nice weekend and ill chat again on monday. thank you very much for your help so far its been invaluable to me

Steve
 
Old 07-22-2005, 11:54 AM   #28
steve007
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3
Posts: 96

Original Poster
Rep: Reputation: 15
there was an option for what interfaces to use, it was on localhost, but i changed it onto all... but it still hasnt made a difference it still says its closed...damn
 
Old 07-22-2005, 12:05 PM   #29
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
postfix was restarted after you edited the configuration?

I know when I start to get so close to get something working I start forgetting about little things like that
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dns client cannot resolve on dns server jtvillegas Linux - Software 3 03-12-2016 04:30 PM
help needed to setup a DNS server can anyone say how to configure a DNS server subha Linux - Networking 4 04-28-2012 12:50 AM
How the DNS-server is connected to work of a web-server and a mail-server? ukrainet Linux - Newbie 2 01-10-2005 10:18 PM
Do I leave primary and seconday DNS blank for a DNS Server? imsam Linux - Networking 3 10-25-2004 02:48 PM
need help to set up caching only dns server to with bogus DNS entries ullas Linux - Networking 1 10-28-2003 02:54 PM


All times are GMT -5. The time now is 04:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration