LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-30-2003, 07:48 AM   #1
jxfdasilva
Member
 
Registered: Oct 2003
Posts: 44

Rep: Reputation: 15
Unhappy And now...


Hi there,

Since is very dificulty to realize why Mandrake doesn't recognize CD-Rom driver, and this happen only after boot the Mandrake, which means that there's not a BIOS problem. Now what I want, and since I shre tha same HD with WinXP (I creat 2 partion), I can I recovery the Linux I had already installed or How can I format the Linux Partion, and reinstall it again....withou compromize the WinXP!



Rgds


Josť

Mozambique
 
Old 10-30-2003, 09:36 AM   #2
HLVS
Member
 
Registered: Oct 2003
Location: Prague, Czech Republic
Distribution: Gentoo, FreeBSD
Posts: 37

Rep: Reputation: 15
Hi,
It's easy - you can safely do it from Windows using some partition manager (formatting) or just boot from MDK CD - it will let you choose whather you want to format existing linux partition or not (actually - i have installed mdk only once but if i remember well... )

I would suggest you not doing it and trying to fix your existing installation - you might learn something.. at first - make sure that you have your CD-ROM in /etc/fstab .. it would be also nice if you could post here what exactly does it say when you try to mount CD-ROM. Also make sure you have CD-ROM support in your kernel.
 
Old 10-30-2003, 10:18 AM   #3
jxfdasilva
Member
 
Registered: Oct 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Hi,


First of all, tnx for the support. I had Linux Mandrake9.1 installed when I decide to install windows on the same HD but in different partion. Now the windowsXP is running well but no linux no LILO!! I try to recovery Linux make the system boot from CDROM. It start well, than I must choose F1 because it doesn't run in graphic mode(??), in text mode it start detecting hardware installed and the it stop sayng cannot detect CDROM driver....????


N Idea?



Jose
 
Old 10-30-2003, 02:19 PM   #4
HLVS
Member
 
Registered: Oct 2003
Location: Prague, Czech Republic
Distribution: Gentoo, FreeBSD
Posts: 37

Rep: Reputation: 15
Hi,
for getting lilo back as boot loader you need to write it to MBR.. you can do it by booting and running as root /sbin/lilo.. of course you have to have lilo.conf set up but i suppose mdk has done it already for you.. to make sure look to lilo.conf and to man lilo. I don't personally use lilo, so i don't know much about setting it up. Hope it helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 07:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration