LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2010, 11:04 AM   #61
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0

Quote:
Originally Posted by snowpine View Post
See my post #20. You need alsa-utils installed ("sudo apt-get install alsa-utils") if you want to use alsamixer and alsaconf.
Wow! that's the first positive response I've had from terminal in a long time!!:-
~ $ sudo apt-get install alsa-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
alsa-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

Does that look right to you?
 
Old 12-07-2010, 11:08 AM   #62
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
That means you've already got alsa-utils. So why can't it find them?
 
Old 12-07-2010, 11:10 AM   #63
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,037

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
Quote:
Originally Posted by hexeta View Post
Wow! that's the first positive response I've had from terminal in a long time!!:-
~ $ sudo apt-get install alsa-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
alsa-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

Does that look right to you?
Weirder and weirder. What about:

Code:
which alsamixer
which alsaconf
That should give you the full pathname (for example /usr/bin/alsamixer) so try typing that instead of just alsamixer.

If "which" returns nothing then I don't know what to say, maybe Mint is different from other distros in how Alsa is configured and packaged?
 
Old 12-07-2010, 11:34 AM   #64
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Hi reed9, thanks for your patience!
I've cpoied and pasted the big chunk of text into leafpad, named it "soundcard_on" and attempted to save it to /usr/local/sbin, but get an error msg saying:-
"can't open file to write"!
 
Old 12-07-2010, 11:44 AM   #65
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by snowpine View Post
Weirder and weirder. What about:

Code:
which alsamixer
which alsaconf
That should give you the full pathname (for example /usr/bin/alsamixer) so try typing that instead of just alsamixer.

If "which" returns nothing then I don't know what to say, maybe Mint is different from other distros in how Alsa is configured and packaged?
here's the terminal output:-
~ $ which alsamixer
/usr/bin/alsamixer
hexeta@hexeta-desktop ~ $ which alsaconf

Is that significant!
 
Old 12-07-2010, 11:51 AM   #66
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,037

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
OK, now we are getting somewhere!

What happens when you type /usr/bin/alsamixer in the terminal? Do you see the mixer?

Also can you copy & paste the output of:

Code:
$PATH
Mine looks like this (I'm not using Mint though):

Code:
/home/snowpine/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games: No such file or directory
Note the /usr/bin which allows me to run apps like alsamixer without typing the full pathname.

If your $PATH is messed up, let me know and we can fix it. In the meantime you should be able to run apps in the terminal by typing their full pathname (determined using the "which" command).
 
Old 12-07-2010, 11:53 AM   #67
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Quote:
Originally Posted by hexeta View Post
Hi reed9, thanks for your patience!
I've cpoied and pasted the big chunk of text into leafpad, named it "soundcard_on" and attempted to save it to /usr/local/sbin, but get an error msg saying:-
"can't open file to write"!
Yes, if you're going to save it directly into /usr/local/sbin, you'll need to open the text editor as root
Code:
gksudo leafpad
My original instructions were to save it to your home directory and move it to the new location with sudo
Code:
sudo mv soundcard_on /usr/sbin/local
Note if you name it soundcard_on vs soundcard-on to change the name everywhere else in the instructions as well.
 
Old 12-07-2010, 11:53 AM   #68
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
OMG!
I've just opened /usr/bin expecting to find one entry "alsamixer"but my HDD was spinning for a good two minutes before it opened the bin....my God! it's like the Windows Sys32 folder!, it just goes on and on!
It is certainly there! That's good isn't it?
 
Old 12-07-2010, 11:58 AM   #69
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by reed9 View Post
Yes, if you're going to save it directly into /usr/local/sbin, you'll need to open the text editor as root
Code:
gksudo leafpad
My original instructions were to save it to your home directory and move it to the new location with sudo
Code:
sudo mv soundcard_on /usr/sbin/local
Note if you name it soundcard_on vs soundcard-on to change the name everywhere else in the instructions as well.
Hmm.. see what I mean!
I'm a danger to my self and all around!
OK, Ill save it to my home directory, and I'll change the name to "soundcard-on"


Just tried what you say and this is the response:-
mv: cannot stat `soundcard_on': No such file or directory

Notice that for some reason terminal command named soundcard_on not what I changed it to (-on), so I re did the command, but the result is exactly the same! what's wrong?

Last edited by hexeta; 12-07-2010 at 12:07 PM.
 
Old 12-07-2010, 11:58 AM   #70
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Quote:
Originally Posted by hexeta View Post
here's the terminal output:-
~ $ which alsamixer
/usr/bin/alsamixer
Same as Slackware. So the mystery remains, why did you get "not found" before?
Quote:
Originally Posted by hexeta View Post
hexeta@hexeta-desktop ~ $ which alsaconf
Is that significant!
Try:
Code:
whereis alsaconf
This is what I get:
Code:
bash-4.1$ whereis alsaconf
alsaconf: /usr/sbin/alsaconf /usr/man/man8/alsaconf.8.gz /usr/share/man/man8/alsaconf.8.gz /usr/X11/man/man8/alsaconf.8.gz
And it's a bash script:
Code:
bash-4.1$ file /usr/sbin/alsaconf
/usr/sbin/alsaconf: a /bin/bash script text executable

Last edited by brianL; 12-07-2010 at 12:03 PM.
 
Old 12-07-2010, 12:02 PM   #71
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,037

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
BrianL, it is a good suggestion, but I am not sure whether Mint uses alsaconf. I don't have it on my Debian machines, and Mint is based on Ubuntu which is based on Debian, so...
 
Old 12-07-2010, 12:07 PM   #72
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
I think I've always got sound OK automatically when I've run Ubuntu or Debian...not sure though, can't really remember.
 
Old 12-07-2010, 12:12 PM   #73
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
I notice that opening the properties for the "soundcard-on" file, I can tick the option to make the file executable,....would that enable me to move it to it's intended destination more successfully?
 
Old 12-07-2010, 12:16 PM   #74
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,037

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
I just booted up Linux Mint Fluxbox edition to check for you. alsaconf is neither installed nor available from the repositories. alsamixer runs OK from the terminal.

My educated guess at this point is that it's a bug specific to the LXDE edition related to the $PATH variable (see my post #66).
 
Old 12-07-2010, 12:19 PM   #75
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by brianL View Post
I think I've always got sound OK automatically when I've run Ubuntu or Debian...not sure though, can't really remember.
I might be talking a load of B*ll*x brian but as far as I have un-earthed, it's a peculiarity of the Thinkpad which has an unusual marriage of chips which confuses the hell out of most linux distro's ....or so Im lead to believe.
Story of my life I'm afraid,......if there is something that will react in an unexpected way, it must be mine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound on ThinkPad T22 Running Ubuntu 10.04 s giustizia Ubuntu 3 09-11-2010 03:02 AM
not sound on toshiba laptop running linux MINT kszabo Linux - Hardware 0 08-19-2009 03:06 PM
Sound Problem on Older Computer Running Linux Mint j1nxy06 Linux - Newbie 0 02-22-2009 12:02 PM
IBM ThinkPad, the sound works on boot, but then stops. larwana Linux - Laptop and Netbook 0 03-16-2004 01:36 PM


All times are GMT -5. The time now is 02:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration