LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2010, 10:24 AM   #1
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Rep: Reputation: 0
Ancient Thinkpad running Mint 9 cannot get sound to endure re-boot


I think the title says it all really!
I'm a total newb, and absolutely lost in the Linux environment.
with the help of others (to whom grateful thanks), I've managed to get this distro installed and my PCMCIA Wireless card working without a LAN connection!
Result......well it was for me!
next big prob is sound.......any sound at all!
This command sudo modprobe snd-cs4236 sometimes gives me some, just for the current session, if it don't want to play, it just ignores me!
Two main questions,
1) How do I get the attention of the "Alsa Mixer"? (the GUI is normally just blank and may or may not be activated by the above command!)
2) Once I have the attention of the "Alsa mixer", how do I maintain it upon re-boot?

Some one guided me to this post and despite it's age, I appended my plea for help....but I fear it is not the correct place............I just hope I'm now in the right place!
http://www.linuxquestions.org/hcl/sh...hp/product/132
 
Old 12-06-2010, 10:38 AM   #2
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,432

Rep: Reputation: 196Reputation: 196
From a terminal as root, type this command:

Code:
# alsamixer
Press escape to get out . To store the new settings, again, in a terminal as root, type:

Code:
# alsactl store
 
Old 12-06-2010, 10:38 AM   #3
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,184

Rep: Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168
I would suggest opening a Terminal (usually under Applications->Accessories or System Tools, not sure how Mint is structured) and running the following commands:

Code:
alsamixer
That should allow you to adjust your mixer settings.

Code:
sudo alsactl store
That should save the settings for next time.

As far as your module issue, that should be solvable by adding snd-cs4236 to /etc/modules
 
Old 12-06-2010, 11:47 AM   #4
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Thanks guys for such a fast response.....I must have set something wrongly, 'cos I'm not getting any email advice of posts!

Because I don't know how to open a terminal as "root", I can't follow mlangdn's advice.
Tried that posted by snowpine with the following response from terminal: -
~ $ alsamixer
cannot open mixer: No such file or directory.
~ $ sudo alsactl store
alsactl: save_state:1502: No soundcards found...

Quote:
Originally Posted by snowpine
As far as your module issue, that should be solvable by adding snd-cs4236 to /etc/modules
What?...just typing it as an extra line on the existing page??

On my travels around t' internet today, I found this: -
http://www.thinkwiki.org/wiki/Script...ip_in_PnP_mode but no idea if it is the right thing for my machine, or how to execute it.
I've asked for a helping hand there but no response so far

Just checked my settings and they are showing that I'm subsribed to this thread, and emails are enabled.....but it ain't happening!
I'll keep checking back regularly so I don't miss any one's posts!
Could do with Mod's attention to this problem.

Last edited by hexeta; 12-06-2010 at 12:18 PM. Reason: just to confirm my settings are correct but not working
 
Old 12-06-2010, 12:19 PM   #5
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,184

Rep: Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168
On further investigation, it looks like Mint (since it is based on Ubuntu) probably uses PulseAudio instead of ALSA; that could explain the "cannot open alsamixer" error.

Sorry but I have no experience with PulseAudio.

/etc/modules is just a text file, you can edit it with "gksu gedit /etc/modules" and simply add a new line at the bottom for your sound module. (Unless Mint has some different/fancy way of doing things...)

Last edited by snowpine; 12-06-2010 at 12:20 PM.
 
Old 12-06-2010, 12:30 PM   #6
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Thanks snowpine, but Mint 9 Lxde comes with Alsa mixer "out of the box" as they say!

PS: still no email notifications!
Where are the Mods??

Last edited by hexeta; 12-06-2010 at 12:32 PM.
 
Old 12-06-2010, 12:43 PM   #7
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,184

Rep: Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168
Quote:
Originally Posted by hexeta View Post
Thanks snowpine, but Mint 9 Lxde comes with Alsa mixer "out of the box" as they say!
I stand corrected, sorry.

Does it make a difference if you "sudo modprobe snd-cs4236" first?
 
Old 12-06-2010, 01:05 PM   #8
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by hexeta View Post
Thanks snowpine, but Mint 9 Lxde comes with Alsa mixer "out of the box" as they say!

PS: still no email notifications!
Where are the Mods??
Hi there!

We got your report about the email notifications. Here's what I suggest, assuming your email address is correct and is the one you subscribed with:

1) Go to My Subscribed Threads" and click the checkbox beside this thread. Scroll to the bottom of the page, and using the little drop-down menu, select "Email Notification" and hit GO. That should fix it for this thread.

2) Go to your UserCP Edit Options" and scroll into the "Messaging and Notification" area and set your "Default Thread Subscription Mode" to whatever you desire. Scroll to the bottom of that page and select "Save Changes".

If this doesn't fix the issue, please contact me again by PM or email, and I'll look into this further.

Kind regards.
Sasha
 
Old 12-06-2010, 01:09 PM   #9
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by snowpine View Post
Does it make a difference if you "sudo modprobe snd-cs4236" first?
That's the command that I was told to use to kick start Alsa, because when it opens normally the GUI is just blank.
clicking on edit>Prog. prefs. brings up another window with some slider prefs.
edit>Sound card prefs. however just makes the whole thing disappear.

sometimes when I used "sudo modprobe snd-cs4236" it would unlock the GUI, other times it didn't...on those occasions, it was "listed" by Terminal as "used by 0 (Zero)".
On those occasions, I can't make it work at all.
Even when it does work, it dies when I shut down....but at least I now know that it should work
 
Old 12-06-2010, 01:12 PM   #10
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,184

Rep: Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168
I don't understand your comments about "unlocking the GUI." Alsamixer is a terminal application. There is no clicking involved.
 
Old 12-06-2010, 01:15 PM   #11
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Quote:
Originally Posted by hexeta View Post
Thanks guys for such a fast response.....I must have set something wrongly, 'cos I'm not getting any email advice of posts!

Because I don't know how to open a terminal as "root", I can't follow mlangdn's advice.
Tried that posted by snowpine with the following response from terminal: -
~ $ alsamixer
cannot open mixer: No such file or directory.
~ $ sudo alsactl store
alsactl: save_state:1502: No soundcards found...


What?...just typing it as an extra line on the existing page??
You shouldn't run alsamixer as root. alsactl store is run with root privs, which you are doing by prefacing it with "sudo". It's saying there is no file or directory mixer? Sounds like you maybe didn't write alsamixer as all one word?

Yes, /etc/modules is just a text file. Adding the module name will force the module to load at boot. You can do so with any text editor (run with root privileges) or append as so from the terminal
Code:
echo "snd-cs4236" | sudo tee -a /etc/modules
 
Old 12-06-2010, 01:17 PM   #12
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Quote:
Originally Posted by snowpine View Post
I don't understand your comments about "unlocking the GUI." Alsamixer is a terminal application. There is no clicking involved.
I assume the GUI referred to is the mixer GUI. Am I right in that if you don't load the module, the mixer is blank, when you load the module, it shows the normal mixer channels?
 
Old 12-06-2010, 01:49 PM   #13
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,432

Rep: Reputation: 196Reputation: 196
The sound card may not be configured. If that's the case, run:

Code:
# alsaconf
That does have to be ran as root.

Alsa will then configure your sound and load the proper module.
 
Old 12-06-2010, 02:15 PM   #14
hexeta
Member
 
Registered: Dec 2010
Location: Northwest UK
Distribution: Currently; Mint 9 Lxde
Posts: 87

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by snowpine View Post
I don't understand your comments about "unlocking the GUI." Alsamixer is a terminal application. There is no clicking involved.
No, this is the blank GUI, and it shows the Programme preferences that I have described
When it's working right, the GUI has 8/10 slider controls for the various inputs and the master volume control
http://i53.tinypic.com/nnkwo7.jpg
 
Old 12-06-2010, 02:19 PM   #15
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,184

Rep: Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168Reputation: 1168
I am not familiar with "GNOME ALSA Mixer" and cannot help you with it, sorry.

I am still unclear on what happens when you enter the following sequence of commands into the terminal (use copy & paste to avoid typos):

Code:
sudo modprobe snd-cs4236
alsamixer
sudo alsactl store
Please copy & paste the output of these commands if you would like my further assistance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound on ThinkPad T22 Running Ubuntu 10.04 s giustizia Ubuntu 3 09-11-2010 02:02 AM
not sound on toshiba laptop running linux MINT kszabo Linux - Hardware 0 08-19-2009 02:06 PM
Sound Problem on Older Computer Running Linux Mint j1nxy06 Linux - Newbie 0 02-22-2009 11:02 AM
IBM ThinkPad, the sound works on boot, but then stops. larwana Linux - Laptop and Netbook 0 03-16-2004 12:36 PM


All times are GMT -5. The time now is 05:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration