LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-20-2008, 11:32 PM   #1
bittus
Member
 
Registered: Aug 2006
Posts: 153

Rep: Reputation: 15
Question amavis installation error


Hi,

I am trying to install Amavisd to integrate it with postfix. But when i try to compile amavis I endup in some errors:

[root@xxxxxx amavisd-0.1]# ./configure --enable-postfix
creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for mawk... no
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking whether make sets ${MAKE}... (cached) yes
checking for a BSD compatible install... /usr/bin/install -c
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for perl... /usr/bin/perl
checking for perl modules...
module not found in path: 'MIME/Parser/Filer'.
module not found in path: 'Unix/Syslog'.
module not found in path: 'Mail/Header'.
module not found in path: 'Convert/UUlib'.
module not found in path: 'Convert/TNEF'.
module not found in path: 'Compress/Zlib'.
module not found in path: 'Archive/Tar'.
module not found in path: 'Archive/Zip'.
configure: error: You are missing some perl modules. Please check the README


Can anyone help me on this issue . . . . . .

Last edited by bittus; 02-21-2008 at 01:56 AM. Reason: mis-spelled amavis as amvis
 
Old 02-21-2008, 12:43 AM   #2
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Did you check the README for required perl modules? The error message is pretty clear isn't it?

From the INSTALL file on amavisd-new's home page

Quote:
Prerequisites:
==============

file(1) utility is required, the most recent version is heartly recommended!
There are a number of security and robustness problems with earlier versions.
Use file(1) version 4.23 or later to avoid known vulnerabilities.

Archive::Zip (Archive-Zip-x.xx) (1.14 or later should be used!)
Compress::Zlib (Compress-Zlib-x.xx) (1.35 or later)
Convert::TNEF (Convert-TNEF-x.xx)
Convert::UUlib (Convert-UUlib-x.xxx) (1.08 or later, stick to new versions!)
MIME::Base64 (MIME-Base64-x.xx)
MIME::Parser (MIME-Tools-x.xxxx) (latest version from CPAN - currently 5.425)
Mail::Internet (MailTools-1.58 or later have workarounds for Perl 5.8.0 bugs)
Net::Server (Net-Server-x.xx) (version 0.88 finally does setuid right)
Digest::MD5 (Digest-MD5-x.xx) (2.22 or later)
IO::Stringy (IO-stringy-x.xxx)
Time::HiRes (Time-HiRes-x.xx) (use 1.49 or later, older can cause problems)
Unix::Syslog (Unix-Syslog-x.xxx)
BerkeleyDB with bdb library 3.2 or later (4.2 or later preferred)
Mail:KIM (Mail-DKIM-0.29 or later)
 
Old 02-21-2008, 01:06 AM   #3
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
But the funny thing is tat I installed amavisd succesfully before. All these happened when I tried to reinstall amavisd.

This is making me confused . . . .
 
Old 02-21-2008, 01:13 AM   #4
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You should be able to install these pretty easily with cpan
 
Old 02-21-2008, 01:52 AM   #5
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
I did it with CPAN and got cleared tat error.

But now new error generated . . . .

Quote:
checking for lha... no
configure: error: Sorry, you need lha

Last edited by bittus; 02-21-2008 at 01:53 AM.
 
Old 02-21-2008, 05:41 AM   #6
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You shouldn't need lha, it's a "use it if it's there decoder", but anyway, you could have found this in the INSTALL file had you read it

lha: http://www2m.biglobe.ne.jp/~dolphin/lha/lha.htm

So you can get it from there if not somewhere else.

I found this on my search of google, after it referred me to freshmeat

http://www.infor.kanazawa-it.ac.jp/~ishii/lhaunix/

This is easier to read (at least for me)
 
Old 02-21-2008, 05:51 AM   #7
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Sorry - are you using amavisd and not amavisd-new? Isn't amavisd quite out of date nowadays?
 
Old 02-22-2008, 02:50 AM   #8
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
billymayday, thanks a lot for your support.

I installed amavisd-new and it is working fine now . . . . .

Appreciate your service.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation of Binutils(configure:error:installation or configuration problem:C ...) h_r0019 Linux From Scratch 1 05-05-2007 07:40 AM
xen installation error: error 13: invalid or unsupported executable format Niceman2005 Linux - Software 0 01-05-2007 01:51 AM
Error on Fedora core 4 installation - Error informing the kernal about modifications monolegis Fedora 2 02-15-2006 06:11 PM
Error 219. Error running jifyboot during installation jfi Linspire/Freespire 10 12-14-2004 09:49 AM
installation error: Error mounting sda1: Invalid Argument sadirmata Linux - Newbie 1 01-29-2002 02:28 AM


All times are GMT -5. The time now is 08:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration