LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-11-2007, 10:38 PM   #1
Guilherme
Member
 
Registered: Jul 2006
Posts: 83

Rep: Reputation: 15
aMSN and LibTCL8.4


Hello.
One thing I would like to have in MSN (actualy i am using kopete) is the microphone and webcam functionality, so I saw somewhere that aMSN can make it...
I decided to download it and compile it ...
Acording with the dependencies I compiled TCL8.4 and TK8.4, everything ok untill here, although with TK I couldn't compile it, anyway I used RPM (it worked nicely). I runned "./configure && make && make install" as well as and it finish well... so I runned the same command to aMSN and everything ok ...
But, when I run "amsn" this is reported to me:
Code:
Application initialization failed: Can't find a usable init.tcl in the following directories:
    /usr/lib/tcl8.4 /usr/lib/tcl8.4 /lib/tcl8.4 /usr/library /library /tcl8.4.11/library /usr/lib/tcl8.4



This probably means that Tcl wasn't installed properly.

Error in startup script: can't find package Tk
    while executing
"package require Tk"
    (file "/usr/bin/amsn" line 48)
I am actualy unsing Mandriva 2006 with KDE.

I gone to /lib directory, maybe the libtcl could be something like libtcl8.4 .. but there is nothing at all...

could you help me please? how can I fix it

Thanks
 
Old 06-12-2007, 04:00 AM   #2
DiBosco
Member
 
Registered: Nov 2001
Location: Manchester, UK
Distribution: Mageia 4
Posts: 741

Rep: Reputation: 35
My understanding is aMSN will only work with cam and not mic. The bleeding edge stuff which has best cam support is the svn stuff, youd be best off installing that if you can work out how to compile and not just install an rpm. I'm using aMSN on 2007.1 and the cam works very well. Hopefully they'll add audio.

On the tcl issue, I had this too on one of my installations. IIRC, I went to control centre | software manager and installed a tcl-devel rpm which did the trick. I found this after much Googling!
 
Old 06-12-2007, 10:46 AM   #3
Guilherme
Member
 
Registered: Jul 2006
Posts: 83

Original Poster
Rep: Reputation: 15
ok ... it is working... thank you a lot..

By the way, I tryed to use Skype and it reports me soundcard error when I try to make a call... althohg it worked before, a long time ago with other Mandriva instalation.
The application detects the card "Creative Sound Blaste Live!" on all the ways, input/output and alarms...
For sometime ago I had this error when I was trying to record a sound "Device /dev/dsp does not exists" ... I googled a lot and nothing...

What is this??

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in gcvs(libtcl8.4.so is missing) Rajesh kumar P K Linux - Software 1 05-07-2007 08:32 PM
amsn profile being used by another amsn session aeruzcar Linux - Software 2 01-28-2006 03:23 PM
libtcl8.3.so Ermen Linux - Software 1 11-16-2004 08:53 AM
rpm cant find libtcl or libtk but there is libtcl8.* arkamir Linux - Software 1 12-19-2003 04:13 PM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration