LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2008, 02:50 AM   #1
ks.sundarrajan
LQ Newbie
 
Registered: Mar 2008
Posts: 13

Rep: Reputation: 0
Amaya Installation


Can any one help me install amaya 10.1 on fedora 8.
I tried amaya forum but no one gave me executeable answers. I get a lot of errors but not able to solve it. Can any one give me a manual or a link which has the complete installation steps from start to end. I downloaded the 27.3 Mb source file.
I also have the rpm of amaya 8.7 but it asks for lots of dependencies as below....

rpm -i amaya-8.7-1.2.el4.rf.x86_64.rpm
warning: amaya-8.7-1.2.el4.rf.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
error: Failed dependencies:
libX11.so.6()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libXext.so.6()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libXi.so.6()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libc.so.6()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libdl.so.2()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libgcc_s.so.1()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libgdk-1.2.so.0()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libgdk_imlib.so.1()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libglib-1.2.so.0()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libgmodule-1.2.so.0()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libgtk-1.2.so.0()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libjpeg.so.62()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libm.so.6()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libm.so.6(GLIBC_2.2.5)(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libpng12.so.0()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libstdc++.so.6()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64
libz.so.1()(64bit) is needed by amaya-8.7-1.2.el4.rf.x86_64


Thanks in advance
 
Old 03-18-2008, 03:04 AM   #2
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 35
Did you try building from the source you downloaded?
 
Old 03-18-2008, 04:32 AM   #3
ks.sundarrajan
LQ Newbie
 
Registered: Mar 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Amaya Installation

yes, i created a folder called linux inside the Amaya10.0/Amaya directory

executed this command : ../configure inside the linux directory.

I did not get any errors here.

Next step was to execute the gmake all command which i did and got the below errors:
Code:
In file included from ../../annotlib/annotlib.h:24,
                 from ../../annotlib/ANNOTevent.c:20:
../../amaya/amaya.h:35:20: error: MathML.h: No such file or directory
../../amaya/amaya.h:36:17: error: SVG.h: No such file or directory
gmake[1]: *** [ANNOTevent.o] Error 1
gmake[1]: Leaving directory `/usr/local/Amaya10.0/Amaya/linux/annotlib'
gmake[1]: Entering directory `/usr/local/Amaya10.0/Amaya/linux/davlib'
/bin/sh: line 0: cd: ../libwww/Library/src: No such file or directory
gmake[2]: Entering directory `/usr/local/Amaya10.0/Amaya/linux/davlib'
gmake[2]: *** No rule to make target `HTHome.o'.  Stop.
gmake[2]: Leaving directory `/usr/local/Amaya10.0/Amaya/linux/davlib'
gmake[1]: *** [HTHome] Error 2
gmake[1]: Leaving directory `/usr/local/Amaya10.0/Amaya/linux/davlib'
gmake[1]: Entering directory `/usr/local/Amaya10.0/Amaya/linux/amaya'
gmake[2]: Entering directory `/usr/local/Amaya10.0/Amaya/linux'
checking build system type... i686-redhat-linux-gnu
checking host system type... i686-redhat-linux-gnu
checking target system type... i686-redhat-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
configure: error: source directory already configured; run "make distclean" there first
libwww is configured
patching wwwconf.h because appkit.h do not compile on macos, and it seems that appkit.h is not used in amaya
wwwconf.h patched !
/bin/sh: line 1: cd: libwww/modules/md5: No such file or directory
gmake[3]: Entering directory `/usr/local/Amaya10.0/Amaya/linux'
gmake[3]: *** No rule to make target `libmd5.la'.  Stop.
gmake[3]: Leaving directory `/usr/local/Amaya10.0/Amaya/linux'
gmake[2]: *** [libwww_make_module_md5] Error 2
gmake[2]: Leaving directory `/usr/local/Amaya10.0/Amaya/linux'
gmake[1]: *** [amaya_comp_libwww] Error 2
gmake[1]: Leaving directory `/usr/local/Amaya10.0/Amaya/linux/amaya'
and the execution stops here.
I did not understand why this error came.

Thanks in advance

Last edited by ks.sundarrajan; 03-18-2008 at 04:34 AM.
 
Old 03-18-2008, 04:50 AM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
http://www.w3.org/Amaya/User/BinDist.html

Get Fedora8 rpm, rpm -ivh amaya(etc.)

I just installed it on my system. No problem whatsoever even though I am running a 64 bit Fedora.

But: if you install a 64 bit rpm on a 32 bit system, you can only expect to see a lot of dependency issues. Basically, you don't have any of the required 64 bit libs. The error messages you posted seem to imply that you have a 32 bit system, yet your rpm is 64 bit.

Last edited by jay73; 03-18-2008 at 04:53 AM.
 
Old 03-18-2008, 05:44 AM   #5
ks.sundarrajan
LQ Newbie
 
Registered: Mar 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Amaya Installation

Perfect.....

Thankz a lot ...

As u posted, i downloaded the rpm amaya_wx from the given link and executed the rpm command and the installtion was finished in just 10 seconds.

Thanks for every one who tried to help me on this.

Thanks again jay

Bye take care

Last edited by ks.sundarrajan; 03-18-2008 at 05:45 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
amaya opening error sri_ram1982 Linux - Software 1 12-21-2007 03:28 AM
Amaya....Dreamweaver killer? psychobyte Linux - Desktop 0 02-07-2007 06:18 PM
Amaya Compiling Error alkos333 Slackware 5 01-19-2007 02:18 PM
Amaya and conflicts linda SUSE / openSUSE 3 09-20-2005 02:39 AM
Amaya web editor - how do I......... bigjohn Linux - Software 12 09-05-2004 04:21 PM


All times are GMT -5. The time now is 12:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration