LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-03-2006, 10:14 AM   #1
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Rep: Reputation: 30
Amarok 1.4 Wont let me install!


Hi i've downloaded both the the amarok 1.4 rpm and the libamarok rpms but for some reason when i double click it i get the following message:

Some package requested cannot be installed:

amarok-1.4.0-1.1.20060mdk.i586 (due to unsatisfied libamarok0[==1/4/0])

when i try installing the libamarok rpm i get the same but with

libamarok0-1.1.0-1.1.20060mdk.i586 (due to unsatisfied amarok [== 1.4.0-1.1..20060mdk])


Any ideas? is it asking me to somehow install them together?
 
Old 07-03-2006, 05:41 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Try urpmi amarok-1.4.0-1.1.20060mdki.586-mdk.rpm from the cli.
Good luck.
 
Old 07-04-2006, 05:26 PM   #3
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Original Poster
Rep: Reputation: 30
no luck:

[root@localhost My Downloads]# urpmi amarok-1.4.0-1.1.20060mdk.i586.rpm
Some package requested cannot be installed:
amarok-1.4.0-1.1.20060mdk.i586 (due to unsatisfied libamarok0[== 1.4.0])
Continue? (Y/n) y
[root@localhost My Downloads]#
 
Old 07-06-2006, 10:29 AM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
How about trying the -- nodeps argument.
Good luck.
 
Old 07-06-2006, 03:26 PM   #5
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Rep: Reputation: 135Reputation: 135
put all the necessary rpm packages into a folder, and then run from console as root urpmi *.rpm (after having navigated into that folder). This will permit you to see the dependencies on other packages, and to find those you could use pbone.net

Thats how I did, on the same distro, ,and it worked perfectly.

Good Luck
 
Old 07-07-2006, 06:02 PM   #6
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Original Poster
Rep: Reputation: 30
I'm sinking deeper and deeper into dependancies:

I thought i found what amarok is craving for (libgpod) but i get this when i put them all in the same directory:

[root@localhost Amarok1.4]# urpmi *.rpm
Some package requested cannot be installed:
amarok-1.4.0-1.1.20060mdk.i586 (due to unsatisfied libgpod.so.0)
libamarok0-1.4.0-1.1.20060mdk.i586 (due to missing amarok-1.4.0-1.1.20060mdk.i586)
libgpod0-devel-0.3.0-0.1.20060mdk.i586 (due to unsatisfied libgpod0[== 0.3.0])
Continue? (Y/n)


looking in pbone.net , it says that libgpod0 should have libspod.so.0 (i've doubled clicked on it and installed it manually) i'm still baffle by the first two lines , surely they contradict lol

i think i'm going to try finding an earlier release of 1.4 maybe i just downladed a dud.
 
Old 07-07-2006, 06:57 PM   #7
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Original Poster
Rep: Reputation: 30
sorry, made a mistake, installed libgpod not libpod0 lol

after loading a whole bunch of dependancies manually (ouch) , its installed.

there doesnt seem to be a 1.4.0 version of amarok-engine-arts or gstreamer , the xine engine never works on my install, it always says "xine was unable to initialise any audio-drivers"!

doing a urpmi search gives a lot of possible packages and i dont know whuch one solves this problem.

arts engine worked fine in the amarok 1.3. never worried about why xine didnt till now

Last edited by Maverick1182; 07-07-2006 at 07:11 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Amarok wont play this shoutcast stream tony_stevens Linux - General 0 06-05-2006 02:24 PM
i want to install newer amarok to install amarok xine engine amolgupta Linux - Software 1 04-24-2006 06:24 AM
amarok wont go away..... picturefixer Ubuntu 1 01-18-2006 08:16 PM
amarok wont start in Slackware jaakkop Linux - Software 1 07-17-2005 04:16 AM
I am a newbie and I really like the Amarok media p but it wont play kiam Linux - Newbie 4 07-09-2005 12:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration